ifenslave_2.7ubuntu1_all.deb


Advertisement

Description

ifenslave - configure network interfaces for parallel routing (bonding)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename ifenslave_2.7ubuntu1_all.deb
Package name ifenslave
Package version 2.7ubuntu1
Package release -
Package architecture all
Package type deb
Category net
Homepage -
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 13.05 KB
Installed size 87.00 KB
This is a tool to attach and detach slave network interfaces to a bonding
device. A bonding device will act like a normal Ethernet network device to
the kernel, but will send out the packets via the slave devices using a simple
round-robin scheduler. This allows for simple load-balancing, identical to
"channel bonding" or "trunking" techniques used in switches.
The kernel must have support for bonding devices for ifenslave to be useful.
This package supports 2.6.x kernels and the recent 3.x.x kernels.

Alternatives

Package Version Architecture Repository
ifenslave_2.7ubuntu1_all.deb 2.7ubuntu1 all Ubuntu Main
ifenslave - - -

Requires

Name Value
ifupdown >= 0.7.46
iproute2 -

Replaces

Name Value
ifenslave-2.6 << 1.1.0-22

Download

Type URL
Mirror archive.ubuntu.com
Binary Package ifenslave_2.7ubuntu1_all.deb
Source Package ifenslave

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ifenslave deb package:
    # sudo apt-get install ifenslave

Files

Path
/etc/network/if-post-down.d/ifenslave
/etc/network/if-pre-up.d/ifenslave
/etc/network/if-up.d/ifenslave
/sbin/ifenslave
/sbin/ifenslave-2.6
/usr/share/doc/ifenslave/README.Debian.gz
/usr/share/doc/ifenslave/changelog.gz
/usr/share/doc/ifenslave/copyright
/usr/share/doc/ifenslave/examples/ethernet+hotplug_wifi
/usr/share/doc/ifenslave/examples/two_hotplug_ethernet
/usr/share/man/man8/ifenslave-2.6.8.gz
/usr/share/man/man8/ifenslave.8.gz

Changelog

2015-07-24 - Louis Bouchard <louis.bouchard@ubuntu.com>
ifenslave (2.7ubuntu1) wily; urgency=medium
* Merge from Debian unstable. Remaining changes:
- Upstart event based bond bringup:
+ Drop ethernet+wifi example
+ Drop two_ethernet example
+ Update ethernet+hotplug_wifi example
+ Update two_hotplug_ethernet example
+ Update pre-up and post-down scripts for event bringup
+ Update README.Debian examples
- Update scripts to use /run/network/ifstate instead of
/etc/network/run/ifstate
(LP: #1477928)
2015-07-13 - Dmitry Smirnov <onlyjob@debian.org>
ifenslave (2.7) unstable; urgency=low
* Fix change in /sys/class/net/{bond}/slave_ naming after k3.13
(Closes: #791906). Thanks, Louis Bouchard.
* Standards-Version: 3.9.6.
2014-08-31 - Dmitry Smirnov <onlyjob@debian.org>
ifenslave (2.6) unstable; urgency=low
* Added support for "packets_per_slave" option in interface stanza
(Closes: #758913); Thanks, John Holland.
* README.Debian:
+ added note regarding "udev renaming issue".
+ added "see also" note with link to "Bonding" section of wiki.
2014-05-02 - St├ęphane Graber <stgraber@ubuntu.com>
ifenslave (2.5ubuntu1) utopic; urgency=medium
* Merge from Debian unstable. Remaining changes:
- Upstart event based bond bringup:
+ Drop ethernet+wifi example
+ Drop two_ethernet example
+ Update ethernet+hotplug_wifi example
+ Update two_hotplug_ethernet example
+ Update pre-up and post-down scripts for event bringup
+ Update README.Debian examples
- Update scripts to use /run/network/ifstate instead of
/etc/network/run/ifstate
2014-03-24 - Dmitry Smirnov <onlyjob@debian.org>
ifenslave (2.5) unstable; urgency=low
* "ifupdown (>= 0.7.46)" compatibility update (Closes: #742410).
Thanks to Andrew Shadura.
* Added versioned Depends on "ifupdown (>= 0.7.46)".
2014-03-03 - St├ęphane Graber <stgraber@ubuntu.com>
ifenslave (2.4ubuntu1) trusty; urgency=medium
* Re-apply Ubuntu delta to new source.
2014-02-11 - Dmitry Smirnov <onlyjob@debian.org>
ifenslave (2.4) unstable; urgency=medium
* Added "ifenslave-2.6.prerm" to remove dangling alternatives
(Closes: #736668).
Thanks to Andreas Beckmann.
2014-01-17 - Dmitry Smirnov <onlyjob@debian.org>
ifenslave (2.3) unstable; urgency=medium
* Added transitional package "ifenslave-2.6" and corresponding
Breaks/Replaces (Closes: #735614).
Thanks, Andreas Beckmann.
2014-01-12 - Dmitry Smirnov <onlyjob@debian.org>
ifenslave (2.2) unstable; urgency=medium
* Rebase on top of "ifenslave-2.6 (1.1.0-21)".
* Added retrospective changelog entry.
* Removed obsolete lintian-override.
* Removed "${shlibs:Depends}" from Depends.
2013-11-10 - Dmitry Smirnov <onlyjob@debian.org>
ifenslave (2.1) unstable; urgency=low
[ Dmitry Smirnov ]
* Package and binary renamed to "ifenslave"
* No longer provide alternatives but still ship ifenslave-2.6
(symlink) for backward compatibility.
* Converted to native package; added lintian-override.
* Updated package description.
* "debian/copyright" to copyright-format-1.0.
* Debhelper & compat to version 9.
* Standards to 3.9.5.
* Source package compression to ".xz".
* Removed obsolete ifenslave-2.4 from Conflicts.
* Depend on "iproute2" instead of transitional "iproute" (Closes: #715382).
* Added "ifupdown" to Depends.
* Multi-Arch: foreign.
* Added VCS links.
* Added myself to Uploaders.
[ Guus Sliepen ]
* Replace ifenslave binary with a tiny shell script.
* Let dh_installifupdown install the if-up/down scripts.
* Conflict with ifenslave-2.6.
* Change license of everything to GPL-3+.

See Also

Package Description
ifupdown_0.8.10ubuntu1_amd64.deb high level tools to configure network interfaces
im-config_0.29-1ubuntu12_all.deb Input method configuration framework
imagemagick-6.q16_6.8.9.9-7ubuntu5_amd64.deb image manipulation programs -- quantum depth Q16
imagemagick-common_6.8.9.9-7ubuntu5_all.deb image manipulation programs -- infrastructure
imagemagick-doc_6.8.9.9-7ubuntu5_all.deb document files of ImageMagick
imagemagick_6.8.9.9-7ubuntu5_amd64.deb image manipulation programs -- binaries
indent-doc_2.2.11-4_all.deb Documentation for GNU indent
indent_2.2.11-4_amd64.deb C language source code formatting program
indicator-application_12.10.1+15.04.20150128-0ubuntu1_amd64.deb Application Indicators
indicator-appmenu_15.02.0+16.04.20151104-0ubuntu1_amd64.deb Indicator for application menus
indicator-bluetooth_0.0.6+16.04.20160214-0ubuntu1_amd64.deb System bluetooth indicator
indicator-datetime_15.10+16.04.20160406-0ubuntu1_amd64.deb Simple clock
indicator-keyboard_0.0.0+16.04.20151125-0ubuntu1_amd64.deb Keyboard indicator
indicator-messages_13.10.1+15.10.20150505-0ubuntu1_amd64.deb indicator that collects messages that need a response
indicator-power_12.10.6+16.04.20160105-0ubuntu1_amd64.deb Indicator showing power state
Advertisement
Advertisement