idle-python3.5_3.5.1-10_all.deb


Advertisement

Description

idle-python3.5 - IDE for Python (v3.5) using Tkinter

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename idle-python3.5_3.5.1-10_all.deb
Package name idle-python3.5
Package version 3.5.1
Package release 10
Package architecture all
Package type deb
Category python
Homepage -
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 34.85 KB
Installed size 189.00 KB
IDLE is an Integrated Development Environment for Python (v3.5).
IDLE is written using Tkinter and therefore quite platform-independent.

Alternatives

Package Version Architecture Repository
idle-python3.5_3.5.2-2ubuntu0~16.04.5_all.deb 3.5.2 all Ubuntu Updates Main
idle-python3.5_3.5.2-2ubuntu0~16.04.5_all.deb 3.5.2 all Ubuntu Updates Main
idle-python3.5_3.5.1-10_all.deb 3.5.1 all Ubuntu Main
idle-python3.5 - - -

Requires

Name Value
python3-tk -
python3.5 -
python3.5-tk -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package idle-python3.5_3.5.1-10_all.deb
Source Package python3.5

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install idle-python3.5 deb package:
    # sudo apt-get install idle-python3.5

Files

Path
/usr/bin/idle-python3.5
/usr/share/applications/idle-python3.5.desktop
/usr/share/doc/idle-python3.5/NEWS.txt
/usr/share/doc/idle-python3.5/README.Debian
/usr/share/doc/idle-python3.5/README.txt
/usr/share/doc/idle-python3.5/TODO.txt
/usr/share/doc/idle-python3.5/changelog.Debian.gz
/usr/share/doc/idle-python3.5/copyright
/usr/share/doc/idle-python3.5/extend.txt
/usr/share/lintian/overrides/idle-python3.5
/usr/share/man/man1/idle-python3.5.1.gz

Changelog

2016-03-31 - Matthias Klose <doko@debian.org>
python3.5 (3.5.1-10) unstable; urgency=medium
* Update to 20160330 from the 3.5 branch.
2016-03-23 - Matthias Klose <doko@debian.org>
python3.5 (3.5.1-9) unstable; urgency=medium
* Update to 20160323 from the 3.5 branch.
* Always build _math.o with -fPIC.
2016-03-18 - Matthias Klose <doko@debian.org>
python3.5 (3.5.1-8) unstable; urgency=medium
* Update to 20160318 from the 3.5 branch.
* Fix python3-venv with updated python-pip packages (Barry Warsaw).
Closes: #815014, #815864.
* Fix generating devhelp documentation (Simon McVittie).
Closes: #816299. LP: #1553633.
2016-02-24 - Matthias Klose <doko@debian.org>
python3.5 (3.5.1-7) unstable; urgency=medium
* Update to 20160224 from the 3.5 branch.
* python3.5-venv: Drop the dependency on python-setuptools-whl,
depend on python-pip-whl (>= 8.0.2-7).
* Don't run the test_socket test, hangs on some buildds.
2016-02-22 - Matthias Klose <doko@debian.org>
python3.5 (3.5.1-6) unstable; urgency=medium
* Update to 20160221 from the 3.5 branch.
2016-01-13 - Matthias Klose <doko@debian.org>
python3.5 (3.5.1-5) unstable; urgency=medium
* Update to 20160113 from the 3.5 branch.
2016-01-11 - Matthias Klose <doko@debian.org>
python3.5 (3.5.1-4) unstable; urgency=medium
* Update to 20160111 from the 3.5 branch.
2016-01-05 - Matthias Klose <doko@debian.org>
python3.5 (3.5.1-3) unstable; urgency=medium
* Update to 20160105 from the 3.5 branch.
* Fix maintainer scripts with findutils 4.6. Closes: #809079.
2015-12-10 - Matthias Klose <doko@debian.org>
python3.5 (3.5.1-2) unstable; urgency=medium
* Disable LTO on Debian/s390x.
* Don't run test_signal on alpha, currently breaks the testsuite.
2015-12-07 - Matthias Klose <doko@debian.org>
python3.5 (3.5.1-1) unstable; urgency=medium
* Python 3.5.1 release.
* Fix building architecture independent packages only. Closes: #806870.
* Update symbols files for i386.
* d/p/fix-sslv3-test.diff: properly handle Ubuntu's openssl having OP_NO_SSLv3
forced on by default (Marc Deslauriers).

See Also

Package Description
idle3_3.5.1-3_all.deb IDE for Python using Tkinter (default version)
idle_2.7.11-1_all.deb IDE for Python using Tkinter (default version)
ieee-data_20150531.1_all.deb OUI and IAB listings
ifenslave_2.7ubuntu1_all.deb configure network interfaces for parallel routing (bonding)
ifupdown_0.8.10ubuntu1_amd64.deb high level tools to configure network interfaces
im-config_0.29-1ubuntu12_all.deb Input method configuration framework
imagemagick-6.q16_6.8.9.9-7ubuntu5_amd64.deb image manipulation programs -- quantum depth Q16
imagemagick-common_6.8.9.9-7ubuntu5_all.deb image manipulation programs -- infrastructure
imagemagick-doc_6.8.9.9-7ubuntu5_all.deb document files of ImageMagick
imagemagick_6.8.9.9-7ubuntu5_amd64.deb image manipulation programs -- binaries
indent-doc_2.2.11-4_all.deb Documentation for GNU indent
indent_2.2.11-4_amd64.deb C language source code formatting program
indicator-application_12.10.1+15.04.20150128-0ubuntu1_amd64.deb Application Indicators
indicator-appmenu_15.02.0+16.04.20151104-0ubuntu1_amd64.deb Indicator for application menus
indicator-bluetooth_0.0.6+16.04.20160214-0ubuntu1_amd64.deb System bluetooth indicator
Advertisement
Advertisement