hplip_3.16.3+repack0-1_amd64.deb


Advertisement

Description

hplip - HP Linux Printing and Imaging System (HPLIP)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename hplip_3.16.3+repack0-1_amd64.deb
Package name hplip
Package version 3.16.3+repack0
Package release 1
Package architecture amd64
Package type deb
Category utils
Homepage http://hplipopensource.com/hplip-web/index.html
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 64.02 KB
Installed size 315.00 KB
The HP Linux Printing and Imaging System provides full support for
printing on most HP SFP (single function peripheral) inkjets and many
LaserJets, and for scanning, sending faxes and for photo-card access on
most HP MFP (multi-function peripheral) printers.
HPLIP is composed of:
* System services to handle communications with the printers
* HP CUPS backend driver (hp:) with bi-directional communication with
HP printers (provides printer status feedback to CUPS and enhanced
HPIJS functionality such as 4-side full-bleed printing support)
* HP CUPS backend driver for sending faxes (hpfax:)
* hpcups CUPS Raster driver to turn rasterized input from the CUPS
filter chain into the printer's native format (PCL, LIDIL, ...).
(hpcups is shipped in a separate package)
* HPIJS Ghostscript IJS driver to rasterize output from PostScript(tm)
files or from any other input format supported by Ghostscript, and
also for PostScript(tm) to fax conversion support
(HPIJS is shipped in a separate package)
* Command line utilities to perform printer maintenance, such as
ink-level monitoring or pen cleaning and calibration
* GUI and command line utility to download data from the photo card
interfaces in MFP devices
* GUI and command line utilities to interface with the fax functions
* A GUI toolbox to access all these functions in a friendly way
* HPAIO SANE backend (hpaio) for flatbed and Automatic Document Feeder
(ADF) scanning using MFP devices
USB, JetDirect (network) and parallel-port devices are supported.

Alternatives

Package Version Architecture Repository
hplip_3.16.3+repack0-1_i386.deb 3.16.3+repack0 i386 Ubuntu Main
hplip - - -

Requires

Name Value
adduser >= 3.34
coreutils >= 5.1.0
cups >= 1.1.20
hplip-data = 3.16.3+repack0-1
libc6 >= 2.14
libcups2 >= 1.6.0
libdbus-1-3 >= 1.9.14
libhpmud0 = 3.16.3+repack0-1
libsane >= 1.0.24
libsane-hpaio = 3.16.3+repack0-1
lsb-base >= 3
policykit-1 -
printer-driver-hpcups = 3.16.3+repack0-1
python3 << 3.6
python3 >= 3.5~
python3-dbus >= 0.80
python3-gi -
python3-pexpect -
python3-pil -
python3-reportlab -
wget -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package hplip_3.16.3+repack0-1_amd64.deb
Source Package hplip

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install hplip deb package:
    # sudo apt-get install hplip

Files

Path
/etc/dbus-1/system.d/com.hp.hplip.conf
/lib/udev/rules.d/56-hpmud.rules
/usr/bin/hp-align
/usr/bin/hp-check
/usr/bin/hp-clean
/usr/bin/hp-colorcal
/usr/bin/hp-config_usb_printer
/usr/bin/hp-doctor
/usr/bin/hp-firmware
/usr/bin/hp-info
/usr/bin/hp-levels
/usr/bin/hp-logcapture
/usr/bin/hp-makeuri
/usr/bin/hp-pkservice
/usr/bin/hp-plugin
/usr/bin/hp-plugin-ubuntu
/usr/bin/hp-probe
/usr/bin/hp-query
/usr/bin/hp-scan
/usr/bin/hp-setup
/usr/bin/hp-testpage
/usr/bin/hp-timedate
/usr/lib/cups/backend/hp
/usr/lib/cups/backend/hpfax
/usr/lib/cups/filter/hpps
/usr/lib/cups/filter/pstotiff
/usr/lib/python3/dist-packages/cupsext.cpython-35m-x86_64-linux-gnu.so
/usr/lib/python3/dist-packages/hpmudext.cpython-35m-x86_64-linux-gnu.so
/usr/lib/python3/dist-packages/pcardext.cpython-35m-x86_64-linux-gnu.so
/usr/lib/python3/dist-packages/scanext.cpython-35m-x86_64-linux-gnu.so
/usr/share/bug/hplip/presubj
/usr/share/bug/hplip/script
/usr/share/cups/mime/pstotiff.convs
/usr/share/cups/mime/pstotiff.types
/usr/share/dbus-1/system-services/com.hp.hplip.service
/usr/share/doc/hplip/NEWS.Debian.gz
/usr/share/doc/hplip/changelog.Debian.gz
/usr/share/doc/hplip/copyright
/usr/share/doc/hplip/users-guide.txt
/usr/share/man/man1/hp-align.1.gz
/usr/share/man/man1/hp-check.1.gz
/usr/share/man/man1/hp-clean.1.gz
/usr/share/man/man1/hp-colorcal.1.gz
/usr/share/man/man1/hp-config_usb_printer.1.gz
/usr/share/man/man1/hp-doctor.1.gz
/usr/share/man/man1/hp-firmware.1.gz
/usr/share/man/man1/hp-info.1.gz
/usr/share/man/man1/hp-levels.1.gz
/usr/share/man/man1/hp-logcapture.1.gz
/usr/share/man/man1/hp-makeuri.1.gz
/usr/share/man/man1/hp-pkservice.1.gz
/usr/share/man/man1/hp-plugin.1.gz
/usr/share/man/man1/hp-probe.1.gz
/usr/share/man/man1/hp-query.1.gz
/usr/share/man/man1/hp-scan.1.gz
/usr/share/man/man1/hp-setup.1.gz
/usr/share/man/man1/hp-testpage.1.gz
/usr/share/man/man1/hp-timedate.1.gz
/usr/share/polkit-1/actions/com.hp.hplip.policy

Changelog

2016-03-19 - Julian Andres Klode <jak@debian.org>
hplip (3.16.3+repack0-1) unstable; urgency=medium
* Imported Upstream version 3.16.3
2016-03-12 - Julian Andres Klode <jak@debian.org>
hplip (3.16.2+repack0-7) unstable; urgency=medium
* Apply HP-LaserJet_4000-PostScript-PPD.patch like other patches
* Do not run install actions twice in indep+arch builds (Closes: #817883)
2016-03-11 - Julian Andres Klode <jak@debian.org>
hplip (3.16.2+repack0-6) unstable; urgency=medium
* Handle building of only Architecture: any packages
* Use --dbgsym-migration instead of --ddeb-migration
2016-03-10 - Julian Andres Klode <jak@debian.org>
hplip (3.16.2+repack0-5) unstable; urgency=medium
* Add myself as an uploader
* Port the packaging to dh(1) and clean it up internally:
- Drop unused patches
- debian/rules: Drop /usr/share/gnome-pkg-tools/1/rules/sf-get-source.mk
- Delete unused debian/tmpno directory
- Do not set DH_ALWAYS_EXCLUDE for CVS and drop DH_VERBOSE comment
- Drop invalid use of X-Python-Version
- debian/rules: Port to dh(1)
- clean: Restore uncompressed files
- Use the standard source:Version substvar and its friends
- Remove support for installing Linda files
- Do not install lintian overrides manually, use dh_lintian
- Install ppd-updater files directly using dh_install
- Do not pass sourcedir to dh_install
- Install FAX ppds using install files
- Simply use dh_install --list-missing
- Let upstream install html into /usr/share/doc/hplip-doc/
- debian/rules: Stop patching hplip.conf
- Do not pass variables to build/install, not needed anymore
- Delete README.source, outdated
- Rename README.Source to README.source and drop outdated stuff
- Use upstream symlinks; drops hp-hpdio (not a script)
- Clean up lintian overrides
- hplip-data: Override two lintian tags
- Bump Standards-Version to 3.9.7
* Dropped stuff:
- Do not install .la files
- Do not install hpssd into bin, it's not executable
- Drop hp-unload for now, it does not support Python 3
* Install missing manual pages that are available
* Menu entry cleanup
- Drop hplip-gui.menu, having both .desktop and .menu is forbidden now
- Get rid of HPmenu.xpm and hp-logo.xpm, use upstream logo
* Build flag changes:
- Build with as-needed
- Use full hardening
2016-02-25 - Didier Raboud <odyx@debian.org>
hplip (3.16.2+repack0-4) unstable; urgency=medium
* Add patch to order page sizes consistently in hp-scan, to ensure manpage
generation reproducibility
2016-02-23 - Didier Raboud <odyx@debian.org>
hplip (3.16.2+repack0-3) unstable; urgency=medium
* Fix LD_LIBRARY_PATH to include DEB_HOST_MULTIARCH when generating python
tools' manpages; fixes the FTBFS of -2
2016-02-15 - Didier Raboud <odyx@debian.org>
hplip (3.16.2+repack0-2) unstable; urgency=medium
* Multi-arch'ify libsane-hpaio and libhpmud0 (Closes: #813043, #804379)
2016-02-13 - Didier Raboud <odyx@debian.org>
hplip (3.16.2+repack0-1) unstable; urgency=medium
* New 3.16.2 upstream release
- Repack the 3.16.2 upstream release
Uncompress various source files, for better upstream tracking in the VCS
* debian/rules - get-orig-source:
- force upstream/latest-repack merge to use 'theirs' merge strategy and
make it not fail the target
- drop 'modeswitch' copy-paste leftover
* Fix typo in previous changelog entry

See Also

Package Description
hud-doc_14.10+16.04.20160415-0ubuntu1_all.deb Backend for the Unity HUD
hud_14.10+16.04.20160415-0ubuntu1_amd64.deb Backend for the Unity HUD
humanity-icon-theme_0.6.10_all.deb Humanity Icon theme
hunspell-af_5.1.0-1ubuntu2_all.deb Afrikaans dictionary for hunspell
hunspell-an_0.2-2_all.deb Aragonese dictionary for hunspell
hunspell-ar_3.2-1_all.deb Arabic dictionary for hunspell
hunspell-be_0.53-3_all.deb Belarusian dictionary for hunspell and academic orthography
hunspell-bg_5.1.0-1ubuntu2_all.deb Bulgarian dictionary for hunspell
hunspell-bn_5.1.0-1ubuntu2_all.deb Bengali dictionary for hunspell
hunspell-br_0.12-2_all.deb Breton language dictionary for hunspell
hunspell-bs_5.1.0-1ubuntu2_all.deb Bosnian dictionary for hunspell
hunspell-ca_3.0.1+repack1-3_all.deb Catalan dictionaries for hunspell
hunspell-cs_5.1.0-1ubuntu2_all.deb Czech dictionary for hunspell
hunspell-da_5.1.0-1ubuntu2_all.deb Danish dictionary for hunspell
hunspell-de-at_20151222-1_all.deb Austrian (German) dictionary for hunspell
Advertisement
Advertisement