grub-legacy-ec2_0.7.7~bzr1212-0ubuntu1_all.deb


Advertisement

Description

grub-legacy-ec2 - Handles update-grub for ec2 instances

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename grub-legacy-ec2_0.7.7~bzr1212-0ubuntu1_all.deb
Package name grub-legacy-ec2
Package version 0.7.7~bzr1212
Package release 0ubuntu1
Package architecture all
Package type deb
Category admin
Homepage -
License -
Maintainer Scott Moser <smoser@ubuntu.com>
Download size 21.78 KB
Installed size 105.00 KB
EC2 instances that use grub-legacy as a bootloader need a way to keep
/boot/grub/menu.lst up to date while not conflicting with grub-pc.
This package provides that.

Alternatives

Package Version Architecture Repository
grub-legacy-ec2_18.5-45-g3554ffe8-0ubuntu1~16.04.1_all.deb 18.5 all Ubuntu Updates Main
grub-legacy-ec2_18.5-45-g3554ffe8-0ubuntu1~16.04.1_all.deb 18.5 all Ubuntu Updates Main
grub-legacy-ec2_0.7.7~bzr1212-0ubuntu1_all.deb 0.7.7~bzr1212 all Ubuntu Main
grub-legacy-ec2 - - -

Requires

Name Value
cdebconf -
debconf >= 0.5
debconf >= 1.5.19
debconf-2.0 -
ucf -
util-linux >= 2.15-1

Conflicts

Name Value
grub -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package grub-legacy-ec2_0.7.7~bzr1212-0ubuntu1_all.deb
Source Package cloud-init

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install grub-legacy-ec2 deb package:
    # sudo apt-get install grub-legacy-ec2

Files

Path
/etc/kernel/kernel/postinst.d/x-grub-legacy-ec2
/etc/kernel/kernel/postrm.d/x-grub-legacy-ec2
/usr/sbin/grub-set-default
/usr/sbin/grub-set-default-legacy-ec2
/usr/sbin/update-grub-legacy-ec2
/usr/share/doc/grub-legacy-ec2/changelog.Debian.gz
/usr/share/doc/grub-legacy-ec2/copyright
/usr/share/lintian/overrides/grub-legacy-ec2

Changelog

2016-04-15 - Scott Moser <smoser@ubuntu.com>
cloud-init (0.7.7~bzr1212-0ubuntu1) xenial; urgency=medium
* New upstream snapshot.
- fix iscsi root by not writing interface as 'auto' when networking
information comes from kernel command line (LP: #1568637)
- apply networking less often, when possible only on first
instance boot (LP: #1571004).
- no longer delete /etc/network/interfaces.d/eth0.cfg on
ubuntu (LP: #1563487)
2016-04-14 - Scott Moser <smoser@ubuntu.com>
cloud-init (0.7.7~bzr1209-0ubuntu1) xenial; urgency=medium
* New upstream snapshot.
- fallback net config: do not consider devices starting with 
'veth' (LP: #1569064)
2016-04-13 - Scott Moser <smoser@ubuntu.com>
cloud-init (0.7.7~bzr1208-0ubuntu1) xenial; urgency=medium
* New upstream snapshot.
- phone_home: allow usage of fqdn (LP: #1566824) [Ollie Armstrong]
- chef: straighten out validation_cert and validation_key (LP: #1568940)
- skip bridges when generating fallback networking (LP: #1569974)
- rh_subscription: only check subscription if configured (LP: #1536706)
- SmartOS, CloudSigma: fix error when dmi data is not availble
(LP: #1569469)
- DataSourceNoCloud: fix check_instance_id when upgraded (LP: #1568150)
- lxd: adds basic support for dpkg based lxd-bridge 
configuration. (LP: #1569018)
- centos: Ensure that a resolve conf object is written as a string.
(LP: #1479988)
2016-04-06 - Scott Moser <smoser@ubuntu.com>
cloud-init (0.7.7~bzr1200-0ubuntu1) xenial; urgency=medium
* New upstream snapshot.
- fix adding of users when no group is specified (LP: #1562918)
- fix write_files with compressed content (LP: #1565638)
- systemd: do not specify After of obsolete syslog.target (LP: #1536964)
- chef: fix chef installation from gems (LP: #1553345)
- disk_setup: correctly send force to mkfs on block devices (LP: #1548772)
- locale: list unsupported environment settings in warning (LP: #1558069)
- fix NoCloud and other datasources if no datasource config (LP: #1514407)
2016-03-31 - Scott Moser <smoser@ubuntu.com>
cloud-init (0.7.7~bzr1192-0ubuntu2) xenial; urgency=medium
[Logan Rosen]
* debian/cloud-init.postinst: fix shell syntax in upgrade (LP: #1564187)
2016-03-29 - Scott Moser <smoser@ubuntu.com>
cloud-init (0.7.7~bzr1192-0ubuntu1) xenial; urgency=medium
* New upstream snapshot.
- Misc fixes for VMware Support.
- network config improvements:
- do not raise exception on non-debian if network config is found.
- apply network config in 'cloud-init --local' even if there is
no datasource found.
- do not write 70-persistent-net.rules only systemd .link files.
- improve how cloud-init-wait waits: remove the check and sleep
loop and replace it with 'udevadm settle'.
2016-03-24 - Scott Moser <smoser@ubuntu.com>
cloud-init (0.7.7~bzr1189-0ubuntu1) xenial; urgency=medium
* d/control: adjust build dependency as python3-pyflakes in xenial
now provides python3 modules for pyflakes.
* d/cloud-init.install, d/control, d/dirs, d/grub-legacy-ec2.install:
run wrap-and-sort
* d/cloud-init.install: add lib/udev/ files.
* d/cloud-init.postinst: touch /var/lib/cloud/data/upgraded-network
if upgrading from version that did not have network support.
* New upstream snapshot.
* initial support for support network configuration in cloud-init --local
* do not rely on network metadata service on every boot for 
ConfigDrive Openstack Azure (LP: #1553815)

See Also

Package Description
grub-pc-bin_2.02~beta2-36ubuntu3_amd64.deb GRand Unified Bootloader, version 2 (PC/BIOS binaries)
grub-pc_2.02~beta2-36ubuntu3_amd64.deb GRand Unified Bootloader, version 2 (PC/BIOS version)
grub-xen-bin_2.02~beta2-36ubuntu3_amd64.deb GRand Unified Bootloader, version 2 (Xen binaries)
grub-xen_2.02~beta2-36ubuntu3_amd64.deb GRand Unified Bootloader, version 2 (Xen version)
grub2-common_2.02~beta2-36ubuntu3_amd64.deb GRand Unified Bootloader (common files for version 2)
grub_0.97-29ubuntu68_amd64.deb GRand Unified Bootloader (Legacy version)
gsettings-desktop-schemas-dev_3.18.1-1ubuntu1_amd64.deb Development files for GSettings desktop-wide schemas
gsettings-desktop-schemas_3.18.1-1ubuntu1_all.deb GSettings desktop-wide schemas
gsettings-ubuntu-schemas_0.0.5+16.04.20160307-0ubuntu1_all.deb GSettings deskop-wide schemas for Ubuntu
gsfonts_8.11+urwcyr1.0.7~pre44-4.2ubuntu1_all.deb Fonts for the Ghostscript interpreter(s)
gstreamer1.0-alsa_1.8.0-1ubuntu1_amd64.deb GStreamer plugin for ALSA
gstreamer1.0-clutter-3.0_3.0.18-1_amd64.deb Clutter PLugin for GStreamer 1.0
gstreamer1.0-doc_1.8.0-1_all.deb GStreamer core documentation and manuals
gstreamer1.0-plugins-base-apps_1.8.0-1ubuntu1_amd64.deb GStreamer helper programs from the "base" set
gstreamer1.0-plugins-base-doc_1.8.0-1ubuntu1_all.deb GStreamer documentation for plugins from the "base" set
Advertisement
Advertisement