gnu-standards_2010.03.11-1_all.deb


Advertisement

Description

gnu-standards - GNU coding and package maintenance standards

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename gnu-standards_2010.03.11-1_all.deb
Package name gnu-standards
Package version 2010.03.11
Package release 1
Package architecture all
Package type deb
Category doc
Homepage http://savannah.gnu.org/projects/gnustandards
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 1.22 MB
Installed size 1.66 MB
This package contains two pieces of documentation from the GNU
project: 'GNU Coding Standards', and 'Information for Maintainers of
GNU Software'.
These are useful to refer to if you are writing or maintaining software
for GNU, but could also be helpful as guidelines for other projects.

Alternatives

Package Version Architecture Repository
gnu-standards_2010.03.11-1_all.deb 2010.03.11 all Ubuntu Main
gnu-standards - - -

Requires

Name Value
dpkg >= 1.15.4
install-info -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package gnu-standards_2010.03.11-1_all.deb
Source Package gnu-standards

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gnu-standards deb package:
    # sudo apt-get install gnu-standards

Files

Path
/usr/share/doc-base/gnu-coding-standards
/usr/share/doc-base/gnu-maintainers-information
/usr/share/doc/gnu-standards/changelog.Debian.gz
/usr/share/doc/gnu-standards/changelog.gz
/usr/share/doc/gnu-standards/copyright
/usr/share/doc/gnu-standards/maintain.dvi.gz
/usr/share/doc/gnu-standards/maintain.html
/usr/share/doc/gnu-standards/maintain.pdf.gz
/usr/share/doc/gnu-standards/maintain.text.gz
/usr/share/doc/gnu-standards/standards.dvi.gz
/usr/share/doc/gnu-standards/standards.html
/usr/share/doc/gnu-standards/standards.pdf.gz
/usr/share/doc/gnu-standards/standards.text.gz
/usr/share/info/maintain.info.gz
/usr/share/info/standards.info.gz

Changelog

2010-03-21 - Tim Retout <diocles@debian.org>
gnu-standards (2010.03.11-1) unstable; urgency=low
* New upstream version.
* debian/source/format: Use Format 3.0 (quilt).
2010-03-08 - Tim Retout <diocles@debian.org>
gnu-standards (2010.02.23-1) unstable; urgency=low
* New upstream version.
* debian/control: Bump Standards-Version to 3.8.4 (no changes needed).
2010-01-27 - Tim Retout <diocles@debian.org>
gnu-standards (2010.01.27-1) unstable; urgency=low
* New upstream version.
* debian/control: Update maintainer email address.
* debian/copyright: Update copyright years and maintainer email address.
2009-12-22 - Tim Retout <tim@retout.co.uk>
gnu-standards (2009.12.12-1) unstable; urgency=low
* New upstream version.
2009-12-07 - Tim Retout <tim@retout.co.uk>
gnu-standards (2009.11.20-1) unstable; urgency=low
* New upstream version.
2009-10-31 - Tim Retout <tim@retout.co.uk>
gnu-standards (2009.09.14-1) unstable; urgency=low
* New upstream version.
* debian/control:
+ Update Standards-Version to 3.8.3.
+ Add ${misc:Depends} to Depends to get new
dpkg (>= 1.15.4) | install-info dependency.
* debian/watch: New file with comments explaining upstream distribution
mechanism, as suggested by a lintian message.
2009-03-20 - Tim Retout <tim@retout.co.uk>
gnu-standards (2009.03.12-1) unstable; urgency=low
* New Upstream Version
* debian/copyright:
+ Add 2009 to the copyright statements.
+ Update license to version 1.3 or later of the GFDL.
* debian/control:
+ Revise long description.
+ Update Standards-Version to 3.8.1. (No changes needed.)
2008-06-23 - Tim Retout <tim@retout.co.uk>
gnu-standards (2008.06.10-1) unstable; urgency=low
* New maintainer.  (Closes: #487136)
* New upstream version. (Closes: #283295, #434638)
* debian/copyright:
+ Update to reflect relicensing upstream (to GFDL 1.2 or later).
+ Add instructions for creating source tarball.
+ Update list of upstream authors.
+ Add Debian packaging copyright information.
* debian/control:
+ (Section): Move back to main. (Closes: #462871, #357675)
+ Move debhelper dependency to Build-Depends. Bump to (>= 5.0.0)
+ Build-Depends-Indep on texinfo (>= 4.6), not (>= 4.6-1).
+ Build-Depends-Indep on texlive-base, texlive-latex-base, and
texlive-generic-recommended. Remove tetex-bin and tetex-extra.
+ Bump Standards-Version to 3.8.0.
+ Add Homepage and Vcs-* fields.
* debian/compat:
+ Bump debhelper compatibility level to 5.
* debian/rules:
+ Remove binary-arch. Move rules to binary-indep.
+ Remove configure, configure-stamp and install rules. Add dh_clean -k to
binary-indep.
+ Remove refresh rule and associated variables.
+ Do not call unused debhelper commands.
+ Remove arguments to dh_installinfo and dh_installdocs.
+ Pass ChangeLog as argument to dh_installchangelogs.
+ No longer specify SHELL.
* debian/postrm, debian/preinst:
+ Remove empty maintainer scripts.
* debian/gnu-standards.postinst, debian/gnu-standards.prerm:
+ Remove; let dh_installinfo handle them.
* debian/gnu-standards.doc-base.standards,
debian/gnu-standards.doc-base.maintain:
+ Add doc-base registration files. (Closes: #451650)
* debian/gnu-standards.info:
+ New file, list info files for dh_installinfo here.
* debian/dirs, debian/docs: Remove.
* debian/gnu-standards.docs: New file, list docs to install.
2004-12-16 - Simon Law <sfllaw@debian.org>
gnu-standards (2005.03.08) unstable; urgency=low
* New maintainer.  (Closes: Bug#284219)
* New upstream versions.
* Moved to non-free.
2003-11-09 - Ben Pfaff <pfaffben@debian.org>
gnu-standards (2003.11.09-1) unstable; urgency=low
* New upstream versions of *.texi, texinfo.tex.  Closes: #168176.
* New upstream URL http://www.gnu.org/prep.
* standards.texi: Add @ifhtml alternative for CHAPTER.
* Use `makeinfo --html instead of texi2html.

See Also

Package Description
gnupg-agent_2.1.11-6ubuntu2_amd64.deb GNU privacy guard - cryptographic agent
gnupg-doc_2003.04.06+dak1-1ubuntu1_all.deb GNU Privacy Guard documentation
gnupg2_2.1.11-6ubuntu2_amd64.deb GNU privacy guard - a free PGP replacement (new v2.x)
gnupg_1.4.20-1ubuntu3_amd64.deb GNU privacy guard - a free PGP replacement
gnutls-doc_3.4.10-4ubuntu1_all.deb GNU TLS library - documentation and examples
gobi-loader_0.7-0ubuntu2_amd64.deb Firmware loader for Qualcom GobiUSB chipsets
gobject-introspection_1.46.0-3ubuntu1_amd64.deb Generate interface introspection data for GObject libraries
golang-1.6-doc_1.6.1-0ubuntu1_all.deb Go programming language - documentation
golang-1.6-go_1.6.1-0ubuntu1_amd64.deb Go programming language compiler, linker, compiled stdlib
golang-1.6-race-detector-runtime_0.0+svn252922-0ubuntu1_amd64.deb Runtime support for Go's race detector
golang-1.6-src_1.6.1-0ubuntu1_amd64.deb Go programming language - source files
golang-1.6_1.6.1-0ubuntu1_all.deb Go programming language compiler - metapackage
golang-check.v1-dev_0.0+git20150729.11d3bc7-2_all.deb Rich testing extension for Go's testing package
golang-context-dev_0.0~git20140604.1.14f550f-1_all.deb General purpose registry for global request variables
golang-dbus-dev_2-1ubuntu1_all.deb Go client bindings for D-Bus
Advertisement
Advertisement