gnu-efi_3.0.2-1ubuntu1_amd64.deb


Advertisement

Description

gnu-efi - Library for developing EFI applications

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename gnu-efi_3.0.2-1ubuntu1_amd64.deb
Package name gnu-efi
Package version 3.0.2
Package release 1ubuntu1
Package architecture amd64
Package type deb
Category devel
Homepage http://sourceforge.net/projects/gnu-efi/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 104.44 KB
Installed size 612.00 KB
GNU toolchain for building applications that can run in the environment
presented by Intel's EFI (Extensible Firmware Interface). EFI is a firmware
specification for the "BIOS" on ia64(IPF), IA-32(x86) and x86_64 systems.

Alternatives

Package Version Architecture Repository
gnu-efi_3.0.8-0ubuntu1~16.04.1_amd64.deb 3.0.8 amd64 Ubuntu Updates Main
gnu-efi_3.0.8-0ubuntu1~16.04.1_i386.deb 3.0.8 i386 Ubuntu Updates Main
gnu-efi_3.0.2-1ubuntu1_i386.deb 3.0.2 i386 Ubuntu Main
gnu-efi - - -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package gnu-efi_3.0.2-1ubuntu1_amd64.deb
Source Package gnu-efi

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gnu-efi deb package:
    # sudo apt-get install gnu-efi

Files

Path
/usr/include/efi/efi.h
/usr/include/efi/efi_nii.h
/usr/include/efi/efi_pxe.h
/usr/include/efi/efiapi.h
/usr/include/efi/eficon.h
/usr/include/efi/efidebug.h
/usr/include/efi/efidef.h
/usr/include/efi/efidevp.h
/usr/include/efi/efierr.h
/usr/include/efi/efifs.h
/usr/include/efi/efigpt.h
/usr/include/efi/efiip.h
/usr/include/efi/efilib.h
/usr/include/efi/efilink.h
/usr/include/efi/efinet.h
/usr/include/efi/efipart.h
/usr/include/efi/efipciio.h
/usr/include/efi/efipoint.h
/usr/include/efi/efiprot.h
/usr/include/efi/efipxebc.h
/usr/include/efi/efirtlib.h
/usr/include/efi/efiser.h
/usr/include/efi/efishellintf.h
/usr/include/efi/efishellparm.h
/usr/include/efi/efistdarg.h
/usr/include/efi/efitcp.h
/usr/include/efi/efiudp.h
/usr/include/efi/efiui.h
/usr/include/efi/libsmbios.h
/usr/include/efi/pci22.h
/usr/include/efi/romload.h
/usr/include/efi/ia32/efibind.h
/usr/include/efi/ia32/efilibplat.h
/usr/include/efi/ia32/pe.h
/usr/include/efi/protocol/adapterdebug.h
/usr/include/efi/protocol/eficonsplit.h
/usr/include/efi/protocol/efidbg.h
/usr/include/efi/protocol/efivar.h
/usr/include/efi/protocol/intload.h
/usr/include/efi/protocol/legacyboot.h
/usr/include/efi/protocol/piflash64.h
/usr/include/efi/protocol/vgaclass.h
/usr/include/efi/x86_64/efibind.h
/usr/include/efi/x86_64/efilibplat.h
/usr/include/efi/x86_64/pe.h
/usr/lib/crt0-efi-x86_64.o
/usr/lib/elf_x86_64_efi.lds
/usr/lib/libefi.a
/usr/lib/libgnuefi.a
/usr/lib32/crt0-efi-ia32.o
/usr/lib32/elf_ia32_efi.lds
/usr/lib32/libefi.a
/usr/lib32/libgnuefi.a
/usr/share/doc/gnu-efi/TODO.Debian
/usr/share/doc/gnu-efi/changelog.Debian.gz
/usr/share/doc/gnu-efi/copyright

Changelog

2015-06-04 - Mario Limonciello <Mario_Limonciello@Dell.com>
gnu-efi (3.0.2-1ubuntu1) wily; urgency=medium
* Merge with Debian unstable, remaining changes: 
- debian/patches/gcc46-compatibility: don't break with old compilers
and -DGNU_EFI_USE_MS_ABI.
2014-09-25 - Julian Andres Klode <jak@debian.org>
gnu-efi (3.0.2-1) unstable; urgency=medium
* Imported Upstream version 3.0.2
* debian/rules: Simplify by using upstream Makefile for install
* debian/control: Bump Standards-Version to 3.9.6
* debian/copyright: Remove spaces from License keyword
* Add any-arm and any-arm64 to the architecture list
* inc-efistdarg.h-Use-gcc-builtins-instead-of-stdarg.h.patch: Applied upstream
2015-05-12 - Steve Langasek <steve.langasek@ubuntu.com>
gnu-efi (3.0v-5ubuntu1) wily; urgency=medium
* Merge from Debian unstable (LP: #1396381), remaining changes:
- debian/patches/gcc46-compatibility: don't break with old compilers
and -DGNU_EFI_USE_MS_ABI.
* Dropped changes, included in Debian:
- pass architecture arguments when building the x86_64 code on i386
2014-07-21 - Julian Andres Klode <jak@debian.org>
gnu-efi (3.0v-5) unstable; urgency=medium
* inc/efistdarg.h: Use gcc builtins instead of stubs
- The last upload of gnu-efi caused things to compile, but severely
broke them.
2014-07-19 - Julian Andres Klode <jak@debian.org>
gnu-efi (3.0v-4) unstable; urgency=medium
* Take over maintenance
* Add git information and git-buildpackage configuration
* Use gbp pq for maintaining the patch queue
* inc/efistdarg.h: Stub out va_copy (Closes: #753682)
2014-07-16 - Daniel Baumann <mail@daniel-baumann.ch>
gnu-efi (3.0v-3) unstable; urgency=low
* Stepping down from maintainers, no interest anymore since syslinux uses
its own copy of gnu-efi that is bundled and sort-of impossible to patch
out.
2014-05-06 - Daniel Baumann <mail@daniel-baumann.ch>
gnu-efi (3.0v-2) unstable; urgency=low
* Temporarily build without stdarg.h in efistdarg.h (Closes: #747158).
2014-04-05 - Daniel Baumann <mail@daniel-baumann.ch>
gnu-efi (3.0v-1) unstable; urgency=low
* Merging upstream version 3.0v.
* Updating year in copyright file.
* Updating make calls in rules for new upstream release.
2014-04-24 - Steve Langasek <steve.langasek@ubuntu.com>
gnu-efi (3.0u+debian-4ubuntu1) utopic; urgency=low
* Merge from Debian unstable.  Remaining changes:
- debian/patches/gcc46-compatibility: don't break with old compilers
and -DGNU_EFI_USE_MS_ABI.
* Dropped changes, included in Debian:
- pass architecture arguments when building the x86_64 code on i386
2014-03-31 - Daniel Baumann <mail@daniel-baumann.ch>
gnu-efi (3.0u+debian-4) unstable; urgency=low
* Updating to standards version 3.9.5.
* Building with dh --parallel.

See Also

Package Description
gnu-standards_2010.03.11-1_all.deb GNU coding and package maintenance standards
gnupg-agent_2.1.11-6ubuntu2_amd64.deb GNU privacy guard - cryptographic agent
gnupg-doc_2003.04.06+dak1-1ubuntu1_all.deb GNU Privacy Guard documentation
gnupg2_2.1.11-6ubuntu2_amd64.deb GNU privacy guard - a free PGP replacement (new v2.x)
gnupg_1.4.20-1ubuntu3_amd64.deb GNU privacy guard - a free PGP replacement
gnutls-doc_3.4.10-4ubuntu1_all.deb GNU TLS library - documentation and examples
gobi-loader_0.7-0ubuntu2_amd64.deb Firmware loader for Qualcom GobiUSB chipsets
gobject-introspection_1.46.0-3ubuntu1_amd64.deb Generate interface introspection data for GObject libraries
golang-1.6-doc_1.6.1-0ubuntu1_all.deb Go programming language - documentation
golang-1.6-go_1.6.1-0ubuntu1_amd64.deb Go programming language compiler, linker, compiled stdlib
golang-1.6-race-detector-runtime_0.0+svn252922-0ubuntu1_amd64.deb Runtime support for Go's race detector
golang-1.6-src_1.6.1-0ubuntu1_amd64.deb Go programming language - source files
golang-1.6_1.6.1-0ubuntu1_all.deb Go programming language compiler - metapackage
golang-check.v1-dev_0.0+git20150729.11d3bc7-2_all.deb Rich testing extension for Go's testing package
golang-context-dev_0.0~git20140604.1.14f550f-1_all.deb General purpose registry for global request variables
Advertisement
Advertisement