gir1.2-secret-1_0.18.4-1ubuntu2_amd64.deb


Advertisement

Description

gir1.2-secret-1 - Secret store (GObject-Introspection)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename gir1.2-secret-1_0.18.4-1ubuntu2_amd64.deb
Package name gir1.2-secret-1
Package version 0.18.4
Package release 1ubuntu2
Package architecture amd64
Package type deb
Category introspection
Homepage https://wiki.gnome.org/Projects/Libsecret
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 7.06 KB
Installed size 36.00 KB
This package contains introspection data for libsecret, which can be used
to generate dynamic bindings.
libsecret is a library for storing and retrieving passwords and other secrets.
It communicates with the "Secret Service" using DBus.
This package contains the introspection datas for the libsecret library.

Alternatives

Package Version Architecture Repository
gir1.2-secret-1_0.18.4-1ubuntu2_i386.deb 0.18.4 i386 Ubuntu Main
gir1.2-secret-1 - - -

Requires

Name Value
gir1.2-glib-2.0 -
libgirepository-1.0-1 >= 1.41.4-1
libsecret-1-0 >= 0.18

Download

Type URL
Mirror archive.ubuntu.com
Binary Package gir1.2-secret-1_0.18.4-1ubuntu2_amd64.deb
Source Package libsecret

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gir1.2-secret-1 deb package:
    # sudo apt-get install gir1.2-secret-1

Files

Path
/usr/lib/x86_64-linux-gnu/girepository-1.0/Secret-1.typelib
/usr/share/doc/gir1.2-secret-1/changelog.Debian.gz
/usr/share/doc/gir1.2-secret-1/copyright

Changelog

2016-04-17 - Matthias Klose <doko@ubuntu.com>
libsecret (0.18.4-1ubuntu2) xenial; urgency=medium
* Don't run the python and vala tests on s390x, hanging. In 0.18.3,
these all failed to run due to dbus/mock failures.
2016-02-10 - Sebastien Bacher <seb128@ubuntu.com>
libsecret (0.18.4-1ubuntu1) xenial; urgency=medium
* debian/control.in,
debian/patches/dont_use_gjs.patch:
- don't build-depends on gjs it's in universe
2016-01-25 - Michael Biebl <biebl@debian.org>
libsecret (0.18.4-1) unstable; urgency=medium
* New upstream release.
* Run test suite during build
- Add Build-Depends on dbus on gjs.
- Use dbus-run-session to run the test suite as some of the tests require
a D-Bus session.
- Unset LD_PRELOAD when running the test suite as most tests fail when run
under fakeroot.
2015-08-06 - Michael Biebl <biebl@debian.org>
libsecret (0.18.3-1) unstable; urgency=medium
* New upstream release.
2015-05-20 - Michael Biebl <biebl@debian.org>
libsecret (0.18.2-1) unstable; urgency=medium
[ Laurent Bigonville ]
* debian/control.in: Bump gtk-doc-tools build-dep to >= 1.9
[ Iain Lane ]
* Lower Breaks version to seahorse (<< 3.10), as the API port happened in
this version.
[ Michael Biebl ]
* New upstream release.
* Install typelib files into multiarch paths.
* Mark gir and dev packages as Multi-Arch: same.
* Update Homepage: URL.
* Bump Standards-Version to 3.9.6. No further changes.
* Fix invalid short name for BSD license in debian/copyright.
2014-03-23 - Andreas Henriksson <andreas@fatal.se>
libsecret (0.18-1) unstable; urgency=low
[ Jeremy Bicha ]
* debian/rules:
- Build with --disable-silent-rules for a useful build log
* Update homepage
[ Michael Biebl ]
* New upstream release (0.16).
* Refresh patches.
[ Jackson Doak ]
* debian/control:
- Improve description of libsecret-tools. Closes: #711475
[ Andreas Henriksson ]
* New upstream release (0.18)
* Bump glib build-dependency to >= 2.38.0 according to configure.ac
* Drop debian/patches, both patches obsolete.
- debian/patches/dont_run_gjs_tests.patch
- debian/patches/introspection-dir.patch
* Bump Standards-Version to 3.9.5
* Update debian/libsecret-1-0.symbols
- Missing secret_service_new* symbols...
- See https://git.gnome.org/browse/libsecret/commit/?id=1758194f26a41
- "The _new() suffix confuses vala and gobject introspection [...]
This is an API/API break, but its to the portion of the library
marked as unstable. [...]"
- Also adds several new symbols
* Add "Breaks: seahorse (<< 3.12)" to libsecret-1-0 to handle above.
* Install Secret g-i typelib file from multiarch path.
* debian/rules: quote the wildcard argument of find to avoid premature exp.
2013-05-24 - Michael Biebl <biebl@debian.org>
libsecret (0.15-2) unstable; urgency=low
* Upload to unstable.
* Don't hard-code dpkg in Pre-Depends but use ${misc:Pre-Depends} instead.
* Add Vcs-* fields.
* Drop alternative Build-Depends on valac-0.18. No longer required since
valac is now recent enough.
* Bump Standards-Version to 3.9.4. No further changes.
2013-03-24 - Andreas Henriksson <andreas@fatal.se>
libsecret (0.15-1) experimental; urgency=low
* New upstream release.
2013-03-16 - Andreas Henriksson <andreas@fatal.se>
libsecret (0.14-1) experimental; urgency=low
[ Rico Tzschichholz ]
* debian/control:
- Add multiarch annotations and pre-depends
[ Andreas Henriksson ]
* New upstream release.
* Update debian/libsecret-1-0.symbols: added SECMEM_pool_data_v1_0@Base 0.14
2012-11-02 - Sjoerd Simons <sjoerd@debian.org>
libsecret (0.11-1) experimental; urgency=low
* New upstrema release

See Also

Package Description
gir1.2-signon-1.0_1.13+16.04.20151209.1-0ubuntu1_amd64.deb GObject introspection data for the Signon library
gir1.2-soup-2.4_2.52.2-1_amd64.deb GObject introspection data for the libsoup HTTP library
gir1.2-telepathyglib-0.12_0.24.1-1.1_amd64.deb GLib Telepathy connection manager library (GObject-Introspection)
gir1.2-timezonemap-1.0_0.4.5_amd64.deb typelib interface for libtimezonemap
gir1.2-totem-1.0_3.18.1-1ubuntu4_amd64.deb GObject introspection data for Totem media player
gir1.2-totem-plparser-1.0_3.10.6-1ubuntu1_amd64.deb GObject introspection data for the Totem Playlist Parser library
gir1.2-tracker-1.0_1.6.2-0ubuntu1_amd64.deb GObject introspection data for Tracker
gir1.2-udisks-2.0_2.1.7-1ubuntu1_amd64.deb GObject based library to access udisks2 - introspection data
gir1.2-unity-5.0_7.1.4+15.10.20151002-0ubuntu2_amd64.deb GObject introspection data for the Unity library
gir1.2-unity-webapps-0.2_2.5.0~+16.04.20160201-0ubuntu1_amd64.deb GObject introspection data for the UnityWebapps library
gir1.2-upowerglib-1.0_0.99.4-2_amd64.deb GObject introspection data for upower
gir1.2-vte-2.91_0.42.5-1ubuntu1_amd64.deb GObject introspection data for the VTE library
gir1.2-webkit2-4.0_2.10.9-1ubuntu1_amd64.deb Web content engine library for GTK+ - GObject introspection data
gir1.2-wnck-3.0_3.14.1-2_amd64.deb GObject introspection data for the WNCK library
gir1.2-xkl-1.0_5.4-0ubuntu2_amd64.deb X Keyboard Extension high-level API - introspection data
Advertisement
Advertisement