gir1.2-ibus-1.0_1.5.11-1ubuntu2_amd64.deb


Advertisement

Description

gir1.2-ibus-1.0 - Intelligent Input Bus - introspection data

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename gir1.2-ibus-1.0_1.5.11-1ubuntu2_amd64.deb
Package name gir1.2-ibus-1.0
Package version 1.5.11
Package release 1ubuntu2
Package architecture amd64
Package type deb
Category introspection
Homepage https://github.com/ibus/ibus/releases
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 64.26 KB
Installed size 368.00 KB
IBus is an Intelligent Input Bus. It is a new input framework for the Linux
OS. It provides full featured and user friendly input method user interface.
It also may help developers to develop input method easily.
This package contains the GObject introspection data which are needed
for developing the IBus applications in various programming languages
with GObject introspection support.

Alternatives

Package Version Architecture Repository
gir1.2-ibus-1.0_1.5.11-1ubuntu2.1_amd64.deb 1.5.11 amd64 Ubuntu Updates Main
gir1.2-ibus-1.0_1.5.11-1ubuntu2.1_i386.deb 1.5.11 i386 Ubuntu Updates Main
gir1.2-ibus-1.0_1.5.11-1ubuntu2_i386.deb 1.5.11 i386 Ubuntu Main
gir1.2-ibus-1.0 - - -

Requires

Name Value
gir1.2-glib-2.0 -
libgirepository-1.0-1 >= 1.41.4-1
libibus-1.0-5 >= 1.5.11-1ubuntu2
python3:any >= 3.3.2-2~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package gir1.2-ibus-1.0_1.5.11-1ubuntu2_amd64.deb
Source Package ibus

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gir1.2-ibus-1.0 deb package:
    # sudo apt-get install gir1.2-ibus-1.0

Files

Path
/usr/lib/python2.7/dist-packages/gi/overrides/IBus.py
/usr/lib/python3/dist-packages/gi/overrides/IBus.py
/usr/lib/x86_64-linux-gnu/girepository-1.0/IBus-1.0.typelib
/usr/share/doc/gir1.2-ibus-1.0/changelog.Debian.gz
/usr/share/doc/gir1.2-ibus-1.0/copyright
/usr/share/lintian/overrides/gir1.2-ibus-1.0

Changelog

2016-01-19 - Iain Lane <iain@orangesquash.org.uk>
ibus (1.5.11-1ubuntu2) xenial; urgency=medium
* debian/ibus.gsettings-override:
- Use system keyboard layout by default (LP: #1240198).
2015-11-30 - Aron Xu <happyaron.xu@gmail.com>
ibus (1.5.11-1ubuntu1) xenial; urgency=medium
* Merge with Debian, remaining changes:
- ubuntu-no-notification.patch: Don't show the notification if not
actually upgrading from a previous version.
- ubuntu-disable-trigger.patch: Disable input method switching
under Unity; it's handled by gnome-settings-daemon.
- ubuntu-forward-panel-properties.patch: Augment the panel service
D-Bus interface so that external consumers can detect when the panel
service properties are changed.
- Switch gnome-icon-theme to adwaita-icon-theme
2015-11-19 - Aron Xu <aron@debian.org>
ibus (1.5.11-1) unstable; urgency=medium
* Replace gnome-icon-theme with adwaita-icon-theme, thanks to Iain Lane
* Imported Upstream version 1.5.11
2015-06-14 - Aron Xu <aron@debian.org>
ibus (1.5.10-1) unstable; urgency=medium
* Imported Upstream version 1.5.10.
* Remove ibus-zz-C.UTF-8.patch, applied upstream.
* Drop python-notify dependency (Closes: #781920).
* Build with python3 only (LP: #1440391).
2014-10-23 - Osamu Aoki <osamu@debian.org>
ibus (1.5.9-1) unstable; urgency=medium
* New upstream release.
2014-10-22 - Osamu Aoki <osamu@debian.org>
ibus (1.5.8-4) unstable; urgency=medium
* Enable M-A. 
2014-10-10 - Osamu Aoki <osamu@debian.org>
ibus (1.5.8-3) unstable; urgency=medium
* Debian jessie has C.UTF-8 but doen't always have en_US.UTF-8.  
Closes: #758385
2014-08-06 - Aron Xu <aron@debian.org>
ibus (1.5.8-2) unstable; urgency=medium
* Disable parallel to try avoid FTBFS on kfreebsd*
2014-08-04 - Osamu Aoki <osamu@debian.org>
ibus (1.5.8-1) unstable; urgency=medium
[ Aron Xu ]
* Allow parallel building
[ Osamu Aoki ]
* Update ibus document with Qt5 support
[ Aron Xu ]
* Imported Upstream version 1.5.8
* Remove patch for chasing HEAD, imported new upstream release
* Remove the patch for updating IBusKeymap jp, applied upstream
* Drop gtk2 version of the password patch because it's never executed
* Drop ibus-541492-xkb.patch
* Drop ibus-530711-preload-sys.patch
* Drop ibus-810211-no-switch-by-no-trigger.patch
* Drop 999-update-po.patch
[ Osamu Aoki ]
* linux-any for ibus-wayland
* Remove some symbols matching ibus-541492-xkb.patch
* Remove old patch for GTK+ 3.6
2014-07-27 - Osamu Aoki <osamu@debian.org>
ibus (1.5.7-2) unstable; urgency=medium
* Fix Japanese keycode/keysym table (upstream accepted patch).
* Build override modules with python-gi-dev and include them 
in gir*. Closes: #754670
* Add debug package. Closes: #754650

See Also

Package Description
gir1.2-ido3-0.1_13.10.0+15.10.20151002-0ubuntu1_amd64.deb Typelib file for libido3-0.1
gir1.2-isocodes-1.2_1.2.2-1_amd64.deb access of iso-codes data and translations - GObject introspection
gir1.2-javascriptcoregtk-4.0_2.10.9-1ubuntu1_amd64.deb JavaScript engine library from WebKitGTK+ - GObject introspection data
gir1.2-json-1.0_1.1.2-0ubuntu1_amd64.deb GLib JSON manipulation library (introspection data)
gir1.2-langtag-0.5_0.5.7-2ubuntu1_amd64.deb library to access tags for identifying languages - introspection
gir1.2-libgcab-1.0_0.7-1_amd64.deb Microsoft Cabinet file manipulation library - gir bindings
gir1.2-lightdm-1_1.18.1-0ubuntu1_amd64.deb Typelib file for liblightdm-1
gir1.2-lokdocview-0.1_5.1.2-0ubuntu1_amd64.deb GTK3 widget wrapping LibreOffice functionality - introspection
gir1.2-mediaart-2.0_1.9.0-2_amd64.deb GObject introspection data for MediaArt library
gir1.2-messagingmenu-1.0_13.10.1+15.10.20150505-0ubuntu1_amd64.deb Messaging Menu - gir bindings
gir1.2-modemmanager-1.0_1.4.12-1ubuntu1_amd64.deb GObject introspection data for modemmanager
gir1.2-nautilus-3.0_3.18.4.is.3.14.3-0ubuntu4_amd64.deb libraries for nautilus components - gir bindings
gir1.2-networkmanager-1.0_1.1.93-0ubuntu4_amd64.deb GObject introspection data for NetworkManager
gir1.2-nma-1.0_1.1.93-1ubuntu1_amd64.deb GObject introspection data for libnma
gir1.2-nmgtk-1.0_1.1.93-1ubuntu1_amd64.deb GObject introspection data for libnm-gtk
Advertisement
Advertisement