gir1.2-gnomedesktop-3.0_3.18.2-1ubuntu1_amd64.deb


Advertisement

Description

gir1.2-gnomedesktop-3.0 - Introspection data for GnomeDesktop

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename gir1.2-gnomedesktop-3.0_3.18.2-1ubuntu1_amd64.deb
Package name gir1.2-gnomedesktop-3.0
Package version 3.18.2
Package release 1ubuntu1
Package architecture amd64
Package type deb
Category gnome
Homepage -
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 8.42 KB
Installed size 192.00 KB
This package provides the include files and static library for the GNOME
desktop library functions.
This package contains the introspection data for GnomeDesktop

Alternatives

Package Version Architecture Repository
gir1.2-gnomedesktop-3.0_3.18.2-1ubuntu1_i386.deb 3.18.2 i386 Ubuntu Main
gir1.2-gnomedesktop-3.0 - - -

Requires

Name Value
gir1.2-gdesktopenums-3.0 -
gir1.2-glib-2.0 -
gir1.2-gtk-3.0 -
libgirepository-1.0-1 >= 1.41.4-1
libgnome-desktop-3-12 >= 3.18.1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package gir1.2-gnomedesktop-3.0_3.18.2-1ubuntu1_amd64.deb
Source Package gnome-desktop3

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gir1.2-gnomedesktop-3.0 deb package:
    # sudo apt-get install gir1.2-gnomedesktop-3.0

Files

Path
/usr/lib/x86_64-linux-gnu/girepository-1.0/GnomeDesktop-3.0.typelib
/usr/share/doc/gir1.2-gnomedesktop-3.0/AUTHORS
/usr/share/doc/gir1.2-gnomedesktop-3.0/NEWS.gz
/usr/share/doc/gir1.2-gnomedesktop-3.0/README
/usr/share/doc/gir1.2-gnomedesktop-3.0/changelog.Debian.gz
/usr/share/doc/gir1.2-gnomedesktop-3.0/copyright

Changelog

2015-11-17 - Sebastien Bacher <seb128@ubuntu.com>
gnome-desktop3 (3.18.2-1ubuntu1) xenial; urgency=medium
* Resynchronize on Debian, remaining changes
- debian/patches:
+ 04_compute_average_color.patch: Compute the avergage color in
gnome-desktop itself, not in unity to fix some races (LP #963140)
+ tweak_color_computation.patch, Patch from Gord, no patch header,
no bug link.
+ git_revert_draw_background.patch
+ ubuntu_language.patch, Ported relevant bits from g-c-c 
52_region_language.patch, as required for gnome 3.8 region panel
+ ubuntu_language_list_from_SUPPORTED.patch,
adds api to get list of available languages from SUPPORTED file.
To be used by gnome 3.8 region panel language installation.
+ gnomebg_hidpi_image.patch,
gnome_bg_create_surface: always honor device scale, that fixes
the wallpaper rendering in hidpi config under ubiquity (lp: #1382291)
- debian/libgnome-desktop-3-12.symbols:
+ Add symbols included in Ubuntu patches
- debian/control.in:
+ Mark gnome-desktop3-data Multi-Arch: foreign
2015-11-11 - Michael Biebl <biebl@debian.org>
gnome-desktop3 (3.18.2-1) unstable; urgency=medium
[ Laurent Bigonville ]
* debian/rules: Pass --disable-date-in-gnome-version to the configure to
make the build reproducible (Closes: #784318)
[ Michael Biebl ]
* New upstream release.
2015-10-14 - Jackson Doak <noskcaj@ubuntu.com>
gnome-desktop3 (3.18.1-1ubuntu1) xenial; urgency=low
* Merge with Debian (LP: #1510813), Remaining changes:
- debian/patches:
+ 04_compute_average_color.patch: Compute the avergage color in
gnome-desktop itself, not in unity to fix some races (LP #963140)
+ tweak_color_computation.patch, Patch from Gord, no patch header,
no bug link.
+ git_revert_draw_background.patch
+ ubuntu_language.patch, Ported relevant bits from g-c-c 
52_region_language.patch, as required for gnome 3.8 region panel
+ ubuntu_language_list_from_SUPPORTED.patch,
adds api to get list of available languages from SUPPORTED file.
To be used by gnome 3.8 region panel language installation.
+ gnomebg_hidpi_image.patch,
gnome_bg_create_surface: always honor device scale, that fixes
the wallpaper rendering in hidpi config under ubiquity (lp: #1382291)
- debian/libgnome-desktop-3-12.symbols:
+ Add symbols included in Ubuntu patches
- debian/control.in:
+ Mark gnome-desktop3-data Multi-Arch: foreign
2015-10-14 - Michael Biebl <biebl@debian.org>
gnome-desktop3 (3.18.1-1) unstable; urgency=medium
[ Andreas Henriksson ]
* libgnome-desktop-3-12: Add Breaks: libgnome-desktop-3-10
- Forces a full upgrade. This is to prevent applications linking to
and using both at the same time (which leads to crashed). That
happens in eg. gdm3 built against libgnome-desktop-3-10 when using
gir1.2-gnomedesktop-3.0 3.18.0-1 (built against
libgnome-desktop-3-12).  (Closes: #801603)
[ Michael Biebl ]
* Upload to unstable.
* New upstream release.
* Drop debian/patches/git_update-swedish-translation.patch and
debian/patches/auto_regenerated_sv_indexdocbook.patch, merged upstream.
* Bump Build-Depends on libglib2.0-dev to (>= 2.44.0) as per configure.ac.

See Also

Package Description
gir1.2-gnomekeyring-1.0_3.12.0-1build1_amd64.deb GNOME keyring services library - introspection data
gir1.2-goa-1.0_3.18.3-1ubuntu2_amd64.deb Introspection data for GNOME Online Accounts
gir1.2-gom-1.0_0.3.1-1_amd64.deb GObject introspection data for libgom
gir1.2-grilo-0.2_0.2.15-1_amd64.deb Framework for discovering and browsing media - GObject introspection data
gir1.2-gst-plugins-base-1.0_1.8.0-1ubuntu1_amd64.deb Description: GObject introspection data for the GStreamer Plugins Base library
gir1.2-gstreamer-1.0_1.8.0-1_amd64.deb Description: GObject introspection data for the GStreamer library
gir1.2-gtk-2.0_2.24.30-1ubuntu1_amd64.deb GTK+ graphical user interface library -- gir bindings
gir1.2-gtk-3.0_3.18.9-1ubuntu3_amd64.deb GTK+ graphical user interface library -- gir bindings
gir1.2-gtkclutter-1.0_1.6.6-1_amd64.deb GObject introspection data for the GTK+ Clutter library
gir1.2-gtksource-3.0_3.18.2-1_amd64.deb gir files for the GTK+ syntax highlighting widget
gir1.2-gtkspell3-3.0_3.0.7-2_amd64.deb GObject introspection data for the GtkSpell library
gir1.2-gtop-2.0_2.32.0-1_amd64.deb gtop system monitoring library (gir bindings)
gir1.2-gucharmap-2.90_3.18.2-1ubuntu1_amd64.deb GObject introspection data for the Unicode browser widget library
gir1.2-gudev-1.0_230-2_amd64.deb libgudev-1.0 introspection data
gir1.2-gusb-1.0_0.2.9-0ubuntu1_amd64.deb GObject introspection data for libgusb
Advertisement
Advertisement