gir1.2-geocodeglib-1.0_3.18.2-1_amd64.deb


Advertisement

Description

gir1.2-geocodeglib-1.0 - introspection data for geocode-glib library

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename gir1.2-geocodeglib-1.0_3.18.2-1_amd64.deb
Package name gir1.2-geocodeglib-1.0
Package version 3.18.2
Package release 1
Package architecture amd64
Package type deb
Category libs
Homepage -
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 5.39 KB
Installed size 70.00 KB
Geocode-glib allows you to do geocoding (going from a place name,
to a longitude/latitude pair) and reverse geocoding (finding a place
name from coordinates) using the Nominatim service.
This library should be used in place of Geoclue's D-Bus API for
geocoding and reverse geocoding.
This package contains GObjectIntrospection data for geocode-glib.

Alternatives

Package Version Architecture Repository
gir1.2-geocodeglib-1.0_3.18.2-1_i386.deb 3.18.2 i386 Ubuntu Main
gir1.2-geocodeglib-1.0 - - -

Requires

Name Value
gir1.2-glib-2.0 -
gir1.2-json-1.0 -
gir1.2-soup-2.4 -
libgeocode-glib0 >= 3.16.2
libgirepository-1.0-1 >= 1.41.4-1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package gir1.2-geocodeglib-1.0_3.18.2-1_amd64.deb
Source Package geocode-glib

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gir1.2-geocodeglib-1.0 deb package:
    # sudo apt-get install gir1.2-geocodeglib-1.0

Files

Path
/usr/lib/x86_64-linux-gnu/girepository-1.0/GeocodeGlib-1.0.typelib
/usr/share/doc/gir1.2-geocodeglib-1.0/AUTHORS
/usr/share/doc/gir1.2-geocodeglib-1.0/NEWS.gz
/usr/share/doc/gir1.2-geocodeglib-1.0/README
/usr/share/doc/gir1.2-geocodeglib-1.0/TODO
/usr/share/doc/gir1.2-geocodeglib-1.0/changelog.Debian.gz
/usr/share/doc/gir1.2-geocodeglib-1.0/copyright

Changelog

2016-02-22 - Michael Biebl <biebl@debian.org>
geocode-glib (3.18.2-1) unstable; urgency=medium
* New upstream release.
2016-02-18 - Michael Biebl <biebl@debian.org>
geocode-glib (3.18.1-1) unstable; urgency=medium
* New upstream release.
* Change Build-Depends on libsoup-gnome2.4-dev to libsoup2.4-dev and bump
the required version to (>= 2.42) as per configure.ac.
* Drop libgeocode-glib-dbg now that we have automatic dbgsym packages.
* Bump Standards-Version to 3.9.7.
2015-09-24 - Andreas Henriksson <andreas@fatal.se>
geocode-glib (3.18.0-1) unstable; urgency=medium
[ Michael Biebl ]
* Update copyright Format to the final specification 1.0.
[ Andreas Henriksson ]
* New upstream release.
2015-05-23 - Michael Biebl <biebl@debian.org>
geocode-glib (3.16.2-1) unstable; urgency=medium
* New upstream release.
* Update symbols file, add new symbols.
* Fix typo in the short package description of libgeocode-glib-dev.
* Convert to multiarch.
* Bump debhelper compatibility level to 9.
* Bump Standards-Version to 3.9.6.
2014-09-23 - Andreas Henriksson <andreas@fatal.se>
geocode-glib (3.14.0-1) unstable; urgency=medium
* New upstream release.
* Upload to unstable.
2014-09-06 - Sjoerd Simons <sjoerd@debian.org>
geocode-glib (3.13.3-1) experimental; urgency=medium
[ Andreas Henriksson ]
* debian/watch: only scan for stable releases.
[ Sjoerd Simons ]
* New upstream release
2014-05-16 - Andreas Henriksson <andreas@fatal.se>
geocode-glib (3.12.2-1) unstable; urgency=medium
* New upstream release.
* Update debian/libgeocode-glib0.symbols with one added symbol.
* Make build fail on symbols file mismatch
2014-03-26 - Andreas Henriksson <andreas@fatal.se>
geocode-glib (3.12.0-1) unstable; urgency=medium
* New upstream release.
* Bump json-glib build-dependency to 0.99.2 according to configure.ac
* Update debian/libjson-glib0.symbols:
- dropped symbol "_geocode_place_set_icon" which has no users in debian
and was probably a mistake to export in the first place.
- multiple additions.
* Install /usr/share/icons/gnome in libgeocode-glib0
- (future versions bumping soname will need to use Replaces.)
* Bump Standards-Version 3.9.5
2013-09-24 - Andreas Henriksson <andreas@fatal.se>
geocode-glib (3.10.0-1) unstable; urgency=low
* New upstream release.
* Drop build-dependency on libgeoip-dev
- geoip code has moved to geoclue
* Bump json-glib build-dependency to >= 0.16.2
* Update install path for documentation to include api-version (-1.0)
* Update debian/libgeocode-glib0.symbols
- several missing symbols, none seems to be used though.
2013-08-14 - Andreas Henriksson <andreas@fatal.se>
geocode-glib (0.99.1-1) unstable; urgency=medium
[ Michael Biebl ]
* Change section of gir1.2-geocodeglib-1.0 to introspection.
[ Andreas Henriksson ]
* Update debian/watch to look for tar.xz files.
* New upstream release.
- bump json-glib build-dependency to >= 0.14
- add build-dependency on libgeoip-dev
- debian/libgeocode-glib-dev.install updated for api-versioned
include directory path.
- debian/libgeocode-glib0.symbols updated for new (and dropped)
symbols. The library still does not give any API guarantees.
* Add breaks against empathy << 3.4.2.3-4~, since that version was the first
to get updated for geocode-glib 0.99.1 API patched in (backported from
upstream release 3.7.3).
(Several dropped symbols where previously used:
"geocode_object_get_coords", "geocode_object_new_for_params",
"geocode_object_resolve_async" and "geocode_object_resolve_finish".)
* Bump Standards-Version to 3.9.4
* Replace Yahoo Place Finder API with Nominatim in package descriptions.

See Also

Package Description
gir1.2-gexiv2-0.10_0.10.3-2_amd64.deb GObject-based wrapper around the Exiv2 library - introspection data
gir1.2-gkbd-3.0_3.6.0-1ubuntu2_amd64.deb GObject introspection data for the GnomeKbd library
gir1.2-glib-2.0_1.46.0-3ubuntu1_amd64.deb Introspection data for GLib, GObject, Gio and GModule
gir1.2-gmenu-3.0_3.13.3-6ubuntu3_amd64.deb GObject introspection data for the GNOME menu library
gir1.2-gnomebluetooth-1.0_3.18.2-1ubuntu2_amd64.deb Introspection data for GnomeBluetooth
gir1.2-gnomedesktop-3.0_3.18.2-1ubuntu1_amd64.deb Introspection data for GnomeDesktop
gir1.2-gnomekeyring-1.0_3.12.0-1build1_amd64.deb GNOME keyring services library - introspection data
gir1.2-goa-1.0_3.18.3-1ubuntu2_amd64.deb Introspection data for GNOME Online Accounts
gir1.2-gom-1.0_0.3.1-1_amd64.deb GObject introspection data for libgom
gir1.2-grilo-0.2_0.2.15-1_amd64.deb Framework for discovering and browsing media - GObject introspection data
gir1.2-gst-plugins-base-1.0_1.8.0-1ubuntu1_amd64.deb Description: GObject introspection data for the GStreamer Plugins Base library
gir1.2-gstreamer-1.0_1.8.0-1_amd64.deb Description: GObject introspection data for the GStreamer library
gir1.2-gtk-2.0_2.24.30-1ubuntu1_amd64.deb GTK+ graphical user interface library -- gir bindings
gir1.2-gtk-3.0_3.18.9-1ubuntu3_amd64.deb GTK+ graphical user interface library -- gir bindings
gir1.2-gtkclutter-1.0_1.6.6-1_amd64.deb GObject introspection data for the GTK+ Clutter library
Advertisement
Advertisement