gir1.2-gcr-3_3.18.0-1ubuntu1_amd64.deb


Advertisement

Description

gir1.2-gcr-3 - GObject introspection data for the GCR library

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename gir1.2-gcr-3_3.18.0-1ubuntu1_amd64.deb
Package name gir1.2-gcr-3
Package version 3.18.0
Package release 1ubuntu1
Package architecture amd64
Package type deb
Category introspection
Homepage https://wiki.gnome.org/Projects/GnomeKeyring
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 13.65 KB
Installed size 80.00 KB
This package contains introspection data for GCR, a library for crypto UI
and related tasks.
It can be used by interpreters understanding the GIRepository format to
write programs using the GCR library.

Alternatives

Package Version Architecture Repository
gir1.2-gcr-3_3.18.0-1ubuntu1_i386.deb 3.18.0 i386 Ubuntu Main
gir1.2-gcr-3 - - -

Requires

Name Value
gir1.2-gck-1 = 3.18.0-1ubuntu1
gir1.2-glib-2.0 -
gir1.2-gtk-3.0 -
libgcr-base-3-1 >= 3.12.0
libgcr-ui-3-1 >= 3.12.0
libgirepository-1.0-1 >= 1.41.4-1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package gir1.2-gcr-3_3.18.0-1ubuntu1_amd64.deb
Source Package gcr

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gir1.2-gcr-3 deb package:
    # sudo apt-get install gir1.2-gcr-3

Files

Path
/usr/lib/x86_64-linux-gnu/girepository-1.0/Gcr-3.typelib
/usr/lib/x86_64-linux-gnu/girepository-1.0/GcrUi-3.typelib
/usr/share/doc/gir1.2-gcr-3/AUTHORS
/usr/share/doc/gir1.2-gcr-3/NEWS.gz
/usr/share/doc/gir1.2-gcr-3/README
/usr/share/doc/gir1.2-gcr-3/changelog.Debian.gz
/usr/share/doc/gir1.2-gcr-3/copyright

Changelog

2015-10-23 - Sebastien Bacher <seb128@ubuntu.com>
gcr (3.18.0-1ubuntu1) xenial; urgency=medium
* Resynchronize on Debian, remaining change
* d/p/0001-gcr-prompt-dialog-Allow-the-use-of-mnemonics-in-the-.patch:
Apply patch to allow mnemonics in prompt dialogs choice labels.
2015-10-08 - Michael Biebl <biebl@debian.org>
gcr (3.18.0-1) unstable; urgency=medium
* New upstream release.
* Bump Build-Depends on libgtk-3-dev to (>= 3.12.0) as per configure.ac.
* Switch Build-Depends from transitional libgcrypt11-dev to libgcrypt20-dev.
2015-05-24 - Michael Biebl <biebl@debian.org>
gcr (3.16.0-1) unstable; urgency=medium
* New upstream release.
* Drop debian/patches/bgo737622.patch, merged upstream.
* Drop obsolete Breaks and Replaces from pre-wheezy.
* Set pkg-gnome-maintainers@lists.alioth.debian.org as Maintainer.
* Install typelib files into multiarch paths.
* Mark gir and dev packages as Multi-Arch: same and the doc packages as
Multi-Arch: foreign.
* Drop transitional package libgcr-3-1, which contained nothing but a few
compat symlinks. All reverse dependencies have been updated, so it's no
longer needed.
* Update Homepage: URL.
* Bump Standards-Version to 3.9.6.
* Bump Build-Depends on libgtk-3-dev to (>= 3.10.0) as per configure.ac.
* Update dependencies of the dev packages as specified in their .pc files.
* Fix debian/libgck-1-0.symbols, sort entries and remove duplicates.
2014-09-30 - Andreas Henriksson <andreas@fatal.se>
gcr (3.14.0-2) unstable; urgency=medium
* Add debian/patches/bgo737622.patch
- fix race in Makefile to avoid FTBFS.
2014-09-23 - Andreas Henriksson <andreas@fatal.se>
gcr (3.14.0-1) unstable; urgency=medium
* New upstream release.
* Update build-dependencies according to configure.ac changes:
+ Bump libglib2.0-dev to >= 2.38.0
+ Bump libgcrypt11-dev to >= 1.4.5
* Update debian/libgcr-base-3-1.symbols
2014-05-16 - Andreas Henriksson <andreas@fatal.se>
gcr (3.12.2-1) unstable; urgency=medium
* New upstream release.
2014-03-23 - Andreas Henriksson <andreas@fatal.se>
gcr (3.12.0-1) unstable; urgency=medium
[ Laurent Bigonville ]
* debian/control.in: Switch to libtasn1-6-dev and libtasn1-6-bin
(Closes: #715354)
[ Andreas Henriksson ]
* New upstream release.
* Add explicit xsltproc build-dependency (used by introspection generation)
* Drop debian/patches, both patches include in upstream release.
- debian/patches/Allow-valgrind-support-to-be-completely-disabled.patch
- debian/patches/Fix-compilation-if-valgrind-support-is-completely-.patch
* Fix {build-,}dependency: libtasn1-6-bin -> libtasn1-bin
* Add 2 new symbols to debian/libgck-1-0.symbols
* Add 7 new symbols to debian/libgcr-base-3-1.symbols
* Add 3 new symbols to debian/libgcr-ui-3-1.symbols
* Bump Standards-Version to 3.9.5
* libgck-1-dev: install usr/share/vala/vapi/pkcs11.vapi
2013-10-26 - Sjoerd Simons <sjoerd@debian.org>
gcr (3.10.1-1) experimental; urgency=low
* New upstream release
* d/p/0001-fix-build-error-with-Werror-format-security.patch
+ Dropped, fixed upstream
* Enable vala bindings
2013-06-30 - Laurent Bigonville <bigon@debian.org>
gcr (3.8.2-4) unstable; urgency=low
[ Jeremy Bicha ]
* Update homepage
[ Laurent Bigonville ]
* d/p/Allow-valgrind-support-to-be-completely-disabled.patch,
d/p/Fix-compilation-if-valgrind-support-is-completely-.patch,
debian/rules: Disable valgrind macros, this is seems to cause
miscompilations on some architectures (Closes: #678496)
* debian/rules, debian/control: Add call to dh-autoreconf
2013-06-18 - Laurent Bigonville <bigon@debian.org>
gcr (3.8.2-3) unstable; urgency=low
* debian/control.in
- Fix typo in gir1.2-gcr-3 long description (Closes: #699679)
- Use canonical URL for Vcs-Svn field
* debian/rules: Use DEB_LDFLAGS_MAINT_APPEND instead of LDFLAGS and include
buildflags.mk to avoid overriding hardening flags
* Bump debhelper and cdbs build-dependencies and convert the package to
multi-arch (Closes: #692743)

See Also

Package Description
gir1.2-gdata-0.0_0.17.4-1_amd64.deb GObject introspection data for the GData webservices library
gir1.2-gdesktopenums-3.0_3.18.1-1ubuntu1_amd64.deb GObject introspection for GSettings desktop-wide schemas
gir1.2-gdkpixbuf-2.0_2.32.2-1ubuntu1_amd64.deb GDK Pixbuf library - GObject-Introspection
gir1.2-gee-0.8_0.18.0-1_amd64.deb GObject based collection and utility library (GObject-Introspection)
gir1.2-geocodeglib-1.0_3.18.2-1_amd64.deb introspection data for geocode-glib library
gir1.2-gexiv2-0.10_0.10.3-2_amd64.deb GObject-based wrapper around the Exiv2 library - introspection data
gir1.2-gkbd-3.0_3.6.0-1ubuntu2_amd64.deb GObject introspection data for the GnomeKbd library
gir1.2-glib-2.0_1.46.0-3ubuntu1_amd64.deb Introspection data for GLib, GObject, Gio and GModule
gir1.2-gmenu-3.0_3.13.3-6ubuntu3_amd64.deb GObject introspection data for the GNOME menu library
gir1.2-gnomebluetooth-1.0_3.18.2-1ubuntu2_amd64.deb Introspection data for GnomeBluetooth
gir1.2-gnomedesktop-3.0_3.18.2-1ubuntu1_amd64.deb Introspection data for GnomeDesktop
gir1.2-gnomekeyring-1.0_3.12.0-1build1_amd64.deb GNOME keyring services library - introspection data
gir1.2-goa-1.0_3.18.3-1ubuntu2_amd64.deb Introspection data for GNOME Online Accounts
gir1.2-gom-1.0_0.3.1-1_amd64.deb GObject introspection data for libgom
gir1.2-grilo-0.2_0.2.15-1_amd64.deb Framework for discovering and browsing media - GObject introspection data
Advertisement
Advertisement