ghostscript-x_9.18~dfsg~0-0ubuntu2_amd64.deb


Advertisement

Description

ghostscript-x - interpreter for the PostScript language and for PDF - X11 support

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename ghostscript-x_9.18~dfsg~0-0ubuntu2_amd64.deb
Package name ghostscript-x
Package version 9.18~dfsg~0
Package release 0ubuntu2
Package architecture amd64
Package type deb
Category text
Homepage http://www.ghostscript.com/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 33.43 KB
Installed size 202.00 KB
GPL Ghostscript is used for PostScript/PDF preview and printing.
Usually as a back-end to a program such as ghostview, it can display
PostScript and PDF documents in an X11 environment.
This package contains the GPL Ghostscript output device for X11.

Alternatives

Package Version Architecture Repository
ghostscript-x_9.26~dfsg+0-0ubuntu0.16.04.8_amd64.deb 9.26~dfsg+0 amd64 Ubuntu Updates Main
ghostscript-x_9.26~dfsg+0-0ubuntu0.16.04.8_i386.deb 9.26~dfsg+0 i386 Ubuntu Updates Main
ghostscript-x_9.18~dfsg~0-0ubuntu2_i386.deb 9.18~dfsg~0 i386 Ubuntu Main
ghostscript-x - - -

Requires

Name Value
ghostscript = 9.18~dfsg~0-0ubuntu2
libc6 >= 2.14
libx11-6 -
libxt6 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package ghostscript-x_9.18~dfsg~0-0ubuntu2_amd64.deb
Source Package ghostscript

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ghostscript-x deb package:
    # sudo apt-get install ghostscript-x

Files

Path
/usr/lib/ghostscript/9.18/X11.so
/usr/share/doc/ghostscript-x/NEWS.Debian.gz
/usr/share/doc/ghostscript-x/changelog.Debian.gz
/usr/share/doc/ghostscript-x/copyright

Changelog

2016-02-29 - Sebastien Bacher <seb128@ubuntu.com>
ghostscript (9.18~dfsg~0-0ubuntu2) xenial; urgency=medium
* Backport change from Debian 
"Add patch cherry-picked upstream to fix add gserrors.h to the
installed files for the so-install target."
2016-02-12 - Till Kamppeter <till.kamppeter@gmail.com>
ghostscript (9.18~dfsg~0-0ubuntu1) xenial; urgency=medium
* New upstream release
- Ghostscript 9.18
- A new method of internally inserting devices into the device chain has
been developed, named "device subclassing". This allows suitably
written devices to be more easily and consistently as "filter" devices.
The first fruit of this is a new implementation of the
"-dFirstPage"/"-dLastPage" feature which functions a device filter in
the Ghostscript graphics library, meaning it works consistently with
all input languages.
- Plus the usual round of bug fixes, compatibility changes, and incremental
improvements.
* 020150523_d73a342_gdevcups_support_color_spaces_18_19_20.patch,
020150724_0c0b085_sanity_check_for_memory_allocation.patch: Removed,
included upstream.
* 2001_docdir_fix_for_debian.patch,
1002_pxl-make-dicctransform-default.patch: Refreshed with quilt.
* debian/symbols.common: Updated for new upstream source. Applied patch
which dpkg-gensymbols generated for debian/libgs9.symbols to this file.
2016-01-27 - Matthias Klose <doko@ubuntu.com>
ghostscript (9.16~dfsg~0-0ubuntu4) xenial; urgency=medium
* Multiarchify the library packages.
2015-09-19 - Till Kamppeter <till.kamppeter@gmail.com>
ghostscript (9.16~dfsg~0-0ubuntu3) wily; urgency=medium
* debian/rules: Demote texlive-lang-cjk from Recommends: to Suggests:
as it pulls in a large amount of unneeded packages (LP: #1449875).
2015-09-18 - Till Kamppeter <till.kamppeter@gmail.com>
ghostscript (9.16~dfsg~0-0ubuntu2) wily; urgency=medium
* debian/rules: Recommend texlive-lang-cjk as some files make
Ghostscript fail (LP: #1449875).

See Also

Package Description
ghostscript_9.18~dfsg~0-0ubuntu2_amd64.deb interpreter for the PostScript language and for PDF
giflib-tools_5.1.2-0.2_amd64.deb library for GIF images (utilities)
gir1.2-a11yprofilemanager-0.1_0.1.10-0ubuntu3_amd64.deb Accessibility Profile Manager - GObject introspection
gir1.2-accountplugin-1.0_0.1.8+16.04.20160201-0ubuntu1_amd64.deb typelib file for libaccount-plugin-1.0-0
gir1.2-accounts-1.0_1.21+16.04.20160222-0ubuntu1_amd64.deb typelib file for libaccounts-glib0
gir1.2-accountsservice-1.0_0.6.40-2ubuntu10_amd64.deb GObject introspection data for AccountService
gir1.2-appindicator-0.1_12.10.1+15.04.20141110-0ubuntu1_amd64.deb Typelib files for libappindicator1
gir1.2-appindicator3-0.1_12.10.1+15.04.20141110-0ubuntu1_amd64.deb Typelib files for libappindicator3-1
gir1.2-appstream_0.9.4-1_amd64.deb Library to access AppStream services (introspection data)
gir1.2-appstreamglib-1.0_0.5.13-1_amd64.deb GObject introspection data for the libappstream-glib library
gir1.2-atk-1.0_2.18.0-1_amd64.deb ATK accessibility toolkit (GObject introspection)
gir1.2-atspi-2.0_2.18.3-4ubuntu1_amd64.deb Assistive Technology Service Provider (GObject introspection)
gir1.2-bamf-3_0.5.3~bzr0+16.04.20160415-0ubuntu1_amd64.deb GObject introspection data for the Bamf library
gir1.2-cheese-3.0_3.18.1-2ubuntu3_amd64.deb tool to take pictures and videos from your webcam - gir bindings
gir1.2-click-0.4_0.4.43+16.04.20160203-0ubuntu2_amd64.deb GIR bindings for Click package management library
Advertisement
Advertisement