fuse_2.9.4-1ubuntu3_amd64.deb


Advertisement

Description

fuse - Filesystem in Userspace

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename fuse_2.9.4-1ubuntu3_amd64.deb
Package name fuse
Package version 2.9.4
Package release 1ubuntu3
Package architecture amd64
Package type deb
Category utils
Homepage http://fuse.sourceforge.net/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 23.87 KB
Installed size 104.00 KB
Filesystem in Userspace (FUSE) is a simple interface for userspace programs to
export a virtual filesystem to the Linux kernel. It also aims to provide a
secure method for non privileged users to create and mount their own filesystem
implementations.

Alternatives

Package Version Architecture Repository
fuse_2.9.4-1ubuntu3.1_amd64.deb 2.9.4 amd64 Ubuntu Updates Main
fuse_2.9.4-1ubuntu3.1_i386.deb 2.9.4 i386 Ubuntu Updates Main
fuse_2.9.4-1ubuntu3_i386.deb 2.9.4 i386 Ubuntu Main
fuse - - -

Requires

Name Value
adduser -
libc6 >= 2.14
libfuse2 = 2.9.4-1ubuntu3
mount >= 2.19.1
sed >= 4

Download

Type URL
Mirror archive.ubuntu.com
Binary Package fuse_2.9.4-1ubuntu3_amd64.deb
Source Package fuse

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install fuse deb package:
    # sudo apt-get install fuse

Files

Path
/bin/fusermount
/bin/ulockmgr_server
/etc/fuse.conf
/sbin/mount.fuse
/usr/share/doc/fuse/changelog.Debian.gz
/usr/share/doc/fuse/copyright
/usr/share/initramfs-tools/hooks/fuse
/usr/share/lintian/overrides/fuse
/usr/share/man/man1/fusermount.1.gz
/usr/share/man/man1/ulockmgr_server.1.gz
/usr/share/man/man8/mount.fuse.8.gz

Changelog

2016-03-11 - Dimitri John Ledkov <xnox@ubuntu.com>
fuse (2.9.4-1ubuntu3) xenial; urgency=medium
* Drop modprobing fuse module, it's builtin on ubuntu.
* Drop creating /dev/fuse, udev does it for us. (LP: #1556143).
* Drop udev|makedev dependency.
2016-02-23 - Dimitri John Ledkov <xnox@ubuntu.com>
fuse (2.9.4-1ubuntu2) xenial; urgency=medium
* Upgrade /etc/fuse.conf permissions to current default of 0644. (LP: #794494)
2015-06-24 - Artur Rona <ari-tczew@ubuntu.com>
fuse (2.9.4-1ubuntu1) wily; urgency=low
* Merge from Debian unstable. (LP: #1468314) Remaining changes:
- debian/fuse-udeb.install:
+ Install ulockmgr_server.
- debian/fuse.udev:
+ Don't install the udev rules; we require the fuse module to be
built-in, and mountall/systemd handle mounting /sys/fs/fuse/connections.
2015-06-09 - Laszlo Boszormenyi (GCS) <gcs@debian.org>
fuse (2.9.4-1) unstable; urgency=low
* New upstream release.
* Don't use modules-load.d anymore (closes: #773894).
* Guard lsmod call in postinst (closes: #767829).
2015-05-24 - Artur Rona <ari-tczew@ubuntu.com>
fuse (2.9.3-16ubuntu1) wily; urgency=low
* Merge from Debian unstable. (LP: #1458397) Remaining changes:
- debian/fuse-udeb.install:
+ Install ulockmgr_server.
- debian/fuse.udev:
+ Don't install the udev rules; we require the fuse module to be
built-in, and mountall/systemd handle mounting /sys/fs/fuse/connections.
* Drop following change, no longer applicable:
- debian/fuse.postinst:
+ Only change the ownership or mode of /etc/fuse.conf
on initial installation.
- Drop the Ubuntu specific way of making fusermount suid root. Using
dpkg-statoverride for this works perfectly well and allows admins to
un-setuid it. [Martin Pitt]
2015-05-21 - Laszlo Boszormenyi (GCS) <gcs@debian.org>
fuse (2.9.3-16) unstable; urgency=high
* Sync with Ubuntu.
* Update Standards-Version to 3.9.6 .
[ Marc Deslauriers <marc.deslauriers@ubuntu.com> ]
* SECURITY UPDATE: privilege escalation via insecure environment
- debian/patches/CVE-2015-3202.patch: use execle to run external
helpers in lib/mount_util.c, util/mount_util.c.
- CVE-2015-3202 (closes: #786439).
2014-07-31 - Laszlo Boszormenyi (GCS) <gcs@debian.org>
fuse (2.9.3-15) unstable; urgency=low
* Use correct long option for udevadm in postinst (closes: #756582).
2014-07-30 - Laszlo Boszormenyi (GCS) <gcs@debian.org>
fuse (2.9.3-14) unstable; urgency=low
* New maintainer (closes: #756548).
* Add watch file.
2014-07-25 - Daniel Baumann <daniel@laptop.127011.net>
fuse (2.9.3-13) unstable; urgency=low
* I don't care anymore, not worth it.. orphaning.
2014-06-20 - Daniel Baumann <mail@daniel-baumann.ch>
fuse (2.9.3-12) unstable; urgency=low
* Cherry-picking patch from upstream for arm64 (Closes: #752081).

See Also

Package Description
fwupd_0.7.0-0ubuntu4_amd64.deb Firmware update daemon
fwupdate-signed_1.11+0.5-2ubuntu4_amd64.deb Linux Firmware Updater EFI signed binary
fwupdate_0.5-2ubuntu4_amd64.deb Tools to manage UEFI firmware updates
g++-5-aarch64-linux-gnu_5.3.1-14ubuntu2cross1_amd64.deb GNU C++ compiler
g++-5-arm-linux-gnueabihf_5.3.1-14ubuntu2cross1_amd64.deb GNU C++ compiler
g++-5-multilib_5.3.1-14ubuntu2_amd64.deb GNU C++ compiler (multilib support)
g++-5-powerpc-linux-gnu_5.3.1-14ubuntu2cross1_amd64.deb GNU C++ compiler
g++-5-powerpc64le-linux-gnu_5.3.1-14ubuntu2cross1_amd64.deb GNU C++ compiler
g++-5_5.3.1-14ubuntu2_amd64.deb GNU C++ compiler
g++-aarch64-linux-gnu_5.3.1-1ubuntu1_amd64.deb GNU C++ compiler for the arm64 architecture
g++-arm-linux-gnueabihf_5.3.1-1ubuntu1_amd64.deb GNU C++ compiler for the armhf architecture
g++-multilib_5.3.1-1ubuntu1_amd64.deb GNU C++ compiler (multilib files)
g++-powerpc-linux-gnu_5.3.1-1ubuntu1_amd64.deb GNU C++ compiler for the powerpc architecture
g++-powerpc64le-linux-gnu_5.3.1-1ubuntu1_amd64.deb GNU C++ compiler for the ppc64el architecture
g++_5.3.1-1ubuntu1_amd64.deb GNU C++ compiler
Advertisement
Advertisement