freetds-dev_0.91-6.1build1_amd64.deb


Advertisement

Description

freetds-dev - MS SQL and Sybase client library (static libs and headers)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename freetds-dev_0.91-6.1build1_amd64.deb
Package name freetds-dev
Package version 0.91
Package release 6.1build1
Package architecture amd64
Package type deb
Category devel
Homepage http://www.freetds.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 234.86 KB
Installed size 1.73 MB
FreeTDS is an implementation of the Tabular DataStream protocol, used for
connecting to MS SQL and Sybase servers over TCP/IP.
This package includes the static libraries and header files for TDS, which
you will need to develop applications that connect to MS SQL servers.  You
will also need this package if you are installing the Perl DBD::Sybase
module on your system using CPAN.

Alternatives

Package Version Architecture Repository
freetds-dev_0.91-6.1build1_i386.deb 0.91 i386 Ubuntu Main
freetds-dev - - -

Requires

Name Value
libct4 = 0.91-6.1build1
libsybdb5 = 0.91-6.1build1

Conflicts

Name Value
crystalspace-dev -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package freetds-dev_0.91-6.1build1_amd64.deb
Source Package freetds

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install freetds-dev deb package:
    # sudo apt-get install freetds-dev

Files

Path
/usr/include/bkpublic.h
/usr/include/cspublic.h
/usr/include/cstypes.h
/usr/include/ctpublic.h
/usr/include/odbcss.h
/usr/include/sqldb.h
/usr/include/sqlfront.h
/usr/include/sybdb.h
/usr/include/syberror.h
/usr/include/sybfront.h
/usr/include/tds_sysdep_public.h
/usr/lib/x86_64-linux-gnu/libct.a
/usr/lib/x86_64-linux-gnu/libct.so
/usr/lib/x86_64-linux-gnu/libsybdb.a
/usr/lib/x86_64-linux-gnu/libsybdb.so
/usr/share/doc/freetds-dev/changelog.Debian.gz
/usr/share/doc/freetds-dev/copyright

Changelog

2016-02-17 - Matthias Klose <doko@ubuntu.com>
freetds (0.91-6.1build1) xenial; urgency=medium
* No-change rebuild for gnutls transition.
2015-07-26 - Andreas Metzler <ametzler@debian.org>
freetds (0.91-6.1) unstable; urgency=low
* Non-maintainer upload.
* Use gnutls_priority_set_direct with a priority string of NORMAL:%COMPAT
instead of deprecated gnutls_{cipher,kx,...}_set_priority functions. This
uses the same priority string as 7ca9321ff440814581a8ec87984f7d76f8cc105e
from upstream GIT, except for not disabling SSL3.0 since Debian's GnuTLS
does not enable SSL3 by default. Closes: #782818
2014-05-08 - Steve Langasek <vorlon@debian.org>
freetds (0.91-6) unstable; urgency=low
* Build against libgnutls28, now that license compatibility issues
with GPLv2-only software have been resolved.  This includes patching
the upstream source to not look for gcrypt, which is no longer needed.
Thanks to Dimitri Ledkov <dimitri.ledkov@canonical.com> for the patch.
Closes: #747449.
2013-09-11 - Steve Langasek <vorlon@debian.org>
freetds (0.91-5) unstable; urgency=low
* Add Kerberos support.  LP: #1223567.
* Stop overriding CPPFLAGS in debian/rules, giving us full proper
hardening support.  Closes: #665268.
* src/odbc/odbc.c: cherry-pick upstream fix for a segfault due to an
uninitialized value.  Thanks to Lionel Elie Mamane <lionel@mamane.lu>
for the fix.  Closes: #650422.
* Allow parallel builds.  Closes: #650421.
* Drop manual autotools patching for dh-autoreconf, fixing builds on
x32 et al.  Closes: #699069.
* Properly bump the build-dep on debhelper to 9.
* Bump to Standards-Version 3.9.4, no changes required.
* Convert copyright file to copyright-format 1.0.
* src/apps/bsqldb.c, src/apps/bsqlodbc.c: fix wrong getopt() option
strings so that arguments to -d are parsed correctly.
Closes: #715697, #715698.
* src/apps/datacopy.c: handle a lack of login/password information
without segfaulting.  Closes: #715785.
2013-05-26 - Steve Langasek <vorlon@debian.org>
freetds (0.91-4) unstable; urgency=low
* Version the breaks: on libiodbc2 now that a fixed version is available
in unstable.
2013-04-03 - Steve Langasek <vorlon@debian.org>
freetds (0.91-3) unstable; urgency=low
* configure.ac: check for libgcrypt in addition to libgnutls, since we
use it directly and will need to link to it in future versions of gcc.
Thanks to Logan Rosen <logan@ubuntu.com> for reporting.  Closes: #704572.
* Also, build-depend explicitly on libgcrypt-dev.
2012-10-12 - Steve Langasek <vorlon@debian.org>
freetds (0.91-2) unstable; urgency=low
* Don't both breaks and recommends libiodbc2, this confuses apt.
Closes: #645726.
2011-11-14 - Steve Langasek <vorlon@debian.org>
freetds (0.91-1) unstable; urgency=low
* New upstream release.  Closes: #852069, LP: #887374.
- Built with new libtool, so should be compatible with binutils-gold.
Closes: #558548.
- Includes fix for upstream corruption seen with Hebrew strings.
Closes: #500451.
- drop patch to src/tds/locale.c; upstream seems to now support fairly
complete autodetection of the client locale.
- update symbols files for two new symbols.
* Pass -DDBLIB_UNIMPLEMENTED=1 so we get a full set of symbols in
libsybdb, even if some functions are not yet implemented.
* Switch to using dpkg-buildflags for hardening.
* src/apps/bsqldb.c: fix a build failure with -Werror=format-security.
* Build-depend on libgnutls-dev for TLS support.  LP: #406468.
* Build-depend on libreadline-dev, which makes freetds-bin a bit more
useful.

See Also

Package Description
friendly-recovery_0.2.31_all.deb Make recovery more user-friendly
ftp_0.17-33_amd64.deb classical file transfer client
fuse_2.9.4-1ubuntu3_amd64.deb Filesystem in Userspace
fwupd_0.7.0-0ubuntu4_amd64.deb Firmware update daemon
fwupdate-signed_1.11+0.5-2ubuntu4_amd64.deb Linux Firmware Updater EFI signed binary
fwupdate_0.5-2ubuntu4_amd64.deb Tools to manage UEFI firmware updates
g++-5-aarch64-linux-gnu_5.3.1-14ubuntu2cross1_amd64.deb GNU C++ compiler
g++-5-arm-linux-gnueabihf_5.3.1-14ubuntu2cross1_amd64.deb GNU C++ compiler
g++-5-multilib_5.3.1-14ubuntu2_amd64.deb GNU C++ compiler (multilib support)
g++-5-powerpc-linux-gnu_5.3.1-14ubuntu2cross1_amd64.deb GNU C++ compiler
g++-5-powerpc64le-linux-gnu_5.3.1-14ubuntu2cross1_amd64.deb GNU C++ compiler
g++-5_5.3.1-14ubuntu2_amd64.deb GNU C++ compiler
g++-aarch64-linux-gnu_5.3.1-1ubuntu1_amd64.deb GNU C++ compiler for the arm64 architecture
g++-arm-linux-gnueabihf_5.3.1-1ubuntu1_amd64.deb GNU C++ compiler for the armhf architecture
g++-multilib_5.3.1-1ubuntu1_amd64.deb GNU C++ compiler (multilib files)
Advertisement
Advertisement