dh-php_0.10_all.deb


Advertisement

Description

dh-php - debhelper add-on to handle PHP PECL extensions

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Main amd64
Package name: dh-php
Package version: 0.10
Package release:
Package architecture: all
Package type: deb
Installed size: 32 B
Download size: 7.09 KB
Official Mirror: archive.ubuntu.com
dh-php provides a debhelper sequence add-on named 'php' and the dh_php command. The dh_php command adds the appropriate code to the postinst, prerm and postrm maint scripts to properly enable/disable PHP PECL extensions for all available PHP SAPIs.

Alternatives

    Download

    Binary package: dh-php_0.10_all.deb
    Source package: dh-php

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install dh-php deb package:
      # sudo apt-get install dh-php

    Files

    • /usr/bin/dh_php
    • /usr/share/debhelper/autoscripts/postinst-php
    • /usr/share/debhelper/autoscripts/postrm-php
    • /usr/share/debhelper/autoscripts/preinst-php
    • /usr/share/debhelper/autoscripts/prerm-php
    • /usr/share/doc/dh-php/changelog.gz
    • /usr/share/doc/dh-php/copyright
    • /usr/share/perl5/Debian/Debhelper/Sequence/php.pm

    Changelog

    2016-03-02 - Ondřej Surý <ondrej@debian.org> dh-php (0.10) unstable; urgency=medium * Even better cleanup of enabled modules in postrm remove and purge

    2016-03-02 - Ondřej Surý <ondrej@debian.org> dh-php (0.9) unstable; urgency=medium * Cleanup old symlinks to /etc/php/mods-available in preinst script

    2016-02-29 - Ondřej Surý <ondrej@debian.org> dh-php (0.8) unstable; urgency=medium * Rewrite [ -x /usr/sbin/php#HELPER# ] as which php#HELPER# >/dev/null to prevent lintian warning about absolute paths

    2016-02-29 - Ondřej Surý <ondrej@debian.org> dh-php (0.7) unstable; urgency=medium * Remove support for pure configuration snippets in dh_php * Install ini files into versioned directories /etc/php/X.Y/mods-available * Remove the old configuration file in /etc/php/mods-available (if it exists)

    2015-12-31 - Ondřej Surý <ondrej@debian.org> dh-php (0.6) unstable; urgency=medium * Depend on at least one phpapi-<ver>, but not a specific one

    2015-12-09 - Ondřej Surý <ondrej@debian.org> dh-php (0.5) unstable; urgency=medium * Add support for dh_php --version=X.Y

    2015-12-09 - Ondřej Surý <ondrej@debian.org> dh-php (0.4) unstable; urgency=medium * Add extra ALL argument for ALL versions, fixes broken maintscripts

    2015-08-16 - Ondřej Surý <ondrej@debian.org> dh-php (0.3) unstable; urgency=medium * Rename the package just to dh-php (but the multiversion support is not yet there) * Update Vcs-Urls to point to anonscm.debian.org * Remove obsolete Conflicts/Replaces with php5-dev

    2014-04-27 - Ondřej Surý <ondrej@debian.org> dh-php5 (0.2) unstable; urgency=medium * Don't fail purge when php5-common is uninstalled (Closes: #745561)

    2014-02-13 - Ondřej Surý <ondrej@debian.org> dh-php5 (0.1) unstable; urgency=low * Initial release (Closes: #737842)

    Advertisement
    Advertisement