dc_1.06.95-9build1_amd64.deb


Advertisement

Description

dc - GNU dc arbitrary precision reverse-polish calculator

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename dc_1.06.95-9build1_amd64.deb
Package name dc
Package version 1.06.95
Package release 9build1
Package architecture amd64
Package type deb
Category math
Homepage http://ftp.gnu.org/gnu/bc/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 45.30 KB
Installed size 157.00 KB
GNU dc is a reverse-polish desk calculator which supports unlimited
precision arithmetic.  It also allows you to define and call macros.
A reverse-polish calculator stores numbers on a stack. Entering a number
pushes it on the stack.  Arithmetic operations pop arguments off the
stack and push the results.

Alternatives

Package Version Architecture Repository
dc_1.06.95-9build1_i386.deb 1.06.95 i386 Ubuntu Main
dc - - -

Requires

Name Value
libc6 >= 2.14

Download

Type URL
Mirror archive.ubuntu.com
Binary Package dc_1.06.95-9build1_amd64.deb
Source Package bc

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install dc deb package:
    # sudo apt-get install dc

Files

Path
/usr/bin/dc
/usr/share/doc-base/dc
/usr/share/doc/dc/AUTHORS
/usr/share/doc/dc/NEWS.gz
/usr/share/doc/dc/README
/usr/share/doc/dc/changelog.Debian.gz
/usr/share/doc/dc/copyright
/usr/share/doc/dc/dc.html
/usr/share/doc/dc/examples/dc_factor
/usr/share/info/dc.info.gz
/usr/share/man/man1/dc.1.gz
/usr/share/menu/dc

Changelog

2014-12-11 - Brian Murray <brian@ubuntu.com>
bc (1.06.95-9build1) vivid; urgency=medium
* No change rebuild to get debug symbols on all architectures.
2014-06-14 - Ryan Kavanagh <rak@debian.org>
bc (1.06.95-9) unstable; urgency=medium
* Remove ancient unnecessary install-info dependencies.
* Fix some formatting issues with bc man page, 07_bc_man.diff
(Closes: #725898). Thanks to Bjarni Ingi Gislason for the patch.
* Bump standards version to 3.9.5
2013-06-02 - Ryan Kavanagh <rak@debian.org>
bc (1.06.95-8) unstable; urgency=low
* Use makeinfo instead of obsoleted texi2html
* Reintroduce patch reading ~/.dcrc file at dc start, 06_read_dcrc.diff
(Closes: #582137) (LP: #918836)
* Drop old-style 'Home page:' entries in long description
* Added a gbp.conf to use pristine-tar and to sign tags
2013-05-24 - Ryan Kavanagh <rak@debian.org>
bc (1.06.95-7) unstable; urgency=low
* New maintainer (Closes: #705771)
* Switch to Debian source format 3.0 (quilt)
* Updated copyright file with missing licenses and holders. Now in DEP-5
format.
* Bump standards version to 3.9.4
* Bump debhelper Build-Dependency to >= 9 and switch from old-style rules
with manual calls to dh_* to modern style dh rules
* Bump compat level to 9
* Drop libreadline5-dev from Build-Depends, it no longer exists in unstable
* Add a doc-base file for bc
* Fix a typo in bc, 01_typo_in_bc.diff
* Fix hyphens used as minus signs in manpages,
02_hyphens_as_minus_in_man.diff
* Fix array initialization bug, 03_array_initialize.diff (Closes: #671513,
#586969)
* Revert all inline patches and introduce them as logical quilt patches
+ Set the info dircategory to Math, 04_info_dircategory.diff
+ Notice read/write errors on input and output,
05_notice_read_write_errors.diff
* clean target now conforms to Debian Policy §4.9, "must undo any effects
that the build target may have had [...]"
* Added Vcs-Git/Vcs-Browser entries to debian/control
* Reintroduce the missing 1.06.94-3.1 changelog entry
* Get rid of postinst/postrm files, they were unneeded
2013-04-30 - Colin Watson <cjwatson@debian.org>
bc (1.06.95-6) unstable; urgency=low
* QA upload.
* Make bc Multi-Arch: foreign, so that it can satisfy (build-)dependencies
from other architectures (thanks, Sune Vuorela and Wookey; closes:
#681784, LP: #1098408).
* Add build-arch and build-indep targets.
2013-04-19 - John G. Hasler <jhasler@debian.org>
bc (1.06.95-5) unstable; urgency=low
* Orphaned
2012-08-01 - John G. Hasler <jhasler@debian.org>
bc (1.06.95-4) unstable; urgency=low
* Added #!/bin/sh to scripts.
Closes: #683571: postinst and postrm are not valid scripts
2012-06-22 - John G. Hasler <jhasler@debian.org>
bc (1.06.95-3) unstable; urgency=low
* Applied patch from Pádraig Brady.
Closes: #608255: bc uses uninitialized memory
* Applied patch from Paul Dwerryhouse.
Closes: #472250: please return support for .dcrc file
* Applied patch from Ian Jackson.
Closes: #488735: notice read and write errors on input and output
* Generated bc.html and dc.html but something is still wrong.
* Added homepage field to debian/control.
* I can't see the problem with hyphens.
* Fixed doc-base white space.
* Added watch file.
* I believe that the above changes deal with 558188.
Closes: #558188: Changes made in 1.06.94-3.1 NMU have been lost
2009-10-15 - John G. Hasler <jhasler@debian.org>
bc (1.06.95-2) unstable; urgency=low
* Fixed errors in debian/rules that prevented info files from
being correctly generated.
2009-10-03 - John Hasler <jhasler@debian.org>
bc (1.06.95-1) unstable; urgency=low
* New upstream release
Closes: #538419: New bc upstream version 1.06.95
Fixed libreadline build dependencies.

See Also

Package Description
dconf-cli_0.24.0-2_amd64.deb simple configuration storage system - utilities
dconf-gsettings-backend_0.24.0-2_amd64.deb simple configuration storage system - GSettings back-end
dconf-service_0.24.0-2_amd64.deb simple configuration storage system - D-Bus service
dctrl-tools_2.24-2_amd64.deb Command-line tools to process Debian package information
debconf-doc_1.5.58ubuntu1_all.deb debconf documentation
debconf-i18n_1.5.58ubuntu1_all.deb full internationalization support for debconf
debconf_1.5.58ubuntu1_all.deb Debian configuration management system
debhelper_9.20160115ubuntu3_all.deb helper programs for debian/rules
debian-goodies_0.64_all.deb Small toolbox-style utilities for Debian systems
debian-installer_20101020ubuntu451_amd64.deb Debian installer
debianutils_4.7_amd64.deb Miscellaneous utilities specific to Debian
debootstrap_1.0.78+nmu1ubuntu1_all.deb Bootstrap a basic Debian system
default-jdk-doc_1.8-56ubuntu2_amd64.deb Standard Java or Java compatible Development Kit (documentation)
default-jdk-headless_1.8-56ubuntu2_amd64.deb Standard Java or Java compatible Development Kit (headless)
default-jdk_1.8-56ubuntu2_amd64.deb Standard Java or Java compatible Development Kit
Advertisement
Advertisement