cups_2.1.3-4_amd64.deb


Advertisement

Description

cups - Common UNIX Printing System(tm) - PPD/driver support, web interface

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package name cups
Package version 2.1.3
Package release 4
Package architecture amd64
Package type deb
Installed size 755 B
Download size 187.47 KB
Official Mirror archive.ubuntu.com
The Common UNIX Printing System (or CUPS(tm)) is a printing system and
general replacement for lpd and the like.  It supports the Internet
Printing Protocol (IPP), and has its own filtering driver model for
handling various document types.
This package provides the parts of CUPS which are needed for using printer
drivers.

Alternatives

Package Version Architecture Repository
cups_2.1.3-4ubuntu0.5_amd64.deb 2.1.3 amd64 Ubuntu Updates Main
cups_2.1.3-4ubuntu0.5_i386.deb 2.1.3 i386 Ubuntu Updates Main
cups_2.1.3-4_i386.deb 2.1.3 i386 Ubuntu Main
cups - - -

Requires

Name Value
cups-client >= 2.1.3-4
cups-common >= 2.1.3-4
cups-core-drivers >= 2.1.3-4
cups-daemon >= 2.1.3-4
cups-filters >= 1.0.24-3~
cups-ppdc -
cups-server-common >= 2.1.3-4
debconf >= 1.2.9
debconf-2.0 -
ghostscript >= 9.02~
libavahi-client3 >= 0.6.16
libavahi-common3 >= 0.6.16
libc-bin >= 2.13
libc6 >= 2.16
libcups2 = 2.1.3-4
libcupscgi1 >= 1.4.2
libcupsimage2 >= 1.4.0
libcupsmime1 >= 1.4.0
libcupsppdc1 >= 1.4.0
libgcc1 >= 1:3.0
libstdc++6 >= 4.1.1
libusb-1.0-0 >= 2:1.0.8
lsb-base >= 3.2-14~
poppler-utils >= 0.12
procps -

Replaces

Name Value
cups-bsd << 1.7.2-3~
ghostscript-cups << 9.02~

Download

Type URL
Binary Package cups_2.1.3-4_amd64.deb
Source Package cups

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install cups deb package:
    # sudo apt-get install cups

Files

Path
/etc/cups/snmp.conf
/usr/lib/cups/backend-available/dnssd
/usr/lib/cups/backend-available/lpd
/usr/lib/cups/backend-available/snmp
/usr/lib/cups/backend-available/socket
/usr/lib/cups/backend-available/usb
/usr/lib/cups/cgi-bin/admin.cgi
/usr/lib/cups/cgi-bin/classes.cgi
/usr/lib/cups/cgi-bin/help.cgi
/usr/lib/cups/cgi-bin/jobs.cgi
/usr/lib/cups/cgi-bin/printers.cgi
/usr/lib/cups/daemon/cups-deviced
/usr/lib/cups/daemon/cups-driverd
/usr/lib/cups/daemon/cups-lpd
/usr/lib/cups/filter/rastertodymo
/usr/lib/cups/filter/rastertoepson
/usr/lib/cups/filter/rastertohp
/usr/lib/cups/filter/rastertolabel
/usr/lib/cups/filter/rastertopwg
/usr/lib/cups/monitor/bcp
/usr/lib/cups/monitor/tbcp
/usr/sbin/cupsfilter
/usr/share/bug/cups/presubj
/usr/share/doc/cups/CREDITS.txt
/usr/share/doc/cups/HOWTO_BUGREPORT.txt
/usr/share/doc/cups/NEWS.Debian.gz
/usr/share/doc/cups/README.Debian.gz
/usr/share/doc/cups/README.txt.gz
/usr/share/doc/cups/changelog.Debian.gz
/usr/share/doc/cups/copyright
/usr/share/doc/cups/examples/printer.schema
/usr/share/lintian/overrides/cups
/usr/share/man/de/man1/cups.1.gz
/usr/share/man/de/man5/mime.convs.5.gz
/usr/share/man/de/man5/subscriptions.conf.5.gz
/usr/share/man/de/man7/filter.7.gz
/usr/share/man/de/man8/cups-deviced.8.gz
/usr/share/man/de/man8/cups-driverd.8.gz
/usr/share/man/de/man8/cups-exec.8.gz
/usr/share/man/de/man8/cupsd-helper.8.gz
/usr/share/man/de/man8/cupsfilter.8.gz
/usr/share/man/fr/man1/cups.1.gz
/usr/share/man/fr/man5/mime.convs.5.gz
/usr/share/man/fr/man5/subscriptions.conf.5.gz
/usr/share/man/fr/man7/filter.7.gz
/usr/share/man/fr/man8/cups-deviced.8.gz
/usr/share/man/fr/man8/cups-driverd.8.gz
/usr/share/man/fr/man8/cups-exec.8.gz
/usr/share/man/fr/man8/cupsd-helper.8.gz
/usr/share/man/fr/man8/cupsfilter.8.gz
/usr/share/man/man1/cups.1.gz
/usr/share/man/man5/mime.convs.5.gz
/usr/share/man/man5/subscriptions.conf.5.gz
/usr/share/man/man7/filter.7.gz
/usr/share/man/man8/cups-deviced.8.gz
/usr/share/man/man8/cups-driverd.8.gz
/usr/share/man/man8/cups-exec.8.gz
/usr/share/man/man8/cups-lpd.8.gz
/usr/share/man/man8/cupsd-helper.8.gz
/usr/share/man/man8/cupsfilter.8.gz

Changelog

2016-03-18 - Didier Raboud <odyx@debian.org>
cups (2.1.3-4) unstable; urgency=medium
[ Till Kamppeter ]
* Quirk rule to make Lexmark C540n work (STR #4778)
* Quirk rule to make Xerox WorkCentre 3220 work (LP: #1406203, STR #4789)
2016-02-29 - Didier Raboud <odyx@debian.org>
cups (2.1.3-3) unstable; urgency=medium
* Install missing cups-snmp.8 manpage (Closes: #816316)
2016-02-24 - Didier Raboud <odyx@debian.org>
cups (2.1.3-2) unstable; urgency=medium
* Drop unused libslp-dev Build-Dependency (Closes: #815359)
* Bump Standards-Version to 3.9.7 without changes needed
2016-02-13 - Didier Raboud <odyx@debian.org>
cups (2.1.3-1) unstable; urgency=medium
* New 2.1.3 upstream release:
- /admin resource files (like config files of CUPS) were not served when
the web interface was disabled, breaking utilities like "cupsctl"
(CUPS STR #4755)
2016-01-13 - Didier Raboud <odyx@debian.org>
cups (2.1.2-2) unstable; urgency=medium
[ Till Kamppeter ]
* Add patch to avoid letting pending subscriptions prevent CUPS from
auto-shutdown when idle (CUPS STR#4754)
* Add patch to allow auto-shutdown when idle if the web interface is not
turned off in the CUPS configuration, the web interface is too important
(CUPS STR #4755)
[ Didier Raboud ]
* Remove libpng12-dev Build-Depends alternative to libpng-dev
(Closes: #810183)
2015-12-03 - Didier Raboud <odyx@debian.org>
cups (2.1.2-1) unstable; urgency=low
* New 2.1.2 upstream release
* Drop patches included upstream:
- usb-backend-fix-infinite-loop-when-usblp-module-attached.patch
- usb-backend-delayed-closing-for-old-laserjets.patch
- fix-ppd-file-load-for-ipp-printers.patch
Refresh 2 other patches
* Update Apple Inc. Copyright years in debian/copyright
2015-11-30 - Didier Raboud <odyx@debian.org>
cups (2.1.0-7) unstable; urgency=medium
[ Till Kamppeter ]
* Removed deprecated no-op "--upstart-only" option from dh_installinit call
in debian/rules (LP: #1519228)
* Moved empty directories /etc/cups/ppd and /etc/cups/interfaces to the
cups-core-drivers binary package
* Moved mime.convs from cups-server-common to cups-core-drivers to get it
onto mobile devices with level-2 printing stack (support for IPP printers
with common PDLs auto-set-up by cups-browsed)
2015-11-06 - Didier Raboud <odyx@debian.org>
cups (2.1.0-6) unstable; urgency=medium
[ Till Kamppeter ]
* Move /usr/lib/cups/daemom/cups-exec from the "cups" binary package to the
"cups-daemon" binary package as it is already needed for basic job
execution and therefore already in the level-1 (minimum) printing stack
(LP: #1509423)
2015-10-21 - Didier Raboud <odyx@debian.org>
cups (2.1.0-5) unstable; urgency=medium
[ Till Kamppeter ]
* Add upstream patch to fix cupsGetPPD* with IPP print queues
(CUPS STR #4725)
2015-09-16 - Didier Raboud <odyx@debian.org>
cups (2.1.0-4) unstable; urgency=medium
[ Till Kamppeter ]
* Corrected info header (author and Debian bug closure) of
usb-backend-fix-infinite-loop-when-usblp-module-attached.patch
* USB-backend: Added new quirk rules for delayed closing of the backend for
several older HP LaserJet printers (CUPS STR #4549)
[ Didier Raboud ]
* Add maintscript stanzas to properly remove the oopstops.{convs,types}
conffiles in /etc/cups that are not shipped since 1.3.10-3
(Closes: #799025)

See Also

Package Description
curl_7.47.0-1ubuntu2_amd64.deb command line tool for transferring data with URL syntax
curtin-common_0.1.0~bzr365-0ubuntu1_all.deb Library and tools for curtin installer
cvs_1.12.13+real-15_amd64.deb Concurrent Versions System
cyrus-sasl2-doc_2.1.26.dfsg1-14build1_all.deb Cyrus SASL - documentation
dash_0.5.8-2.1ubuntu2_amd64.deb POSIX-compliant shell
db-util_5.3.21~exp1ubuntu2_all.deb Berkeley Database Utilities
db5.3-doc_5.3.28-11_all.deb Berkeley v5.3 Database Documentation [html]
db5.3-util_5.3.28-11_amd64.deb Berkeley v5.3 Database Utilities
dbconfig-common_2.0.4ubuntu1_all.deb framework that helps packages to manage databases
dbconfig-pgsql_2.0.4ubuntu1_all.deb dbconfig-common PostgreSQL support
dbus-1-doc_1.10.6-1ubuntu3_all.deb simple interprocess messaging system (documentation)
dbus-cpp-dev-examples_5.0.0+15.10.20151022.1-0ubuntu1_amd64.deb header-only dbus-binding leveraging C++-11, example binaries
dbus-x11_1.10.6-1ubuntu3_amd64.deb simple interprocess messaging system (X11 deps)
dbus_1.10.6-1ubuntu3_amd64.deb simple interprocess messaging system (daemon and utilities)
dc_1.06.95-9build1_amd64.deb GNU dc arbitrary precision reverse-polish calculator
Advertisement
Advertisement