crda_3.13-1_amd64.deb


Advertisement

Description

crda - wireless Central Regulatory Domain Agent

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package name crda
Package version 3.13
Package release 1
Package architecture amd64
Package type deb
Installed size 297 B
Download size 59.06 KB
Official Mirror archive.ubuntu.com
This package provides a Central Regulatory Domain Agent (CRDA) to be used by
the Linux kernel cfg80211 wireless subsystem to query and apply the regulatory
domain settings wireless devices may operate within for a given location.
CRDA queries operational frequency regulations stored within the regulatory
database provided by the wireless-regdb package.

Alternatives

Package Version Architecture Repository
crda_3.13-1_i386.deb 3.13 i386 Ubuntu Main
crda - - -

Requires

Name Value
iw >= 3.2-1~
libc6 >= 2.7
libnl-3-200 >= 3.2.7
libnl-genl-3-200 >= 3.2.7
libssl1.0.0 >= 1.0.0
wireless-regdb -

Download

Type URL
Binary Package crda_3.13-1_amd64.deb
Source Package crda

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install crda deb package:
    # sudo apt-get install crda

Files

Path
/etc/default/crda
/lib/crda/libreg.so
/lib/crda/setregdomain
/lib/crda/pubkeys/benh@debian.org.key.pub.pem
/lib/crda/pubkeys/linville.key.pub.pem
/lib/udev/rules.d/40-crda.rules
/lib/udev/rules.d/85-regulatory.rules
/sbin/crda
/sbin/regdbdump
/usr/include/reglib/nl80211.h
/usr/include/reglib/regdb.h
/usr/include/reglib/reglib.h
/usr/share/doc/crda/changelog.Debian.gz
/usr/share/doc/crda/copyright
/usr/share/lintian/overrides/crda
/usr/share/man/man8/crda.8.gz
/usr/share/man/man8/regdbdump.8.gz

Changelog

2014-08-23 - Ben Hutchings <ben@decadent.org.uk>
crda (3.13-1) unstable; urgency=medium
* New upstream version (Closes: #720119)
- reglib: Validate all structure and array lengths (Closes: #716247)
* debian/control, debian/watch: Update Homepage and download URLs
* debian/copyright: Update licence information and copyright holders
- Licence is now copyleft-next 0.3.0
* Fix build regressions in new upstream version:
- Fix the linking order to avoid compilation error
- Add DESTDIR support in install-libreg* rules in Makefile
- Do not run ldconfig if DESTDIR is set
- Fix linking of libraries used by reglib
* Install reglib in /lib/crda, not /usr/lib
* debian/crda.lintian-overrides: Override lintian errors due to
wrongly detecting copyleft-next as GPL
2014-08-22 - Ben Hutchings <ben@decadent.org.uk>
crda (1.1.3-1) unstable; urgency=low
* New upstream version
- Add support to send DFS master region
* debian/control: Correct spelling of 'cfg80211' (Closes: #657905)
* debian/watch: Change regex to avoid matching 'latest' symlink
(Closes: #756624)
* Update policy version to 3.9.4
- debian/copyright: Update to 1.0 format (no changes required)
* debian/copyright: Add my copyright to Debian packaging
* Require iw to be installed in /sbin
2011-12-29 - Ben Hutchings <ben@decadent.org.uk>
crda (1.1.2-1) unstable; urgency=low
* New upstream version
[ Stefan Lippers-Hollmann ]
* switch to libnl3 3.2 and raise versioned build-dependency to (>= 3.2.3-2~),
to be able to expect it in /lib/.
* crda is specific to the linux kernel, restrict it to linux-any.
* bump standards version to 3.9.2, no changes necessary.
[ Ben Hutchings ]
* debian/control: Add references to git repository
* debian/control: Set Multi-Arch: foreign, thanks to Tim Gardner
2011-04-11 - Ben Hutchings <ben@decadent.org.uk>
crda (1.1.1-1) unstable; urgency=low
* Initial release (Closes: #536502)
- Most packaging was done by Kel Modderman and Stefan Lippers-Hollmann

See Also

Package Description
crmsh-doc_2.2.0-1_all.deb crmsh HTML Documentation
crmsh_2.2.0-1_amd64.deb CRM shell for the pacemaker cluster manager
cron_3.0pl1-128ubuntu2_amd64.deb process scheduling daemon
crossbuild-essential-arm64_12.1ubuntu2_all.deb Informational list of cross-build-essential packages
crossbuild-essential-armhf_12.1ubuntu2_all.deb Informational list of cross-build-essential packages
crossbuild-essential-powerpc_12.1ubuntu2_all.deb Informational list of cross-build-essential packages
crossbuild-essential-ppc64el_12.1ubuntu2_all.deb Informational list of cross-build-essential packages
cryptsetup-bin_1.6.6-5ubuntu2_amd64.deb disk encryption support - command line tools
cryptsetup_1.6.6-5ubuntu2_amd64.deb disk encryption support - startup scripts
cu_1.07-23_amd64.deb call up another system
culmus_0.130-1_all.deb TrueType and Type1 Hebrew Fonts for X11
cups-browsed_1.8.3-2ubuntu3_amd64.deb OpenPrinting CUPS Filters - cups-browsed
cups-bsd_2.1.3-4_amd64.deb Common UNIX Printing System(tm) - BSD commands
cups-client_2.1.3-4_amd64.deb Common UNIX Printing System(tm) - client programs (SysV)
cups-common_2.1.3-4_all.deb Common UNIX Printing System(tm) - common files
Advertisement
Advertisement