cloop-utils_3.14.1.2ubuntu1_amd64.deb


Advertisement

Description

cloop-utils - Tools for handling with cloop compressed volumes

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package name cloop-utils
Package version 3.14.1.2ubuntu1
Package release
Package architecture amd64
Package type deb
Installed size 89 B
Download size 29.38 KB
Official Mirror archive.ubuntu.com
Utilities for creating and unpacking compressed loopback files
for cloop.

Alternatives

Package Version Architecture Repository
cloop-utils_3.14.1.2ubuntu1_i386.deb 3.14.1.2ubuntu1 i386 Ubuntu Main
cloop-utils - - -

Requires

Name Value
libc6 >= 2.14
libgcc1 >= 1:3.0
libstdc++6 >= 4.4.0
zlib1g >= 1:1.1.4

Download

Type URL
Binary Package cloop-utils_3.14.1.2ubuntu1_amd64.deb
Source Package cloop

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install cloop-utils deb package:
    # sudo apt-get install cloop-utils

Files

Path
/usr/bin/create_compressed_fs
/usr/bin/extract_compressed_fs
/usr/share/doc/cloop-utils/README
/usr/share/doc/cloop-utils/README.Debian
/usr/share/doc/cloop-utils/changelog.gz
/usr/share/doc/cloop-utils/copyright
/usr/share/doc/cloop-utils/examples/cloop-node-control.sh
/usr/share/man/man1/advfs.1.gz
/usr/share/man/man1/create_compressed_fs.1.gz
/usr/share/man/man1/extract_compressed_fs.1.gz

Changelog

2016-01-07 - Matthias Klose <doko@ubuntu.com>
cloop (3.14.1.2ubuntu1) xenial; urgency=medium
* Merge with Debian; remaining changes:
- Do not build the cloop-src package.
2015-05-03 - Eduard Bloch <blade@debian.org>
cloop (3.14.1.2) unstable; urgency=low
* Fix the build with kernel 3.19+ (f_dentry macro removal)
2014-10-25 - Eduard Bloch <blade@debian.org>
cloop (3.14.1.1) unstable; urgency=medium
* Fixes build failure (old bashism)
* Passing some configure flags to embedded compressor implementation
* Bugfix in create_compressed_fs (fallout from previous change)
* Restored support for kernel versions >= 3.11
* Moved README.md (is just text) to README as hard copy, not symlink
2014-10-25 - Eduard Bloch <blade@debian.org>
cloop (3.14.1) unstable; urgency=medium
* New upstream version
+ updated version, works with kernel versions 3.14..3.17 (closes: #719128)
* New location, now originating on Klaus Knopper's github version
* Changed package package type to native until the mode of cooperation with
upstream is fully clarified
* Overhaul of debian packaging, changed to dh(7) style, auto-updating
autotools-dev files on build now (closes: #727288)
* Enabled hardening, fixed some minor issues in advfs.cc
* Removed special hacks for ancient Cygwin and Mac OS X versions in
extract_compressed_fs.c (closes: #370204)
* Italian translation of debconf messages from Beatrice Torracca
(closes: #714004)
2014-08-26 - Klaus Knopper <knoppix@knopper.net>
cloop (3.14-1) unstable; urgency=medium
* Updates for Kernel >= 3.14
* Preparing for git repository upload
2013-10-10 - Matthias Klose <doko@ubuntu.com>
cloop (2.6.39.2-1ubuntu3) saucy; urgency=low
* Regenerate the autotools patch to support AArch64.
2012-10-01 - Colin Watson <cjwatson@ubuntu.com>
cloop (2.6.39.2-1ubuntu2) quantal; urgency=low
* Rebuild for new armel compiler default of ARMv5t.
2012-01-02 - Steve Langasek <steve.langasek@ubuntu.com>
cloop (2.6.39.2-1ubuntu1) precise; urgency=low
* Merge from Debian testing, remaining changes:
- Do not build the cloop-src package.
* Add Pre-Depends on dpkg (>= 1.15.6~) since we're using xz compression.
2011-12-12 - Eduard Bloch <blade@debian.org>
cloop (2.6.39.2-1) unstable; urgency=low
* Imported new upstream version (closes: 436090, 632603)
* Converted Debian source format to 3.0 (quilt), also using xz where possible
* Move linux-headers-2.6 dependency to linux-headers (closes: 628872)
* Merged extra changelog.knoppix file (documenting Knopper's branch changes)
into common debian/changelog file, dropped the build time merging mess
* Danish translation of the debconf templates from Joe Dalton (closes: 627713)
* Korean translation of the debconf templates from 임영재 (closes: 632291)
2011-07-06 - Klaus Knopper <knoppix@knopper.net>
cloop (2.639-2) unstable; urgency=low
* Change compressed_loop.h -> cloop.h everywhere.

See Also

Package Description
cloud-guest-utils_0.27-0ubuntu24_all.deb cloud guest utilities
cloud-image-utils_0.27-0ubuntu24_all.deb cloud image management utilities
cloud-init_0.7.7~bzr1212-0ubuntu1_all.deb Init scripts for cloud instances
cloud-initramfs-copymods_0.27ubuntu1_all.deb copy initramfs modules into root filesystem for later use
cloud-initramfs-dyn-netconf_0.27ubuntu1_all.deb write a network interface file in /run for BOOTIF
cloud-utils_0.27-0ubuntu24_all.deb metapackage for installation of upstream cloud-utils source
cluster-glue-dev_1.0.12~rc1+hg2777-1.2_amd64.deb Development files for the cluster glue components
cluster-glue_1.0.12~rc1+hg2777-1.2_amd64.deb Reusable cluster components for Linux HA
cmake-data_3.5.1-1ubuntu1_all.deb CMake data files (modules, templates and documentation)
cmake-doc_3.5.1-1ubuntu1_all.deb extended documentation in various formats for CMake
cmake_3.5.1-1ubuntu1_amd64.deb cross-platform, open-source make system
colord-data_1.2.12-1ubuntu1_all.deb system service to manage device colour profiles -- data files
colord_1.2.12-1ubuntu1_amd64.deb system service to manage device colour profiles -- system daemon
comerr-dev_2.1-1.42.13-1ubuntu1_amd64.deb common error description library - headers and static libraries
command-not-found-data_0.3ubuntu16.04_amd64.deb Set of data files for command-not-found
Advertisement
Advertisement