binutils-multiarch_2.26-8ubuntu2_amd64.deb


Advertisement

Description

binutils-multiarch - Binary utilities that support multi-arch targets

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename binutils-multiarch_2.26-8ubuntu2_amd64.deb
Package name binutils-multiarch
Package version 2.26
Package release 8ubuntu2
Package architecture amd64
Package type deb
Category devel
Homepage -
License -
Maintainer Ubuntu Core developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 1.58 MB
Installed size 9.07 MB
The programs in this package are used to manipulate binary and object
files that may have been created on other architectures.  This package
is primarily for multi-architecture developers and cross-compilers and
is not needed by normal users or developers.  Note that a cross-assembling
version of gas is not included in this package, just the binary utilities.
NORMAL USERS SHOULD NOT INSTALL THIS PACKAGE.  It's meant only for those
requiring support for reading info from binaries from other architectures.

Alternatives

Package Version Architecture Repository
binutils-multiarch_2.26.1-1ubuntu1~16.04.8_i386.deb 2.26.1 i386 Ubuntu Updates Main
binutils-multiarch_2.26.1-1ubuntu1~16.04.8_amd64.deb 2.26.1 amd64 Ubuntu Updates Main
binutils-multiarch_2.26.1-1ubuntu1~16.04.3~trinity1_i386.deb 2.26.1 i386 Trinity R14 BuildDeps
binutils-multiarch_2.26.1-1ubuntu1~16.04.3~trinity1_amd64.deb 2.26.1 amd64 Trinity R14 BuildDeps
binutils-multiarch_2.26-8ubuntu2_i386.deb 2.26 i386 Ubuntu Main
binutils-multiarch - - -

Requires

Name Value
binutils = 2.26-8ubuntu2
libc6 >= 2.14
zlib1g >= 1:1.2.0

Download

Type URL
Mirror archive.ubuntu.com
Binary Package binutils-multiarch_2.26-8ubuntu2_amd64.deb
Source Package binutils

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install binutils-multiarch deb package:
    # sudo apt-get install binutils-multiarch

Files

Path
/usr/bin/addr2line
/usr/bin/ar
/usr/bin/embedspu
/usr/bin/gprof
/usr/bin/nm
/usr/bin/objcopy
/usr/bin/objdump
/usr/bin/ranlib
/usr/bin/readelf
/usr/bin/size
/usr/bin/strings
/usr/bin/strip
/usr/lib/x86_64-linux-gnu/libbfd-2.26-multiarch.so
/usr/lib/x86_64-linux-gnu/libopcodes-2.26-multiarch.so
/usr/share/bug/binutils-multiarch
/usr/share/doc/binutils-multiarch
/usr/share/lintian/overrides/binutils-multiarch

Changelog

2016-04-01 - Matthias Klose <doko@ubuntu.com>
binutils (2.26-8ubuntu2) xenial; urgency=medium
* Fix PR ld/19886, --as-needed regression, taken from the trunk.
2016-03-21 - Matthias Klose <doko@ubuntu.com>
binutils (2.26-8ubuntu1) xenial; urgency=medium
* Merge with Debian; remaining changes:
- Build from upstream sources.
- Don't build cross binutils packages for non-linux architectures.
2016-03-21 - Matthias Klose <doko@debian.org>
binutils (2.26-8) unstable; urgency=medium
* Update, taken from the 2.26 branch 20160321.
- Fix PR ld/19827.
2016-03-16 - Matthias Klose <doko@ubuntu.com>
binutils (2.26-7ubuntu2) xenial; urgency=medium
* Stop building the binutils-static and binutils-static-udeb packages.
2016-03-16 - Matthias Klose <doko@ubuntu.com>
binutils (2.26-7ubuntu1) xenial; urgency=medium
* Merge with Debian; remaining changes:
- Build from upstream sources.
- Build binutils-static and binutils-static-udeb packages.
- Don't build cross binutils packages for non-linux architectures.
2016-03-16 - Matthias Klose <doko@debian.org>
binutils (2.26-7) unstable; urgency=medium
* Update, taken from the 2.26 branch 20160316.
- Fix PR ld/19623. Closes: #817891, PR ld/19539, PR binutils/19523.
* Fix cross-building from any-i386 (Samuel Thibault). Closes: #816128.
2016-03-10 - Matthias Klose <doko@ubuntu.com>
binutils (2.26-6ubuntu1) xenial; urgency=medium
* Merge with Debian; remaining changes:
- Build from upstream sources.
- Build binutils-static and binutils-static-udeb packages.
- Don't build cross binutils packages for non-linux architectures.
2016-03-10 - Matthias Klose <doko@debian.org>
binutils (2.26-6) unstable; urgency=medium
* Update, taken from the 2.26 branch 20160310.
- Fix PR ld/19579, PR ld/19752, PR ld/19739.
- Fix PR binutils/19775. Closes: #813006.
2016-02-26 - Matthias Klose <doko@ubuntu.com>
binutils (2.26-5ubuntu1) xenial; urgency=medium
* Merge with Debian; remaining changes:
- Build from upstream sources.
- Build binutils-static and binutils-static-udeb packages.
- Don't build cross binutils packages for non-linux architectures.
2016-02-26 - Matthias Klose <doko@debian.org>
binutils (2.26-5) unstable; urgency=medium
* Update, taken from the 2.26 branch 20160213.
- Fix PR ld/19698, PR ld/19553, ppc64 and AArch64 fixes.

See Also

Package Description
binutils-powerpc-linux-gnu_2.26-8ubuntu2_amd64.deb GNU binary utilities, for powerpc-linux-gnu target
binutils-powerpc64le-linux-gnu_2.26-8ubuntu2_amd64.deb GNU binary utilities, for powerpc64le-linux-gnu target
binutils_2.26-8ubuntu2_amd64.deb GNU assembler, linker and binary utilities
bison-doc_3.0.4-1_all.deb Documentation for the Bison parser generator
bison_3.0.4.dfsg-1_amd64.deb YACC-compatible parser generator
bittornado_0.3.18-10.2_all.deb bittorrent client (and tracker) with console and curses interfaces
blt-dev_2.5.3+dfsg-3_amd64.deb graphics extension library for Tcl/Tk - development files
blt_2.5.3+dfsg-3_amd64.deb graphics extension library for Tcl/Tk - run-time
bluez-cups_5.37-0ubuntu5_amd64.deb Bluetooth printer driver for CUPS
bluez-obexd_5.37-0ubuntu5_amd64.deb bluez obex daemon
bluez_5.37-0ubuntu5_amd64.deb Bluetooth tools and daemons
bogl-bterm_0.1.18-9ubuntu1_amd64.deb Ben's Own Graphics Library - graphical terminal
bonnie++_1.97.1_amd64.deb Hard drive benchmark suite
branding-ubuntu_0.8_all.deb Replacement artwork with Ubuntu branding
bridge-utils_1.5-9ubuntu1_amd64.deb Utilities for configuring the Linux Ethernet bridge
Advertisement
Advertisement