base-passwd_3.5.39_amd64.deb


Advertisement

Description

base-passwd - Debian base system master password and group files

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package name base-passwd
Package version 3.5.39
Package release
Package architecture amd64
Package type deb
Installed size 219 B
Download size 50.67 KB
Official Mirror archive.ubuntu.com
These are the canonical master copies of the user database files
(/etc/passwd and /etc/group), containing the Debian-allocated user and
group IDs. The update-passwd tool is provided to keep the system databases
synchronized with these master files.

Alternatives

Package Version Architecture Repository
base-passwd_3.5.39_i386.deb 3.5.39 i386 Ubuntu Main
base-passwd - - -

Requires

Name Value
libc6 >= 2.8
libdebconfclient0 >= 0.145

Replaces

Name Value
base -

Download

Type URL
Binary Package base-passwd_3.5.39_amd64.deb
Source Package base-passwd

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install base-passwd deb package:
    # sudo apt-get install base-passwd

Files

Path
/usr/sbin/update-passwd
/usr/share/base-passwd/group.master
/usr/share/base-passwd/passwd.master
/usr/share/doc-base/users-and-groups
/usr/share/doc/base-passwd/README
/usr/share/doc/base-passwd/changelog.gz
/usr/share/doc/base-passwd/copyright
/usr/share/doc/base-passwd/users-and-groups.html
/usr/share/doc/base-passwd/users-and-groups.txt.gz
/usr/share/lintian/overrides/base-passwd
/usr/share/man/de/man8/update-passwd.8.gz
/usr/share/man/es/man8/update-passwd.8.gz
/usr/share/man/fr/man8/update-passwd.8.gz
/usr/share/man/ja/man8/update-passwd.8.gz
/usr/share/man/man8/update-passwd.8.gz
/usr/share/man/pl/man8/update-passwd.8.gz
/usr/share/man/ru/man8/update-passwd.8.gz

Changelog

2016-01-02 - Colin Watson <cjwatson@debian.org>
base-passwd (3.5.39) unstable; urgency=medium
* Policy version 3.9.6: no changes required.
* Build with large file support.
2015-07-16 - Colin Watson <cjwatson@debian.org>
base-passwd (3.5.38) unstable; urgency=medium
[ Colin Watson ]
* Simplify dpkg (>= 1.16.4) | sgml-base (<< 1.26+nmu2) build-dependency
(see changelog for 3.5.26) to just dpkg (>= 1.16.4), since that was some
time ago and wheezy has a sufficient version now, and the more elaborate
form causes a complaint from debcheck.
* Allocate uid/gid 64045 for ceph object storage, by request of Gaudenz
Steinlin.
* Allocate uid/gid 64050 for the Evergreen ILS, by request of Robin H.
Johnson.
[ Juan Picca ]
* Make documentation build reproducible (closes: #792520).
2014-11-07 - Colin Watson <cjwatson@debian.org>
base-passwd (3.5.37) unstable; urgency=medium
* Debconf translations:
- Dutch (thanks, Frans Spiesschaert; closes: #765361).
- Danish (thanks, Joe Hansen; closes: #765853).
* Copy /etc/passwd and /etc/group from the master files in the preinst on
initial install, to be more tolerant of bootstrapping tools that
configure the Essential set in slightly different orders (based on a
patch from Michael Tautschnig; see #766459 and #767999).
2014-09-04 - Colin Watson <cjwatson@debian.org>
base-passwd (3.5.36) unstable; urgency=medium
* Update Vcs-Browser URL yet again.
2014-08-31 - Colin Watson <cjwatson@debian.org>
base-passwd (3.5.35) unstable; urgency=medium
* Build with all hardening options (thanks, Markus).
2014-08-30 - Colin Watson <cjwatson@debian.org>
base-passwd (3.5.34) unstable; urgency=medium
* Debconf translations:
- Italian (thanks, Beatrice Torracca; closes: #744344).
* Update Vcs-Browser URL for alioth cgit.
2014-04-09 - Colin Watson <cjwatson@debian.org>
base-passwd (3.5.33) unstable; urgency=medium
* Debconf translations:
- French (thanks, Steve Petruzzello; closes: #736506).
- German (thanks, Chris Leick; closes: #738363).
- Japanese (thanks, victory; closes: #740040).
2014-01-17 - Colin Watson <cjwatson@debian.org>
base-passwd (3.5.32) unstable; urgency=medium
* Debconf translations:
- Portuguese (thanks, Américo Monteiro; closes: #735036).
- Russian (thanks, Yuri Kozlov; closes: #735480).
* update-passwd(8) translations:
- German (thanks, Helge Kreutzmann; closes: #735149).
- Portuguese (thanks, Américo Monteiro; closes: #735247).
2014-01-10 - Colin Watson <cjwatson@debian.org>
base-passwd (3.5.31) unstable; urgency=medium
* Pick up version number for "update-passwd --version" from autoconf,
rather than having a separate manually-updated and out-of-date
version.h.
* Convert hand-crafted Makefiles to Automake.
* users-and-groups: Add a little more commentary on gnats.
2014-01-07 - Colin Watson <cjwatson@debian.org>
base-passwd (3.5.30) unstable; urgency=medium
[ Colin Watson ]
* Remove config.h.in and configure, now autogenerated by dh-autoreconf.
* Change the shell of all global static users other than root (which
retains /bin/sh) and sync (as /bin/sync is rather harmless) to
/usr/sbin/nologin (closes: #274229; LP: #216813, #248844).
* Policy version 3.9.5.
[ Russ Allbery ]
* Add support for debconf prompting to update-passwd (closes: #184979).

See Also

Package Description
bash-completion_2.1-4.2ubuntu1_all.deb programmable completion for the bash shell
bash-doc_4.3-14ubuntu1_all.deb Documentation and examples for the GNU Bourne Again SHell
bash_4.3-14ubuntu1_amd64.deb GNU Bourne Again SHell
bbdb_2.36-4_all.deb The Insidious Big Brother Database (email rolodex) for Emacs
bbswitch-dkms_0.8-3ubuntu1_amd64.deb Interface for toggling the power on NVIDIA Optimus video cards
bc_1.06.95-9build1_amd64.deb GNU bc arbitrary precision calculator language
bcache-tools_1.0.8-2_amd64.deb bcache userspace tools
bcrelay_1.4.0-7_amd64.deb Broadcast relay daemon
bdf2psf_1.108ubuntu15_all.deb font converter to generate console fonts from BDF source fonts
bind9-doc_9.10.3.dfsg.P4-8_all.deb Documentation for BIND
bind9-host_9.10.3.dfsg.P4-8_amd64.deb Version of 'host' bundled with BIND 9.X
bind9_9.10.3.dfsg.P4-8_amd64.deb Internet Domain Name Server
bind9utils_9.10.3.dfsg.P4-8_amd64.deb Utilities for BIND
binfmt-support_2.1.6-1_amd64.deb Support for extra binary formats
binutils-aarch64-linux-gnu_2.26-8ubuntu2_amd64.deb GNU binary utilities, for aarch64-linux-gnu target
Advertisement
Advertisement