autopoint_0.19.7-2ubuntu3_all.deb


Advertisement

Description

autopoint - The autopoint program from GNU gettext

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename autopoint_0.19.7-2ubuntu3_all.deb
Package name autopoint
Package version 0.19.7
Package release 2ubuntu3
Package architecture all
Package type deb
Category devel
Homepage http://www.gnu.org/software/gettext/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 396.30 KB
Installed size 446.00 KB
The `autopoint' program copies standard gettext infrastructure files
into a source package.  It extracts from a macro call of the form
`AM_GNU_GETTEXT_VERSION(VERSION)', found in the package's
`configure.in' or `configure.ac' file, the gettext version used by the
package, and copies the infrastructure files belonging to this version
into the package.

Alternatives

Package Version Architecture Repository
autopoint_0.19.7-2ubuntu3.1_all.deb 0.19.7 all Ubuntu Updates Main
autopoint_0.19.7-2ubuntu3.1_all.deb 0.19.7 all Ubuntu Updates Main
autopoint_0.19.7-2ubuntu3_all.deb 0.19.7 all Ubuntu Main
autopoint - - -

Requires

Name Value
xz-utils -

Replaces

Name Value
gettext <= 0.17-11

Download

Type URL
Mirror archive.ubuntu.com
Binary Package autopoint_0.19.7-2ubuntu3_all.deb
Source Package gettext

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install autopoint deb package:
    # sudo apt-get install autopoint

Files

Path
/usr/bin/autopoint
/usr/share/doc/autopoint/changelog.Debian.gz
/usr/share/doc/autopoint/copyright
/usr/share/gettext/archive.dir.tar.xz
/usr/share/man/man1/autopoint.1.gz

Changelog

2016-02-10 - Matthias Klose <doko@ubuntu.com>
gettext (0.19.7-2ubuntu3) xenial; urgency=medium
* gettext: Move preloadable_libintl.so into the multiarch libdir.
2016-01-28 - Matthias Klose <doko@ubuntu.com>
gettext (0.19.7-2ubuntu2) xenial; urgency=medium
* Fix shlibs dependencies for multiarch locations.
2016-01-27 - Matthias Klose <doko@ubuntu.com>
gettext (0.19.7-2ubuntu1) xenial; urgency=medium
* Merge with Debian; remaining changes:
- Allow the package to cross-build.
- Define a stage1 profile to build without java and git.
- Explicitly configure with --disable-csharp.
- Drop autopoint recommends of gettext. It pulls in git and
other sizable packages which make the CDs explode.
- gettext-el: Add an alternative dependency on emacs24.
* Move libgettextsrc and libgettextlib into the multiarch libdir.
2016-01-05 - Santiago Vila <sanvila@debian.org>
gettext (0.19.7-2) unstable; urgency=high
* Install version specific data files from /usr/share/gettext-VERSION.
This should fix glade support. Thanks to Daiki Ueno. Closes: #809846. 
2015-12-29 - Santiago Vila <sanvila@debian.org>
gettext (0.19.7-1) unstable; urgency=medium
* New upstream release.
* Drop libexpat1-dev from Build-Depends, following upstream.
2015-12-15 - Rico Tzschichholz <ricotz@ubuntu.com>
gettext (0.19.6-1ubuntu1) xenial; urgency=low
* Merge from Debian unstable.  Remaining changes:
- Allow the package to cross-build.
- Define a stage1 profile to build without java and git.
- Explicitly configure with --disable-csharp.
- Drop autopoint recommends of gettext. It pulls in git and
other sizable packages which make the CDs explode.
- gettext-el: Add an alternative dependency on emacs24.
2015-09-14 - Santiago Vila <sanvila@debian.org>
gettext (0.19.6-1) unstable; urgency=medium
* New upstream release.
* Drop debian/patches/03-fix-gettextize-version. No longer needed.
* Drop dependency of gettext-base on libasprintf0v5 as it dates from
a split made in release 0.18.1.1-6.
* Keep curl and friends in Recommends, for translators.
Move autopoint, libasprintf-dev and libgettextpo-dev to Suggests.
* Downgrade libasprintf0v5 to optional.
* Add debian/upstream/signing-key.asc and improve debian/watch file.
* Makefile.in.in has now a general mechanism to set the header of
a POT file, using $(DOMAIN).pot-update. This could be used to set
copyright holders and other things. Closes: #682580.
* Fix po-mode handling of msgfmt version number. Closes: #798903.
* Drop Pre-Depends on multiarch-support, because a stable release
has already happened.
2015-08-02 - Santiago Vila <sanvila@debian.org>
gettext (0.19.5.1-1) unstable; urgency=medium
* New upstream release.
* New C++ ABI. libasprintf0c2 becomes libasprintf0v5.
Thanks a lot to Matthias Klose. Closes: #793897.
* Add patches/03-fix-gettextize-version to avoid FTBFS bugs on
packages using autopoint and friends. See bug-gettext for details.
2015-07-28 - Matthias Klose <doko@ubuntu.com>
gettext (0.19.4-1ubuntu3) wily; urgency=medium
* Rename libasprintf0c2 to libasprintf0v5.
* Add Conflict/Replaces to the old library.
2015-07-15 - Steve Langasek <steve.langasek@ubuntu.com>
gettext (0.19.4-1ubuntu2~gcc5.1) wily; urgency=medium
* No-change test rebuild for g++5 ABI transition

See Also

Package Description
autotools-dev_20150820.1_all.deb Update infrastructure for config.{guess,sub} files
avahi-autoipd_0.6.32~rc+dfsg-1ubuntu2_amd64.deb Avahi IPv4LL network address configuration daemon
avahi-daemon_0.6.32~rc+dfsg-1ubuntu2_amd64.deb Avahi mDNS/DNS-SD daemon
avahi-utils_0.6.32~rc+dfsg-1ubuntu2_amd64.deb Avahi browsing, publishing and discovery utilities
awstats_7.4+dfsg-1_all.deb powerful and featureful web server log analyzer
b43-fwcutter_019-2_amd64.deb utility for extracting Broadcom 43xx firmware
backuppc_3.3.1-2ubuntu3_amd64.deb high-performance, enterprise-grade system for backing up PCs
bamfdaemon_0.5.3~bzr0+16.04.20160415-0ubuntu1_amd64.deb Window matching library - daemon
baobab_3.18.1-1ubuntu1_amd64.deb GNOME disk usage analyzer
base-files_9.4ubuntu4_amd64.deb Debian base system miscellaneous files
base-passwd_3.5.39_amd64.deb Debian base system master password and group files
bash-completion_2.1-4.2ubuntu1_all.deb programmable completion for the bash shell
bash-doc_4.3-14ubuntu1_all.deb Documentation and examples for the GNU Bourne Again SHell
bash_4.3-14ubuntu1_amd64.deb GNU Bourne Again SHell
bbdb_2.36-4_all.deb The Insidious Big Brother Database (email rolodex) for Emacs
Advertisement
Advertisement