apturl_0.5.2ubuntu11_amd64.deb


Advertisement

Description

apturl - install packages using the apt protocol - GTK+ frontend

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Main amd64
Package filename apturl_0.5.2ubuntu11_amd64.deb
Package name apturl
Package version 0.5.2ubuntu11
Package release -
Package architecture amd64
Package type deb
Category admin
Homepage -
License -
Maintainer Michael Vogt <mvo@ubuntu.com>
Download size 8.19 KB
Installed size 56.00 KB
AptUrl is a simple graphical application that takes an URL (which follows the
apt-protocol) as a command line option, parses it and carries out the
operations that the URL describes (that is, it asks the user if he wants the
indicated packages to be installed and if the answer is positive does so for
him).
This package contains the GTK+ frontend.

Alternatives

Package Version Architecture Repository
apturl_0.5.2ubuntu11.2_amd64.deb 0.5.2ubuntu11.2 amd64 Ubuntu Updates Main
apturl_0.5.2ubuntu11.2_i386.deb 0.5.2ubuntu11.2 i386 Ubuntu Updates Main
apturl_0.5.2ubuntu11_i386.deb 0.5.2ubuntu11 i386 Ubuntu Main
apturl - - -

Requires

Name Value
adwaita-icon-theme -
apturl-common = 0.5.2ubuntu11
gir1.2-gtk-3.0 -
gir1.2-webkit2-4.0 -
python3-aptdaemon -
python3-aptdaemon.gtk3widgets -
python3-gi -
python3:any >= 3.3.2-2~
software-properties-gtk -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package apturl_0.5.2ubuntu11_amd64.deb
Source Package apturl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install apturl deb package:
    # sudo apt-get install apturl

Files

Path
/usr/bin/apturl-gtk
/usr/lib/python3/dist-packages/AptUrl/gtk/GtkUI.py
/usr/lib/python3/dist-packages/AptUrl/gtk/__init__.py
/usr/lib/python3/dist-packages/AptUrl/gtk/backend/InstallBackendAptdaemon.py
/usr/lib/python3/dist-packages/AptUrl/gtk/backend/InstallBackendSynaptic.py
/usr/lib/python3/dist-packages/AptUrl/gtk/backend/__init__.py
/usr/share/apturl/apturl-gtk.ui
/usr/share/doc/apturl/changelog.gz
/usr/share/doc/apturl/copyright
/usr/share/man/man8/apturl-gtk.8.gz

Changelog

2016-01-13 - Iain Lane <iain@orangesquash.org.uk>
apturl (0.5.2ubuntu11) xenial; urgency=medium
* Drop webkit1 support, we're switching to pure webkit2 now
2015-12-16 - Sebastien Bacher <seb128@ubuntu.com>
apturl (0.5.2ubuntu10) xenial; urgency=medium
* debian/apturl.install:
- don't install the gconf schemas, it's probably useful to no one
nowadays (would only work for applications using the GNOME2 libgnome)
and creates a depends on gconf which we want to drop from the iso
2015-10-15 - Sebastien Bacher <seb128@ubuntu.com>
apturl (0.5.2ubuntu9) wily; urgency=medium
* data/apturl-gtk.ui: set the dimension on the scrolledwindow rather
than the textview so the description is showing with a non zero height 
2015-06-30 - Iain Lane <iain@orangesquash.org.uk>
apturl (0.5.2ubuntu8) wily; urgency=medium
* Use webkit2 in addition to webkit1. (LP: #1469221)
2015-06-26 - Zygmunt Krynicki <zygmunt.krynicki@canonical.com>
apturl (0.5.2ubuntu7) wily; urgency=medium
* Don't include Debian version in the python module version (LP: #1465549)
2015-04-02 - Tim Lunn <tim@feathertop.org>
apturl (0.5.2ubuntu6) vivid; urgency=medium
[ Tim Lunn ]
* Don't use legacy icon names, these are no longer available in
adwaita-icon-theme. (LP: #1437150) 
[ Iain Lane ]
* For dialog-question, go back to using the stock icon name as Humanity
doesn't yet have an icon with the new name.
2015-01-26 - Iain Lane <iain@orangesquash.org.uk>
apturl (0.5.2ubuntu5) vivid; urgency=medium
* Switch gnome-icon-theme to adwaita-icon-theme, which is its
successor. (LP: #1414613)
2014-03-16 - Dimitri John Ledkov <xnox@ubuntu.com>
apturl (0.5.2ubuntu4) trusty; urgency=medium
* Drop libgtk2-perl Recommends to Suggests.
2013-12-11 - Sebastien Bacher <seb128@ubuntu.com>
apturl (0.5.2ubuntu3) trusty; urgency=low
* AptUrl/AptUrl.py: don't use decode on a str (lp: #1050826)
2013-10-08 - Michael Vogt <michael.vogt@ubuntu.com>
apturl (0.5.2ubuntu2) saucy; urgency=low
* adjust backend to reuse the bits from update-manager (LP: #1200775)

See Also

Package Description
archdetect-deb_1.117ubuntu2_amd64.deb Hardware architecture detector
aspell-doc_0.60.7~20110707-3build1_all.deb Documentation for GNU Aspell spell-checker
aspell-en_7.1-0-1.1_all.deb English dictionary for GNU Aspell
aspell_0.60.7~20110707-3build1_amd64.deb GNU Aspell spell-checker
at-spi2-core_2.18.3-4ubuntu1_amd64.deb Assistive Technology Service Provider Interface (dbus core)
at-spi2-doc_2.18.3-4ubuntu1_all.deb Assistive Technology Service Provider Interface (Documentation)
at_3.1.18-2ubuntu1_amd64.deb Delayed job execution and batch processing
attr_2.4.47-2_amd64.deb Utilities for manipulating filesystem extended attributes
auctex_11.88-1.1ubuntu1_all.deb integrated document editing environment for TeX etc
auditd_2.4.5-1ubuntu2_amd64.deb User space tools for security auditing
augeas-doc_1.4.0-0ubuntu1_all.deb Augeas lenses documentation
augeas-lenses_1.4.0-0ubuntu1_all.deb Set of lenses needed by libaugeas0 to parse config files
augeas-tools_1.4.0-0ubuntu1_amd64.deb Augeas command line tools
authbind_2.1.1+nmu1_amd64.deb Allows non-root programs to bind() to low ports
autoconf-doc_2.69-9_all.deb automatic configure script builder documentation
Advertisement
Advertisement