aptitude_0.7.4-2ubuntu2_amd64.deb


Advertisement

Description

aptitude - terminal-based package manager

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Main amd64
Package name: aptitude
Package version: 0.7.4
Package release: 2ubuntu2
Package architecture: amd64
Package type: deb
Installed size: 4.01 KB
Download size: 1.25 MB
Official Mirror: archive.ubuntu.com
aptitude is a package manager with a number of useful features, including: a mutt-like syntax for matching packages in a flexible manner, dselect-like persistence of user actions, the ability to retrieve and display the Debian changelog of most packages, and a command-line mode similar to that of apt-get. aptitude is also Y2K-compliant, non-fattening, naturally cleansing, and housebroken.

Alternatives

    Download

    Source package: aptitude

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install aptitude deb package:
      # sudo apt-get install aptitude

    Files

    • /etc/cron.daily/aptitude
    • /etc/logrotate.d/aptitude
    • /usr/bin/aptitude-curses
    • /usr/share/bug/aptitude
    • /usr/share/doc/aptitude/NEWS.Debian.gz
    • /usr/share/doc/aptitude/changelog.Debian.gz
    • /usr/share/doc/aptitude/copyright
    • /usr/share/lintian/overrides/aptitude
    • /usr/share/man/cs/man8/aptitude-curses.8.gz
    • /usr/share/man/de/man8/aptitude-curses.8.gz
    • /usr/share/man/es/man8/aptitude-curses.8.gz
    • /usr/share/man/fi/man8/aptitude-curses.8.gz
    • /usr/share/man/fr/man8/aptitude-curses.8.gz
    • /usr/share/man/gl/man8/aptitude-curses.8.gz
    • /usr/share/man/it/man8/aptitude-curses.8.gz
    • /usr/share/man/ja/man8/aptitude-curses.8.gz
    • /usr/share/man/man8/aptitude-curses.8.gz
    • /usr/share/man/pl/man8/aptitude-curses.8.gz
    • /usr/share/man/ru/man8/aptitude-curses.8.gz
    • /usr/share/menu/aptitude

    Changelog

    2015-12-09 - Dimitri John Ledkov <xnox@ubuntu.com> aptitude (0.7.4-2ubuntu2) xenial; urgency=high * Try forcing -O2 build, to resolve FTBFS on ppc64el.

    2015-12-01 - Michael Vogt <michael.vogt@ubuntu.com> aptitude (0.7.4-2ubuntu1) xenial; urgency=low * Merge from Debian unstable. Remaining changes: - Drop aptitude-doc to Suggests. - 03_branding: Ubuntu branding. - 04_changelog: Take changelogs from changelogs.ubuntu.com. - 14_html2text_preferred: Switch back to html2text in favor of elinks, since html2text is in main and elinks isn't. Convert all files to utf-8 encoding as it is better then ascii for iso-8859-1 (English docs).

    2015-11-27 - Axel Beckert <abe@debian.org> aptitude (0.7.4-2) unstable; urgency=high * Cherry-pick patch cfc3c6b9 from master to fix build against APT 1.1. * Bump b-d on libapt-pkg-dev to ≥ 1.1 for now to ease the transition.

    2015-10-16 - Manuel A. Fernandez Montecelo <mafm@debian.org> aptitude (0.7.4-1) unstable; urgency=low * New upstream release. Please see /usr/share/aptitude/NEWS for a change log with more details. - New features: * [curses] Show providers of virtual packages in "description" area (Closes: #103964) - Bug fixes: * Retrieve again long descriptions (Closes: #801460) * Fix for circular dependencies in internal_mark_delete() (Closes: #801430) * Fix race condition replacing ~/.aptitude/config (Closes: #764046) - User visible changes: * [cmdline] In versioned provides, include '=' symbol (Closes: #767393) * [cmdline] "show" now shows arch of packages in multi-arch systems * [curses] Use 'w' in action column for package downgrades (Closes: #801310) * [cmdline] Show feedback of some commands (hold, forbid-version, ...) with verbose>0 (Closes: #270033, #638841) * [cmdline] Require args for some commands: hold, keep... (Closes: #759520) - Internal changes: * In internal_mark_delete(), also check for auto-installability property of real packages providing virtual packages to stop them being marked for deletion (check was also done in later steps). * Convert some instances of boost::unordered_{set,map,multimap} to std:: * Convert some instances of boost::hash to std:: * Remove two uses of boost::lexical_cast, use std::to_string() instead * Create utility function remove_non_recursive() - Documentation: * manpage: * Remove wrong assertion that safe-upgrade does not accept --full-resolver (Closes: #560991) * Document missing &BD specifier when installing packages (Closes: #696568) * Guide/User's Manual: * Update renamed config option ::CmdLine::Show-Summary (Closes: #776789) * Correct some wrong examples of search patterns (Closes: #519456) * debian/patches: - Remove fix-tmpdir.patch, applied upstream

    2015-10-12 - Rico Tzschichholz <ricotz@ubuntu.com> aptitude (0.7.3-1ubuntu1) wily; urgency=medium * Merge with Debian; remaining changes: - Drop aptitude-doc to Suggests. - 03_branding: Ubuntu branding. - 04_changelog: Take changelogs from changelogs.ubuntu.com. - 14_html2text_preferred: Switch back to html2text in favor of elinks, since html2text is in main and elinks isn't. Convert all files to utf-8 encoding as it is better then ascii for iso-8859-1 (English docs).

    Advertisement
    Advertisement