erlang-x11_16.b.3-dfsg-1ubuntu2.2_all.deb


Advertisement

Description

erlang-x11 - Erlang/OTP applications that require X Window System

Property Value
Distribution Ubuntu 14.04 LTS (Trusty Tahr)
Repository Ubuntu Updates Universe i386
Package filename erlang-x11_16.b.3-dfsg-1ubuntu2.2_all.deb
Package name erlang-x11
Package version 16.b.3
Package release dfsg-1ubuntu2.2
Package architecture all
Package type deb
Category universe/interpreters
Homepage http://www.erlang.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 8.82 KB
Installed size 77.00 KB
This package is a dummy package which will install all Erlang/OTP
applications which use graphical interface and therefore require
X Window System to run.

Alternatives

Package Version Architecture Repository
erlang-x11_16.b.3-dfsg-1ubuntu2.2_all.deb 16.b.3 all Ubuntu Updates Universe
erlang-x11_16.b.3-dfsg-1ubuntu2_all.deb 16.b.3 all Ubuntu Universe
erlang-x11_16.b.3-dfsg-1ubuntu2_all.deb 16.b.3 all Ubuntu Universe
erlang-x11 - - -

Requires

Name Value
erlang-appmon -
erlang-base -
erlang-base-hipe -
erlang-common-test -
erlang-debugger -
erlang-dialyzer -
erlang-et -
erlang-gs -
erlang-megaco -
erlang-nox -
erlang-observer -
erlang-pman -
erlang-reltool -
erlang-test-server -
erlang-toolbar -
erlang-tv -
erlang-typer -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package erlang-x11_16.b.3-dfsg-1ubuntu2.2_all.deb
Source Package erlang

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install erlang-x11 deb package:
    # sudo apt-get install erlang-x11

Files

Path
/usr/share/doc/erlang-x11/AUTHORS.gz
/usr/share/doc/erlang-x11/README.Debian
/usr/share/doc/erlang-x11/TODO.Debian
/usr/share/doc/erlang-x11/changelog.Debian.gz
/usr/share/doc/erlang-x11/copyright

Changelog

2017-12-07 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
erlang (1:16.b.3-dfsg-1ubuntu2.2) trusty-security; urgency=medium
* SECURITY UPDATE: CRLF injection vulnerabilities in the FTP module
- debian/patches/CVE-2014-1693.patch: check values in
lib/inets/src/ftp/ftp.erl, /lib/inets/test/ftp_suite_lib.erl.
- CVE-2014-1693
* SECURITY UPDATE: padding-oracle attack
- debian/patches/CVE-2015-2774.patch: re-enable padding check and
provide option to disable in lib/ssl/doc/src/ssl.xml,
lib/ssl/src/dtls_record.erl, lib/ssl/src/ssl.erl,
lib/ssl/src/ssl_cipher.erl, lib/ssl/src/ssl_internal.hrl,
lib/ssl/src/ssl_record.erl, lib/ssl/src/tls_connection.erl,
lib/ssl/src/tls_record.erl, lib/ssl/test/ssl_cipher_SUITE.erl.
- CVE-2015-2774
* SECURITY UPDATE: Adaptive Chosen Ciphertext attack in TLS server
- debian/patches/CVE-2017-1000385.patch: add countermeasurements for
Bleichenbacher attack in lib/ssl/src/ssl_connection.erl,
lib/ssl/src/ssl_connection.hrl, lib/ssl/src/tls_connection.erl.
- CVE-2017-1000385
2014-08-12 - James Page <james.page@ubuntu.com>
erlang (1:16.b.3-dfsg-1ubuntu2.1) trusty; urgency=medium
* Enable IPv6 support in epmd (LP: #1312507), supporting use in IPv6
only environments:
- d/rules: Use "-DEPMD6" in CPPFLAGS and ensure this is passed to
relevant bits of the build process.
2014-01-10 - Matthias Klose <doko@ubuntu.com>
erlang (1:16.b.3-dfsg-1ubuntu2) trusty; urgency=medium
* Build erlang-base-hipe on ppc64 and ppc64el.
2014-01-06 - James Page <james.page@ubuntu.com>
erlang (1:16.b.3-dfsg-1ubuntu1) trusty; urgency=low
* Merge from Debian unstable.  Remaining changes:
- d/patches/fix-pointer-conversion.patch: Remove implicit integer to
pointer conversion.
- d/control: Drop libwxgtk3.0-dev build dependency. Wx isn't in main,
and not supposed to.
- d/control: Drop erlang-wx binary and associated dependencies from
other erlang-* packages.
- d/rules: Add "+debug_info" to ERL_COMPILE_FLAGS for debug builds.
- d/p/bytecode-compat.patch: Specify source/target = 1.5 when compiling
Java source code.
2013-12-12 - Sergei Golovan <sgolovan@debian.org>
erlang (1:16.b.3-dfsg-1) unstable; urgency=low
* New upstream release.
* Refreshed patches.
* Removed patch wich fixes segfault in erlang-wx because it is applied
upstream.
* Removed link diameterc.1.gz because the original manpage is renamed
from diameter-compile.1.gz to diameterc.1.gz.
2013-11-28 - James Page <james.page@ubuntu.com>
erlang (1:16.b.2-dfsg-2ubuntu1) trusty; urgency=low
* Merge from Debian unstable.  Remaining changes:
- d/patches/fix-pointer-conversion.patch: Remove implicit integer to
pointer conversion.
- d/control: Drop libwxgtk3.0-dev build dependency. Wx isn't in main,
and not supposed to.
- d/control: Drop erlang-wx binary and associated dependencies from
other erlang-* packages.
- d/rules: Add "+debug_info" to ERL_COMPILE_FLAGS for debug builds.
- d/p/bytecode-compat.patch: Specify source/target = 1.5 when compiling
Java source code.
2013-11-21 - Sergei Golovan <sgolovan@debian.org>
erlang (1:16.b.2-dfsg-2) unstable; urgency=low
* Switched to wxWidgets 3.0 from 2.8 for erlang-wx application.
* Fixed segfault on adding items to a wxListBox widget (reproducible with
wxWidgets 3.0).
* Added new erlang-dbg package with symbol files for libraries and
binaries in the other packages (except erlang-base-hipe).

See Also

Package Description
erlang_16.b.3-dfsg-1ubuntu2.2_all.deb Concurrent, real-time, distributed functional language
ettercap-common_0.8.0-11ubuntu0.3_i386.deb Multipurpose sniffer/interceptor/logger for switched LAN
ettercap-graphical_0.8.0-11ubuntu0.3_i386.deb Ettercap GUI-enabled executable
ettercap-text-only_0.8.0-11ubuntu0.3_i386.deb Ettercap console-mode executable
evince-gtk_3.10.3-0ubuntu10.4_i386.deb Document (PostScript, PDF) viewer (GTK+ version)
evolution-plugins-experimental_3.10.4-0ubuntu2_i386.deb experimental plugins for Evolution
exempi_2.2.1-1ubuntu1.1_i386.deb command line tool to manipulate XMP metadata
exiv2_0.23-1ubuntu2.2_i386.deb EXIF/IPTC metadata manipulation tool
exo-utils_0.10.2-3ubuntu1.14.04.2_i386.deb Utility files for libexo
expat_2.1.0-4ubuntu1.4_i386.deb XML parsing C library - example application
extplorer_2.1.0b6+dfsg.3-4+deb7u5build0.14.04.1_all.deb web file explorer and manager using Ext JS
faad_2.7-8+deb7u1build0.14.04.1_i386.deb freeware Advanced Audio Decoder player
ffmpegthumbs_4.13.3-0ubuntu0.1_i386.deb video thumbnail generator using ffmpeg
filelight_4.13.1-0ubuntu0.1_i386.deb show where your diskspace is being used
firebird-dev_2.5.2.26540.ds4-9ubuntu1.1_i386.deb Development files for Firebird - an RDBMS based on InterBase 6.0 code
Advertisement
Advertisement