lighttpd_1.4.33-1+nmu2ubuntu2.1_amd64.deb


Advertisement

Description

lighttpd - fast webserver with minimal memory footprint

Property Value
Distribution Ubuntu 14.04 LTS (Trusty Tahr)
Repository Ubuntu Updates Universe amd64
Package filename lighttpd_1.4.33-1+nmu2ubuntu2.1_amd64.deb
Package name lighttpd
Package version 1.4.33
Package release 1+nmu2ubuntu2.1
Package architecture amd64
Package type deb
Category universe/web
Homepage http://lighttpd.net/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 221.89 KB
Installed size 894.00 KB
lighttpd is a small webserver and fast webserver developed with
security in mind and a lot of features.
It has support for
* CGI, FastCGI and SSI
* virtual hosts
* URL rewriting
* authentication (plain files, htpasswd, LDAP)
* transparent content compression
* conditional configuration
* HTTP proxying
and configuration is straight-forward and easy.

Alternatives

Package Version Architecture Repository
lighttpd_1.4.33-1+nmu2ubuntu2.1_i386.deb 1.4.33 i386 Ubuntu Updates Universe
lighttpd_1.4.33-1+nmu2ubuntu2_i386.deb 1.4.33 i386 Ubuntu Universe
lighttpd_1.4.33-1+nmu2ubuntu2_amd64.deb 1.4.33 amd64 Ubuntu Universe
lighttpd - - -

Requires

Name Value
init-system-helpers >= 1.13~
libattr1 >= 1:2.4.46-8
libbz2-1.0 -
libc6 >= 2.15
libfam0 -
libgamin0 -
libldap-2.4-2 >= 2.4.7
libpcre3 -
libssl1.0.0 >= 1.0.0
libterm-readline-perl-perl -
lsb-base >= 3.2-14
mime-support -
perl -
systemd >= 29.1
zlib1g >= 1:1.1.4

Provides

Name Value
httpd -
httpd-cgi -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package lighttpd_1.4.33-1+nmu2ubuntu2.1_amd64.deb
Source Package lighttpd

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lighttpd deb package:
    # sudo apt-get install lighttpd

Files

Path
/etc/cron.daily/lighttpd
/etc/init.d/lighttpd
/etc/lighttpd/lighttpd.conf
/etc/lighttpd/conf-available/05-auth.conf
/etc/lighttpd/conf-available/10-accesslog.conf
/etc/lighttpd/conf-available/10-cgi.conf
/etc/lighttpd/conf-available/10-dir-listing.conf
/etc/lighttpd/conf-available/10-evasive.conf
/etc/lighttpd/conf-available/10-evhost.conf
/etc/lighttpd/conf-available/10-expire.conf
/etc/lighttpd/conf-available/10-fastcgi.conf
/etc/lighttpd/conf-available/10-flv-streaming.conf
/etc/lighttpd/conf-available/10-no-www.conf
/etc/lighttpd/conf-available/10-proxy.conf
/etc/lighttpd/conf-available/10-rrdtool.conf
/etc/lighttpd/conf-available/10-simple-vhost.conf
/etc/lighttpd/conf-available/10-ssi.conf
/etc/lighttpd/conf-available/10-ssl.conf
/etc/lighttpd/conf-available/10-status.conf
/etc/lighttpd/conf-available/10-userdir.conf
/etc/lighttpd/conf-available/10-usertrack.conf
/etc/lighttpd/conf-available/11-extforward.conf
/etc/lighttpd/conf-available/15-fastcgi-php.conf
/etc/lighttpd/conf-available/90-debian-doc.conf
/etc/lighttpd/conf-available/README
/etc/logrotate.d/lighttpd
/etc/ufw/applications.d/lighttpd
/lib/systemd/system/lighttpd.service
/usr/lib/lighttpd/mod_access.so
/usr/lib/lighttpd/mod_accesslog.so
/usr/lib/lighttpd/mod_alias.so
/usr/lib/lighttpd/mod_auth.so
/usr/lib/lighttpd/mod_cgi.so
/usr/lib/lighttpd/mod_compress.so
/usr/lib/lighttpd/mod_dirlisting.so
/usr/lib/lighttpd/mod_evasive.so
/usr/lib/lighttpd/mod_evhost.so
/usr/lib/lighttpd/mod_expire.so
/usr/lib/lighttpd/mod_extforward.so
/usr/lib/lighttpd/mod_fastcgi.so
/usr/lib/lighttpd/mod_flv_streaming.so
/usr/lib/lighttpd/mod_indexfile.so
/usr/lib/lighttpd/mod_proxy.so
/usr/lib/lighttpd/mod_redirect.so
/usr/lib/lighttpd/mod_rewrite.so
/usr/lib/lighttpd/mod_rrdtool.so
/usr/lib/lighttpd/mod_scgi.so
/usr/lib/lighttpd/mod_secdownload.so
/usr/lib/lighttpd/mod_setenv.so
/usr/lib/lighttpd/mod_simple_vhost.so
/usr/lib/lighttpd/mod_ssi.so
/usr/lib/lighttpd/mod_staticfile.so
/usr/lib/lighttpd/mod_status.so
/usr/lib/lighttpd/mod_userdir.so
/usr/lib/lighttpd/mod_usertrack.so
/usr/lib/tmpfiles.d/lighttpd.tmpfile.conf
/usr/sbin/lighttpd
/usr/sbin/lighttpd-angel
/usr/sbin/lighttpd-disable-mod
/usr/sbin/lighttpd-enable-mod
/usr/sbin/lighty-disable-mod
/usr/sbin/lighty-enable-mod
/usr/share/doc/lighttpd/NEWS.Debian.gz
/usr/share/doc/lighttpd/NEWS.gz
/usr/share/doc/lighttpd/README
/usr/share/doc/lighttpd/changelog.Debian.gz
/usr/share/doc/lighttpd/copyright
/usr/share/lighttpd/create-mime.assign.pl
/usr/share/lighttpd/include-conf-enabled.pl
/usr/share/lighttpd/index.html
/usr/share/lighttpd/use-ipv6.pl
/usr/share/lintian/overrides/lighttpd
/usr/share/man/man1/lighttpd-disable-mod.1.gz
/usr/share/man/man1/lighttpd-enable-mod.1.gz
/usr/share/man/man1/lighty-disable-mod.1.gz
/usr/share/man/man1/lighty-enable-mod.1.gz
/usr/share/man/man8/lighttpd.8.gz

Changelog

2019-01-25 - Paulo Flabiano Smorigo <pfsmorigo@canonical.com>
lighttpd (1.4.33-1+nmu2ubuntu2.1) trusty-security; urgency=medium
* SECURITY UPDATE: Fix vulnerabilities in mod_sql and HTTPoxy.
- debian/patches/CVE-2014-2323-CVE-2014-2324.patch: Fix SQL injection
vulnerability in mod_mysql_vhost.c.
- debian/patches/CVE-2016-1000212.patch: Mitigation for HTTPoxy
vulnerability.
- CVE-2014-2323
- CVE-2014-2324
- CVE-2016-1000212
2014-01-28 - Andreas Moog <andreas.moog@warperbbs.de>
lighttpd (1.4.33-1+nmu2ubuntu2) trusty; urgency=medium
* Use dh-autoreconf to regenerate autotools files, fixes FTBFS with 
automake 1.14.1 (Closes: #726934)
* Add lighttpd.pc to ac_config_files to fix FTBFS:
make[3]: *** No rule to make target `lighttpd.pc', needed by `all-am'.
2013-12-18 - Mahyuddin Susanto <udienz@ubuntu.com>
lighttpd (1.4.33-1+nmu2ubuntu1) trusty; urgency=low
* Merge from Debian unstable.  Remaining changes:
- debian/index.html: corrected BTS Ubuntu link for lighttpd.
- debian/index.html: s/Debian/Ubuntu/g branding on the default page.
- debian/lighttpd.conf: Comment 'use-ipv6.pl' by default, which causes
failure to bind port in ipv4.
- Add lighttpd-dev package:
+ debian/control: Added lighttpd-dev package; Build-depends on
automake (>=1.14), libtool.
+ debian/lighttpd-dev.install: Added.
- debian/control: libgamin-dev rather than libfam-dev to fix startup warning.
- debian/rules: Add override_dh_installinit to set "defaults 91 09" to not
start before apache2 but in the same runlevel with the same priority.
- Added a UFW profile set:
+ debian/lighttpd.dirs: added etc/ufw/applications.d
+ debian/rules: install the ufw profile.
+ debian/control: Suggests on ufw.
2013-11-16 - Michael Gilbert <mgilbert@debian.org>
lighttpd (1.4.33-1+nmu2) unstable; urgency=high
* Non-maintainer upload by the Security Team.
* Fix regression caused by the fix for cve-2013-4508 (closes: #729480).
2013-11-13 - Michael Gilbert <mgilbert@debian.org>
lighttpd (1.4.33-1+nmu1) unstable; urgency=high
* Non-maintainer upload by the Security Team (closes: #729453).
* Fix cve-2013-4508: ssl cipher suites issue.
* Fix cve-2013-4559: setuid privilege escalation issue.
* Fix cve-2013-4560: use-after-free in fam.
2013-10-30 - Mattia Rizzolo <mapreri@ubuntu.com>
lighttpd (1.4.33-1ubuntu1) trusty; urgency=low
* Merge from Debian unstable (LP: #1246886).  Remaining changes:
- debian/index.html: corrected BTS Ubuntu link for lighttpd.
- debian/index.html: s/Debian/Ubuntu/g branding on the default page.
- debian/lighttpd.conf: Comment 'use-ipv6.pl' by default, which causes
failure to bind port in ipv4.
- Add lighttpd-dev package:
+ debian/control: Added lighttpd-dev package; Build-depends on
automake (>=1.14), libtool.
+ debian/lighttpd-dev.install: Added.
- debian/control: libgamin-dev rather than libfam-dev to fix startup warning.
- debian/rules: Add override_dh_installinit to set "defaults 91 09" to not
start before apache2 but in the same runlevel with the same priority.
- Added a UFW profile set:
+ debian/lighttpd.dirs: added etc/ufw/applications.d
+ debian/rules: install the ufw profile.
+ debian/control: Suggests on ufw.
- debian/patches/build-dev-package.patch: Updated to reflect 1.4.33 changes.

See Also

Package Description
linux-aws-cloud-tools-4.4.0-1002_4.4.0-1002.2_amd64.deb Linux kernel version specific cloud tools for version 4.4.0-1002
linux-aws-cloud-tools-4.4.0-1003_4.4.0-1003.3_amd64.deb Linux kernel version specific cloud tools for version 4.4.0-1003
linux-aws-cloud-tools-4.4.0-1005_4.4.0-1005.5_amd64.deb Linux kernel version specific cloud tools for version 4.4.0-1005
linux-aws-cloud-tools-4.4.0-1006_4.4.0-1006.6_amd64.deb Linux kernel version specific cloud tools for version 4.4.0-1006
linux-aws-cloud-tools-4.4.0-1009_4.4.0-1009.9_amd64.deb Linux kernel version specific cloud tools for version 4.4.0-1009
linux-aws-cloud-tools-4.4.0-1010_4.4.0-1010.10_amd64.deb Linux kernel version specific cloud tools for version 4.4.0-1010
linux-aws-cloud-tools-4.4.0-1011_4.4.0-1011.11_amd64.deb Linux kernel version specific cloud tools for version 4.4.0-1011
linux-aws-cloud-tools-4.4.0-1012_4.4.0-1012.12_amd64.deb Linux kernel version specific cloud tools for version 4.4.0-1012
linux-aws-cloud-tools-4.4.0-1014_4.4.0-1014.14_amd64.deb Linux kernel version specific cloud tools for version 4.4.0-1014
linux-aws-cloud-tools-4.4.0-1016_4.4.0-1016.16_amd64.deb Linux kernel version specific cloud tools for version 4.4.0-1016
linux-aws-cloud-tools-4.4.0-1017_4.4.0-1017.17_amd64.deb Linux kernel version specific cloud tools for version 4.4.0-1017
linux-aws-cloud-tools-4.4.0-1019_4.4.0-1019.19_amd64.deb Linux kernel version specific cloud tools for version 4.4.0-1019
linux-aws-cloud-tools-4.4.0-1022_4.4.0-1022.22_amd64.deb Linux kernel version specific cloud tools for version 4.4.0-1022
linux-aws-cloud-tools-4.4.0-1023_4.4.0-1023.23_amd64.deb Linux kernel version specific cloud tools for version 4.4.0-1023
linux-aws-cloud-tools-4.4.0-1024_4.4.0-1024.25_amd64.deb Linux kernel version specific cloud tools for version 4.4.0-1024
Advertisement
Advertisement