libapache2-mod-php5filter_5.5.9+dfsg-1ubuntu4.29_amd64.deb


Advertisement

Description

libapache2-mod-php5filter - server-side, HTML-embedded scripting language (apache 2 filter module)

Property Value
Distribution Ubuntu 14.04 LTS (Trusty Tahr)
Repository Ubuntu Updates Universe amd64
Package filename libapache2-mod-php5filter_5.5.9+dfsg-1ubuntu4.29_amd64.deb
Package name libapache2-mod-php5filter
Package version 5.5.9+dfsg
Package release 1ubuntu4.29
Package architecture amd64
Package type deb
Category universe/httpd
Homepage http://www.php.net/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 2.10 MB
Installed size 9.50 MB
This package provides the PHP5 Filter module for the Apache 2 webserver (as
found in the apache2-mpm-prefork package).  Please note that this package
ONLY works with Apache's prefork MPM, as it is not compiled thread-safe.
Unless you specifically need filter-module support, you most likely
should instead install libapache2-mod-php5.
The following extensions are built in: bcmath bz2 calendar Core ctype date
dba dom ereg exif fileinfo filter ftp gettext hash iconv libxml mbstring
mhash openssl pcre Phar posix Reflection session shmop SimpleXML soap
sockets SPL standard sysvmsg sysvsem sysvshm tokenizer wddx xml xmlreader
xmlwriter zip zlib.
PHP (recursive acronym for PHP: Hypertext Preprocessor) is a widely-used
open source general-purpose scripting language that is especially suited
for web development and can be embedded into HTML.

Alternatives

Package Version Architecture Repository
libapache2-mod-php5filter_5.5.9+dfsg-1ubuntu4.29_i386.deb 5.5.9+dfsg i386 Ubuntu Updates Universe
libapache2-mod-php5filter_5.5.9+dfsg-1ubuntu4_i386.deb 5.5.9+dfsg i386 Ubuntu Universe
libapache2-mod-php5filter_5.5.9+dfsg-1ubuntu4_amd64.deb 5.5.9+dfsg amd64 Ubuntu Universe
libapache2-mod-php5filter - - -

Requires

Name Value
apache2 >= 2.4
apache2-api-20120211 -
libbz2-1.0 -
libc6 >= 2.15
libdb5.3 -
libmagic1 -
libpcre3 -
libssl1.0.0 >= 1.0.0
libxml2 >= 2.9.0
mime-support -
php5-common = 5.5.9+dfsg-1ubuntu4.29
tzdata -
ucf -
zlib1g >= 1:1.1.4

Conflicts

Name Value
libapache2-mod-php4 -
libapache2-mod-php5 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libapache2-mod-php5filter_5.5.9+dfsg-1ubuntu4.29_amd64.deb
Source Package php5

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libapache2-mod-php5filter deb package:
    # sudo apt-get install libapache2-mod-php5filter

Files

Path
/etc/apache2/mods-available/php5filter.conf
/etc/apache2/mods-available/php5filter.load
/usr/lib/apache2/modules/libphp5filter.so
/usr/share/bug/libapache2-mod-php5filter/control
/usr/share/bug/libapache2-mod-php5filter/script
/usr/share/doc/libapache2-mod-php5filter
/usr/share/lintian/overrides/libapache2-mod-php5filter
/usr/share/php5/sapi/apache2filter

Changelog

2019-04-22 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
php5 (5.5.9+dfsg-1ubuntu4.29) trusty-security; urgency=medium
* SECURITY UPDATE: Unauthorized users access
- debian/patches/CVE-2019-9637.patch: fix in
main/streams/plain_wrapper.c.
- CVE-2019-9637
* SECURITY UPDATE: Invalid read in exif_process_IFD_MAKERNOTE
- debian/patches/CVE-2019-9638-and-CVE-2019-9639-*.patch: fix in
ext/exif/exif.c, added tests in ext/exif/tests/bug77563.jpg,
ext/exif/tests/bug77563.phpt.
- CVE-2019-9638
- CVE-2019-9639
* SECURITY UPDATE: Invalid read
- debian/patches/CVE-2019-9640.patch: fix in
ext/exif/exif.c, added tests in ext/exif/tests/bug77540.jpg,
ext/exif/tests/bug77540.phpt.
- CVE-2019-9640
* SECURITY UPDATE: Unitialized read
- debian/patches/CVE-2019-9641.patch: fix in ext/exif/exif.c.
- CVE-2019-9641
* SECURITY UPDATE: Buffer overflow
- debian/patches/CVE-2019-9675.patch: fix in
ext/phar/tar.c, added tests, ext/phar/tests/bug77586,phpt,
ext/phar/tests/bug77586/files/*.
- CVE-2019-9675
* Changed the way MAKERNOTE is handled in case we do not have a matching
signature, in order to support tests CVE-2019-9638 and CVE-2019-9639.
- debian/patches/Changed-the-way-MAKERNOTE-is-handled-in-case.patch: fix
it changing the behavior in order to continue the parse in
ext/exif/exif.c
* SECURITY UPDATE: buffer over-read in dns_get_record
- debian/patches/CVE-2019-9022.patch: check length in
ext/standard/dns.c.
- CVE-2019-9022
2019-03-05 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
php5 (5.5.9+dfsg-1ubuntu4.27) trusty-security; urgency=medium
* SECURITY UPDATE: invalid memory access in xmlrpc_decode()
- debian/patches/CVE-2019-9020.patch: check length in
ext/xmlrpc/libxmlrpc/xml_element.c, added test to
ext/xmlrpc/tests/bug77242.phpt.
- CVE-2019-9020
* SECURITY UPDATE: buffer over-read in PHAR extension
- debian/patches/CVE-2019-9021.patch: properly calculate position in
ext/phar/phar.c, added test to ext/phar/tests/bug77247.phpt.
- CVE-2019-9021
* SECURITY UPDATE: buffer over-reads in mbstring regex functions
- debian/patches/CVE-2019-9023-1.patch: don't read past buffer in
ext/mbstring/oniguruma/regparse.c, added test to
ext/mbstring/tests/bug77370.phpt.
- debian/patches/CVE-2019-9023-2.patch: check bounds in
ext/mbstring/oniguruma/regcomp.c, added test to
ext/mbstring/tests/bug77371.phpt.
- debian/patches/CVE-2019-9023-3.patch: add length checks to
ext/mbstring/oniguruma/enc/unicode.c,
ext/mbstring/oniguruma/regcomp.c, ext/mbstring/oniguruma/regparse.c,
ext/mbstring/oniguruma/regparse.h, added test to
ext/mbstring/tests/bug77371.phpt, ext/mbstring/tests/bug77381.phpt.
- debian/patches/CVE-2019-9023-4.patch: add new bounds checks to
ext/mbstring/oniguruma/enc/utf16_be.c,
ext/mbstring/oniguruma/enc/utf16_le.c,
ext/mbstring/oniguruma/enc/utf32_be.c,
ext/mbstring/oniguruma/enc/utf32_le.c, added test to
ext/mbstring/tests/bug77418.phpt.
- CVE-2019-9023
* SECURITY UPDATE: buffer over-read in xmlrpc_decode()
- debian/patches/CVE-2019-9024.patch: fix variable size in
ext/xmlrpc/libxmlrpc/base64.c, added test to
ext/xmlrpc/tests/bug77380.phpt.
- CVE-2019-9024
2018-09-17 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
php5 (5.5.9+dfsg-1ubuntu4.26) trusty-security; urgency=medium
* SECURITY UPDATE: denial of service in exif parsing
- debian/patches/CVE-2018-14851.patch: check length in ext/exif/exif.c.
- CVE-2018-14851
* SECURITY UPDATE: denial of service in exif parsing
- debian/patches/CVE-2018-14883.patch: check length in ext/exif/exif.c.
- CVE-2018-14883
* SECURITY UPDATE: XSS due to the header Transfer-Encoding: chunked
- debian/patches/bug76582.patch: clean up brigade in
sapi/apache2handler/sapi_apache2.c.
- No CVE number

See Also

Package Description
libapache2-mod-proxy-html_2.4.7-1ubuntu4.22_amd64.deb Transitional package for apache2-bin
libapache2-mod-proxy-uwsgi_1.9.17.1-5ubuntu0.1_amd64.deb uwsgi proxy module for Apache2 (mod_uwsgi)
libapache2-mod-ruwsgi_1.9.17.1-5ubuntu0.1_amd64.deb uwsgi module for Apache2 (mod_Ruwsgi)
libapache2-mod-svn_1.8.8-1ubuntu3.3_amd64.deb Apache Subversion server modules for Apache httpd
libapache2-mod-uwsgi_1.9.17.1-5ubuntu0.1_amd64.deb uwsgi module for Apache2 (mod_uwsgi)
libapache2-mod-wsgi-py3_3.4-4ubuntu2.1.14.04.2_amd64.deb Python 3 WSGI adapter module for Apache
libapache2-mpm-itk_2.4.6-01-1ubuntu1_amd64.deb multiuser module for Apache
libapache2-svn_1.8.8-1ubuntu3.3_all.deb Apache Subversion server modules for Apache httpd (dummy package)
libasan0-dbg-armhf-cross_4.8.4-2ubuntu1~14.04.1cross0.11.2_all.deb AddressSanitizer -- a fast memory error detector (debug symbols)
libasan0-dbg-powerpc-cross_4.8.4-2ubuntu1~14.04.1cross0.11.2_all.deb AddressSanitizer -- a fast memory error detector (debug symbols)
libastro-dev_4.13.3-0ubuntu0.1_amd64.deb development files for the Marble astrononmy library
libastro1_4.13.3-0ubuntu0.1_amd64.deb Marble astronomy library
libatomic1-dbg-arm64-cross_4.8.4-2ubuntu1~14.04.1cross0.11.2_all.deb support library providing __atomic built-in functions (debug symbols)
libatomic1-dbg-armhf-cross_4.8.4-2ubuntu1~14.04.1cross0.11.2_all.deb support library providing __atomic built-in functions (debug symbols)
libatomic1-dbg-powerpc-cross_4.8.4-2ubuntu1~14.04.1cross0.11.2_all.deb support library providing __atomic built-in functions (debug symbols)
Advertisement
Advertisement