docker.io_1.6.2~dfsg1-1ubuntu4~14.04.1_amd64.deb


Advertisement

Description

docker.io - Linux container runtime

Property Value
Distribution Ubuntu 14.04 LTS (Trusty Tahr)
Repository Ubuntu Updates Universe amd64
Package filename docker.io_1.6.2~dfsg1-1ubuntu4~14.04.1_amd64.deb
Package name docker.io
Package version 1.6.2~dfsg1
Package release 1ubuntu4~14.04.1
Package architecture amd64
Package type deb
Category universe/admin
Homepage https://dockerproject.com
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 4.53 MB
Installed size 27.79 MB
Docker complements kernel namespacing with a high-level API which operates at
the process level. It runs unix processes with strong guarantees of isolation
and repeatability across servers.
Docker is a great building block for automating distributed systems:
large-scale web deployments, database clusters, continuous deployment systems,
private PaaS, service-oriented architectures, etc.
This package contains the daemon and client. Using docker.io on non-amd64 hosts
is not supported at this time. Please be careful when using it on anything
besides amd64.
Also, note that kernel version 3.8 or above is required for proper operation of
the daemon process, and that any lower versions may have subtle and/or glaring
issues.

Alternatives

Package Version Architecture Repository
docker.io_1.6.2~dfsg1-1ubuntu4~14.04.1_i386.deb 1.6.2~dfsg1 i386 Ubuntu Updates Universe
docker.io_0.9.1~dfsg1-2_i386.deb 0.9.1~dfsg1 i386 Ubuntu Universe
docker.io_0.9.1~dfsg1-2_amd64.deb 0.9.1~dfsg1 amd64 Ubuntu Universe
docker.io - - -

Requires

Name Value
adduser -
file-rc >= 0.8.16
init-system-helpers >= 1.13~
iptables -
libapparmor1 >= 2.6~devel
libc6 >= 2.14
libdevmapper1.02.1 >= 2:1.02.63
libsqlite3-0 >= 3.5.9
perl -
sysv-rc >= 2.88dsf-24

Replaces

Name Value
docker << 1.5~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package docker.io_1.6.2~dfsg1-1ubuntu4~14.04.1_amd64.deb
Source Package docker.io

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install docker.io deb package:
    # sudo apt-get install docker.io

Files

Path
/etc/bash_completion.d/docker
/etc/default/docker
/etc/init/docker.conf
/etc/init.d/docker
/lib/systemd/system/docker.service
/lib/systemd/system/docker.socket
/lib/udev/rules.d/80-docker.io.rules
/usr/bin/docker
/usr/bin/docker.io
/usr/lib/docker.io/dockerinit
/usr/share/doc/docker.io/README.Debian
/usr/share/doc/docker.io/README.md.gz
/usr/share/doc/docker.io/changelog.Debian.gz
/usr/share/doc/docker.io/copyright
/usr/share/docker.io/contrib/check-config.sh
/usr/share/docker.io/contrib/mkimage-alpine.sh
/usr/share/docker.io/contrib/mkimage-arch-pacman.conf
/usr/share/docker.io/contrib/mkimage-arch.sh
/usr/share/docker.io/contrib/mkimage-busybox.sh
/usr/share/docker.io/contrib/mkimage-crux.sh
/usr/share/docker.io/contrib/mkimage-debootstrap.sh
/usr/share/docker.io/contrib/mkimage-rinse.sh
/usr/share/docker.io/contrib/mkimage-unittest.sh
/usr/share/docker.io/contrib/mkimage-yum.sh
/usr/share/docker.io/contrib/mkimage.sh
/usr/share/docker.io/contrib/mkseccomp.pl
/usr/share/docker.io/contrib/mkseccomp.sample
/usr/share/docker.io/contrib/nuke-graph-directory.sh
/usr/share/docker.io/contrib/desktop-integration/README.md
/usr/share/docker.io/contrib/desktop-integration/chromium/Dockerfile
/usr/share/docker.io/contrib/desktop-integration/gparted/Dockerfile
/usr/share/docker.io/contrib/host-integration/Dockerfile.dev
/usr/share/docker.io/contrib/host-integration/Dockerfile.min
/usr/share/docker.io/contrib/host-integration/manager.go
/usr/share/docker.io/contrib/host-integration/manager.sh
/usr/share/docker.io/contrib/host-integration/manager/systemd
/usr/share/docker.io/contrib/host-integration/manager/upstart
/usr/share/docker.io/contrib/mkimage/.febootstrap-minimize
/usr/share/docker.io/contrib/mkimage/busybox-static
/usr/share/docker.io/contrib/mkimage/debootstrap
/usr/share/docker.io/contrib/mkimage/mageia-urpmi
/usr/share/docker.io/contrib/mkimage/rinse
/usr/share/lintian/overrides/docker.io
/usr/share/man/man1/docker-attach.1.gz
/usr/share/man/man1/docker-build.1.gz
/usr/share/man/man1/docker-commit.1.gz
/usr/share/man/man1/docker-cp.1.gz
/usr/share/man/man1/docker-create.1.gz
/usr/share/man/man1/docker-diff.1.gz
/usr/share/man/man1/docker-events.1.gz
/usr/share/man/man1/docker-exec.1.gz
/usr/share/man/man1/docker-export.1.gz
/usr/share/man/man1/docker-history.1.gz
/usr/share/man/man1/docker-images.1.gz
/usr/share/man/man1/docker-import.1.gz
/usr/share/man/man1/docker-info.1.gz
/usr/share/man/man1/docker-inspect.1.gz
/usr/share/man/man1/docker-kill.1.gz
/usr/share/man/man1/docker-load.1.gz
/usr/share/man/man1/docker-login.1.gz
/usr/share/man/man1/docker-logout.1.gz
/usr/share/man/man1/docker-logs.1.gz
/usr/share/man/man1/docker-pause.1.gz
/usr/share/man/man1/docker-port.1.gz
/usr/share/man/man1/docker-ps.1.gz
/usr/share/man/man1/docker-pull.1.gz
/usr/share/man/man1/docker-push.1.gz
/usr/share/man/man1/docker-rename.1.gz
/usr/share/man/man1/docker-restart.1.gz
/usr/share/man/man1/docker-rm.1.gz
/usr/share/man/man1/docker-rmi.1.gz
/usr/share/man/man1/docker-run.1.gz
/usr/share/man/man1/docker-save.1.gz
/usr/share/man/man1/docker-search.1.gz
/usr/share/man/man1/docker-start.1.gz
/usr/share/man/man1/docker-stats.1.gz
/usr/share/man/man1/docker-stop.1.gz
/usr/share/man/man1/docker-tag.1.gz
/usr/share/man/man1/docker-top.1.gz
/usr/share/man/man1/docker-unpause.1.gz
/usr/share/man/man1/docker-version.1.gz
/usr/share/man/man1/docker-wait.1.gz
/usr/share/man/man1/docker.1.gz
/usr/share/man/man5/Dockerfile.5.gz
/usr/share/zsh/vendor-completions/_docker

Changelog

2015-09-22 - Pierre-André MOREY <pierre-andre.morey@canonical.com>
docker.io (1.6.2~dfsg1-1ubuntu4~14.04.1) trusty; urgency=medium
* Backport to Ubuntu 14.04 (LP: #1454719).
* Disabled
- d/p/lxc.autodev-support.patch to minimise regression risk as
it is not relevant for the version of LXC on Trusty (1.0.3-0ubuntu3).
- d/p/update-go.net-golang.org.patch: there has been a url
canonical name change upstream, but keeping this patch on involves
backporting golang to 1.4 which is undesirable for this backport
(golang-go.net-dev needs golang-x-text, which does not build
successfully without a 1.4 backport).
- Wily related fixes:
+ d/p/golang-1.5-wily.patch to fix FTBFS with golang-1.5 build on wily
+ d/p/ppc64el-wily.patch to fix ppc64le FTBFS on wily (LP: #1488668)
+ d/p/libcontainer_arm64_syscall_dup2_to_dup3-c_changes.patch (LP: #1488669)
+ d/p/libcontainer_arm64_syscall_dup2_to_dup3-golang_changes.patch (LP: #1488669)
+ d/rules to build with golang-go on arm64 (LP: #1488669)
+ d/control to build with golang-go on arm64 (LP: #1488669)
* Reverted:
d/rules: http://anonscm.debian.org/cgit/docker/docker.io.git/diff/?id=b1458f5
commit to preserve docker.io symlink.
2015-09-18 - Pierre-André MOREY <pierre-andre.morey@canonical.com>
docker.io (1.6.2~dfsg1-1ubuntu4) wily; urgency=medium
* Add patches from upstream to fix some upgrade path bugs:
- d/p/add-mutex-read-m_path.patch to fix vivid upgrade-path
- d/p/stop-systemd-on-destroy.patch to fix leftover ".scope" fails
* Add patches to fix Wily FTBFS:
- d/p/ppc64el-wily.patch to fix ppc64le FTBFS on wily (LP: #1488668)
- d/p/golang-1.5-wily.patch to fix FTBFS with golang-1.5 build on
wily
* arm64 support fixes for golang-go build (LP: #1488669):
- d/p/libcontainer_arm64_syscall_dup2_to_dup3-c_changes.patch (LP:
#1488669)
- d/p/libcontainer_arm64_syscall_dup2_to_dup3-golang_changes.patch
(LP: #1488669)
* d/rules to build with golang-go on arm64 (LP: #1488669)
* d/control to build with golang-go on arm64 (LP: #1488669)
* Revert device-mapper-cleanup.patch dropped with an new one:
d/p/device-mapper-cleanup2.patch
2015-07-10 - Pierre-André MOREY <pierre-andre.morey@canonical.com>
docker.io (1.6.2~dfsg1-1ubuntu3~14.04.1) trusty; urgency=medium
* Backport to Ubuntu 14.04 (LP: #1454719).
* Disable d/p/lxc.autodev-support.patch to minimise regression risk as
it is not relevant for the version of LXC on Trusty (1.0.3-0ubuntu3).
* Disable d/p/update-go.net-golang.org.patch: there has been a url
canonical name change upstream, but keeping this patch on involves
backporting golang to 1.4 which is undesirable for this backport
(golang-go.net-dev needs golang-x-text, which does not build
successfully without a 1.4 backport).
* d/rules: revert
http://anonscm.debian.org/cgit/docker/docker.io.git/diff/?id=b1458f5
commit to preserve docker.io symlink.
2015-07-09 - Pierre-André MOREY <pierre-andre.morey@canonical.com>
docker.io (1.6.2~dfsg1-1ubuntu3) wily; urgency=medium
* d/docker.io.postinst: fix restart issue on upgrade path from
1.5.0~dfsg1-1ubuntu2 (LP: #1459916).
2015-06-25 - Pierre-André MOREY <pierre-andre.morey@canonical.com>
docker.io (1.6.2~dfsg1-1ubuntu2) wily; urgency=medium
* Add patches
- d/p/lxc.autodev-support.patch: fix bug: LP: #1466550
Make LXC exec driver compatible with recent lxc where lxc.autodev is enabled
by default. 
- d/p/update-go.net-golang.org.patch: fix FTBS bug from wily

See Also

Package Description
docker_1.5-1_amd64.deb System tray for KDE3/GNOME2 docklet applications
dolphin_4.13.3-0ubuntu0.1_amd64.deb file manager
dose-builddebcheck_3.1.3-7ubuntu0.1_amd64.deb Checks whether build-dependencies can be satisfied
dose-distcheck_3.1.3-7ubuntu0.1_amd64.deb Checks whether dependencies of packages can be satisfied
dose-extra_3.1.3-7ubuntu0.1_amd64.deb Extra QA tools from the Dose3-library
dovecot-gssapi_2.2.9-1ubuntu2.6_amd64.deb secure POP3/IMAP server - GSSAPI support
dovecot-ldap_2.2.9-1ubuntu2.6_amd64.deb secure POP3/IMAP server - LDAP support
dovecot-lmtpd_2.2.9-1ubuntu2.6_amd64.deb secure POP3/IMAP server - LMTP server
dovecot-mysql_2.2.9-1ubuntu2.6_amd64.deb secure POP3/IMAP server - MySQL support
dovecot-pgsql_2.2.9-1ubuntu2.6_amd64.deb secure POP3/IMAP server - PostgreSQL support
dovecot-solr_2.2.9-1ubuntu2.6_amd64.deb secure POP3/IMAP server - Solr support
dovecot-sqlite_2.2.9-1ubuntu2.6_amd64.deb secure POP3/IMAP server - SQLite support
dput-ng-doc_1.7ubuntu0.1_all.deb next generation Debian package upload tool (documentation)
dput-ng_1.7ubuntu0.1_all.deb next generation Debian package upload tool
dragonplayer_4.13.3-0ubuntu0.1_amd64.deb simple video player
Advertisement
Advertisement