python3-tk_3.4.3-1~14.04.2_i386.deb


Advertisement

Description

python3-tk - Tkinter - Writing Tk applications with Python 3.x

Property Value
Distribution Ubuntu 14.04 LTS (Trusty Tahr)
Repository Ubuntu Updates Main i386
Package filename python3-tk_3.4.3-1~14.04.2_i386.deb
Package name python3-tk
Package version 3.4.3
Package release 1~14.04.2
Package architecture i386
Package type deb
Category python
Homepage -
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 21.95 KB
Installed size 100.00 KB
A module for writing portable GUI applications with Python 3.x using Tk.
Also known as Tkinter.

Alternatives

Package Version Architecture Repository
python3-tk_3.4.3-1~14.04.2_amd64.deb 3.4.3 amd64 Ubuntu Updates Main
python3-tk_3.4.0-0ubuntu1_i386.deb 3.4.0 i386 Ubuntu Main
python3-tk_3.4.0-0ubuntu1_amd64.deb 3.4.0 amd64 Ubuntu Main
python3-tk - - -

Requires

Name Value
blt >= 2.4z-7
libc6 >= 2.3.6-6~
libtcl8.6 >= 8.6.0
libtk8.6 >= 8.6.0
python3 << 3.5
python3 >= 3.4

Provides

Name Value
python3.4-tk -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python3-tk_3.4.3-1~14.04.2_i386.deb
Source Package python3-stdlib-extensions

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python3-tk deb package:
    # sudo apt-get install python3-tk

Files

Path
/usr/lib/python3.4/lib-dynload/_tkinter.cpython-34m-i386-linux-gnu.so
/usr/share/doc/python3-tk/README.Debian
/usr/share/doc/python3-tk/README.Tk
/usr/share/doc/python3-tk/changelog.Debian.gz
/usr/share/doc/python3-tk/copyright

Changelog

2015-06-17 - Matthias Klose <doko@ubuntu.com>
python3-stdlib-extensions (3.4.3-1~14.04.2) trusty-proposed; urgency=medium
* SRU, update python3.4 for trusty. LP: #1348954.
2015-02-26 - Matthias Klose <doko@debian.org>
python3-stdlib-extensions (3.4.3-1) unstable; urgency=medium
* Bump version to 3.4.3.
2014-10-08 - Matthias Klose <doko@debian.org>
python3-stdlib-extensions (3.4.2-1) unstable; urgency=medium
* Bump version to 3.4.2 release.
2014-10-01 - Matthias Klose <doko@debian.org>
python3-stdlib-extensions (3.4.2~rc1-1) unstable; urgency=medium
* Bump version to 3.4.2 release candidate 1.
2014-07-08 - Matthias Klose <doko@debian.org>
python3-stdlib-extensions (3.4.1-3) unstable; urgency=medium
* Build for blt 2.5. Closes: #753929.
2014-06-13 - Matthias Klose <doko@debian.org>
python3-stdlib-extensions (3.4.1-2) unstable; urgency=medium
* Require BLT version built for Tcl/Tk 8.6.
2014-06-04 - Matthias Klose <doko@debian.org>
python3-stdlib-extensions (3.4.1-1) unstable; urgency=medium
* Bump version to 3.4.1.
* Remove python 3.3 sources.
2014-02-12 - Matthias Klose <doko@debian.org>
python3-stdlib-extensions (3.3.4-1) unstable; urgency=medium
* Bump version to 3.3.4.
* Handle multiarch extension names. Closes: #735805.
2013-12-25 - Matthias Klose <doko@debian.org>
python3-stdlib-extensions (3.3.3-2) unstable; urgency=medium
* Build for python3.4.
2013-11-27 - Matthias Klose <doko@debian.org>
python3-stdlib-extensions (3.3.3-1) unstable; urgency=low
* Bump version to 3.3.3.
* Make the packages Multi-Arch: same. Replace the dependency on
python3 with libpython3-stdlib.
* Allow the package to cross-build.

See Also

Package Description
python3-tz_2012c-1ubuntu0.1_all.deb Python3 version of the Olson timezone database
python3-uno_4.2.8-0ubuntu5.5_i386.deb Python-UNO bridge
python3-update-manager_0.196.25_all.deb python 3.x module for update-manager
python3-urllib3_1.7.1-1ubuntu4.1_all.deb HTTP library with thread-safe connection pooling for Python3
python3-werkzeug_0.9.4+dfsg-1.1ubuntu2.1_all.deb collection of utilities for WSGI applications
python3-wheel_0.24.0-1~ubuntu1.1_all.deb built-package format for Python
python3-yaml_3.10-4ubuntu0.1_i386.deb YAML parser and emitter for Python3
python3.4-dev_3.4.3-1ubuntu1~14.04.7_i386.deb Header files and a static library for Python (v3.4)
python3.4-doc_3.4.3-1ubuntu1~14.04.7_all.deb Documentation for the high-level object-oriented language Python (v3.4)
python3.4-examples_3.4.3-1ubuntu1~14.04.7_all.deb Examples for the Python language (v3.4)
python3.4-minimal_3.4.3-1ubuntu1~14.04.7_i386.deb Minimal subset of the Python language (version 3.4)
python3.4-venv_3.4.3-1ubuntu1~14.04.7_i386.deb Interactive high-level object-oriented language (pyvenv binary, version 3.4)
python3.4_3.4.3-1ubuntu1~14.04.7_i386.deb Interactive high-level object-oriented language (version 3.4)
qdbus_4.8.5+git192-g085f851+dfsg-2ubuntu4.1_i386.deb Qt 4 D-Bus tool
qemu-common_2.0.0+dfsg-2ubuntu1.46_all.deb dummy transitional package from qemu-common to qemu-keymaps
Advertisement
Advertisement