python-aptdaemon.gtk3widgets_1.1.1-1ubuntu5.2_all.deb


Advertisement

Description

python-aptdaemon.gtk3widgets - Python 2 GTK+ 3 widgets to run an aptdaemon client

Property Value
Distribution Ubuntu 14.04 LTS (Trusty Tahr)
Repository Ubuntu Updates Main i386
Package filename python-aptdaemon.gtk3widgets_1.1.1-1ubuntu5.2_all.deb
Package name python-aptdaemon.gtk3widgets
Package version 1.1.1
Package release 1ubuntu5.2
Package architecture all
Package type deb
Category python
Homepage https://launchpad.net/aptdaemon
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 13.39 KB
Installed size 113.00 KB
Aptdaemon is a transaction based package management daemon. It allows
normal users to perform package management tasks, e.g. refreshing the
cache, upgrading the system, installing or removing software packages.
This package provides the Python 2 GTK+ 3 widgets to implement a fully
working graphical client. The widgets can be used to initiate, to
monitor and to control a transaction. The API is not stable yet.

Alternatives

Package Version Architecture Repository
python-aptdaemon.gtk3widgets_1.1.1-1ubuntu5.2_all.deb 1.1.1 all Ubuntu Updates Main
python-aptdaemon.gtk3widgets_1.1.1-1ubuntu5_all.deb 1.1.1 all Ubuntu Main
python-aptdaemon.gtk3widgets_1.1.1-1ubuntu5_all.deb 1.1.1 all Ubuntu Main
python-aptdaemon.gtk3widgets - - -

Requires

Name Value
aptdaemon-data -
gir1.2-gtk-3.0 -
gir1.2-vte-2.90 -
python-aptdaemon = 1.1.1-1ubuntu5.2
python-gi -

Conflicts

Name Value
python-aptdaemon-gtk << 0.41+bzr582-0ubuntu1

Replaces

Name Value
python-aptdaemon-gtk << 0.41+bzr582-0ubuntu1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-aptdaemon.gtk3widgets_1.1.1-1ubuntu5.2_all.deb
Source Package aptdaemon

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-aptdaemon.gtk3widgets deb package:
    # sudo apt-get install python-aptdaemon.gtk3widgets

Files

Path
/usr/lib/python2.7/dist-packages/aptdaemon/gtk3widgets.py
/usr/share/doc/python-aptdaemon.gtk3widgets/changelog.Debian.gz
/usr/share/doc/python-aptdaemon.gtk3widgets/copyright
/usr/share/doc/python-aptdaemon.gtk3widgets/examples/gtk3-demo.py.gz

Changelog

2015-05-29 - Michael Vogt <michael.vogt@ubuntu.com>
aptdaemon (1.1.1-1ubuntu5.2) trusty-security; urgency=low
* SECURITY UPDATE: information disclosure via simulate dbus method
(LP: #1449587)
- debian/patches/lp1449587.diff: drop privileges when running lintian,
update tests.
- CVE-2015-1323
2014-06-06 - Michael Vogt <michael.vogt@ubuntu.com>
aptdaemon (1.1.1-1ubuntu5.1) trusty-proposed; urgency=low
[ Brian Murray ]
* debian/patches/upstream-include-pkg-version.patch:
- include the package version in the crashfile (LP: #1324833)
2014-04-11 - Michael Vogt <michael.vogt@ubuntu.com>
aptdaemon (1.1.1-1ubuntu5) trusty; urgency=low
* debian/python3-aptdaemon.test.install:
- install all test deb files
* debian/patches/dbus_timeout.patch:
- fix pep8 issue
* debian/patches/fix-configparser.patch:
- do not crash when "#" are in comments
* debian/patches/py3_inheritable.patch:
- set status-fds inheritable to fix InstallFiles()
* debian/tests/control:
- add missing fakeroot dependency
- add missing lintian dependency
2014-04-10 - Michael Vogt <michael.vogt@ubuntu.com>
aptdaemon (1.1.1-1ubuntu4) trusty; urgency=low
* debian/patches/dbus_timeout.patch
- increase dbus timeouts to avoid a dbus timeout error if a
policykit authentication dialog is not answered for a while
* debian/patches/lp1266844.patch:
- workaround for LP: #1266844, thanks to Brian Murray
2014-02-20 - Matthias Klose <doko@ubuntu.com>
aptdaemon (1.1.1-1ubuntu3) trusty; urgency=medium
* Rewrite the python shebang path to /usr/bin/python3.
2013-12-05 - Michael Vogt <michael.vogt@ubuntu.com>
aptdaemon (1.1.1-1ubuntu2) trusty; urgency=low
* Backport fix for LP: #1024590 from trunk r963
2013-10-24 - Martin Pitt <martin.pitt@ubuntu.com>
aptdaemon (1.1.1-1ubuntu1) trusty; urgency=low
* Merge with Debian unstable. Remaining Ubuntu changes:
- Build-depend on dh-translations and use it in debian/rules.
- Add upstream_lintian_2.5.18.patch: Recently updated lintian 2.5.18
dropped $LINTIAN_ROOT, adjust tests accordingly (cherrypicked from
upstream trunk). Fixes autopkgtest.
- fix_ftbs.patch: Fix FTBFS (LP: #1226100) with latest pep8 version.
* Move Vcs-Bzr to trusty branch.
2013-08-15 - Julian Andres Klode <jak@debian.org>
aptdaemon (1.1.1-1) unstable; urgency=low
[ Sebastian Heinlein ]
* New upstream release:
- Updated and improved PackageKit 0.8 D-Bus interface support
- Configuration file conflicts now default to replace
- Colored console output
- Minor bug fixes
*debian/control:
- Require the latest PackageKit-Glib version
- Add breaks for the obsoleted PackageKit client libraries of the 0.7.x
series
* debian/patches:
- apt-dbus-text-api.patch: merged upstream
- debconf-flush.patch: merged upstream
- fix-gobject-io-add-watch.patch: merged upstream
- fix-lp898851.patch: merged upstream
- lp1058038.patch: merged upstream
- upstream-dropped-lintian-check.patch: merged upstream
- upstream-pep8-fixes.patch: merged upstream
- fix-high-trust-pkcompat.diff: updated
[ Julian Andres Klode ]
* Re-enable test suite again
2013-07-14 - Julian Andres Klode <jak@debian.org>
aptdaemon (1.0-1) unstable; urgency=low
* Merge with Ubuntu saucy.
- Fixes incorrect GObjectMeta usage (Closes: #707768)
* Build-Depend on xauth (xvfb tests don't seem to work otherwise)
* Disable tests for now, the test infrastructure seems broken; but
upstream does not react to the bug report, and I don't want to
wait any longer because #707768 really needs to be closed.
2013-06-06 - Martin Pitt <martin.pitt@ubuntu.com>
aptdaemon (1.0-0ubuntu10) saucy; urgency=low
* Update Vcs-* to saucy branch.
* Add upstream-dropped-lintian-check.patch: Drop
missing-pre-dependency-on-multiarch-support, it was dropped from saucy
lintian.

See Also

Package Description
python-aptdaemon_1.1.1-1ubuntu5.2_all.deb Python 2 module for the server and client of aptdaemon
python-avahi_0.6.31-4ubuntu1.3_i386.deb Python utility package for Avahi
python-babel-doc_1.3+dfsg.1-2ubuntu2_all.deb tools for internationalizing Python applications - documentation
python-babel-localedata_1.3+dfsg.1-2ubuntu2_all.deb tools for internationalizing Python applications - locale data files
python-babel_1.3+dfsg.1-2ubuntu2_all.deb tools for internationalizing Python applications - Python 2.x
python-bzrlib.tests_2.6.0+bzr6593-1ubuntu1.6_all.deb distributed version control system - testsuite
python-bzrlib_2.6.0+bzr6593-1ubuntu1.6_i386.deb distributed version control system - python library
python-ceilometer_2014.1.5-0ubuntu2_all.deb ceilometer python libraries
python-ceph_0.80.11-0ubuntu1.14.04.4_i386.deb Python libraries for the Ceph distributed filesystem
python-cinder_2014.1.5-0ubuntu2.2_all.deb Cinder Python libraries
python-cinderclient_1.0.8-0ubuntu2_all.deb python bindings to the OpenStack Volume API
python-crypto-doc_2.6.1-4ubuntu0.3_all.deb cryptographic algorithms and protocols for Python (documentation)
python-crypto_2.6.1-4ubuntu0.3_i386.deb cryptographic algorithms and protocols for Python
python-cupshelpers_1.4.3+20140219-0ubuntu2.6_all.deb Python modules for printer configuration with CUPS
python-curtin_0.1.0~bzr399-0ubuntu1~14.04.1_all.deb Library and tools for curtin installer
Advertisement
Advertisement