libnl-route-3-200_3.2.21-1ubuntu4.1_i386.deb


Advertisement

Description

libnl-route-3-200 - library for dealing with netlink sockets - route interface

Property Value
Distribution Ubuntu 14.04 LTS (Trusty Tahr)
Repository Ubuntu Updates Main i386
Package name libnl-route-3-200
Package version 3.2.21
Package release 1ubuntu4.1
Package architecture i386
Package type deb
Installed size 352 B
Download size 94.13 KB
Official Mirror archive.ubuntu.com
This is a library for applications dealing with netlink sockets.
The library provides an interface for raw netlink messaging and various
netlink family specific interfaces.
API to the configuration interfaces of the NETLINK_ROUTE family.

Alternatives

Package Version Architecture Repository
libnl-route-3-200_3.2.21-1ubuntu4.1_amd64.deb 3.2.21 amd64 Ubuntu Updates Main
libnl-route-3-200_3.2.21-1_i386.deb 3.2.21 i386 Ubuntu Main
libnl-route-3-200_3.2.21-1_amd64.deb 3.2.21 amd64 Ubuntu Main
libnl-route-3-200 - - -

Requires

Name Value
libc6 >= 2.8
libnl-3-200 = 3.2.21-1ubuntu4.1
multiarch-support -

Download

Type URL
Binary Package libnl-route-3-200_3.2.21-1ubuntu4.1_i386.deb
Source Package libnl3

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libnl-route-3-200 deb package:
    # sudo apt-get install libnl-route-3-200

Files

Path
/usr/lib/i386-linux-gnu/libnl-route-3.so.200
/usr/lib/i386-linux-gnu/libnl-route-3.so.200.16.1
/usr/share/doc/libnl-route-3-200/changelog.Debian.gz
/usr/share/doc/libnl-route-3-200/copyright

Changelog

2017-06-02 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
libnl3 (3.2.21-1ubuntu4.1) trusty-security; urgency=medium
* SECURITY UPDATE: integer-overflow in nlmsg_reserve()
- debian/patches/CVE-2017-0553.patch: check len in lib/msg.c.
- CVE-2017-0553
2016-10-24 - Louis Bouchard <louis.bouchard@ubuntu.com>
libnl3 (3.2.21-1ubuntu4) trusty; urgency=high
[ Jorge Niedbalski ]
* d/p/lib-nl-Increase-receive-buffer-size-to-4-pages.patch: Increase 
receive buffer size to 4 pages by default. (LP: #1567578).
2016-05-13 - Adam Conrad <adconrad@ubuntu.com>
libnl3 (3.2.21-1ubuntu3) trusty; urgency=medium
* Add a versioned Breaks on network-manager (<< 0.9.8.8-0ubuntu7.3~)
2016-01-28 - Ryan Harper <ryan.harper@canonical.com>
libnl3 (3.2.21-1ubuntu1) trusty; urgency=low
* Apply backported upstream patches (Closes: LP: #1511735)
- lib-socket-use-proper-typed-constant-UINT32_MAX.patch
- lib-socket-don-t-fail-if-no-more-local-ports-can-be.patch
- lib-socket-retry-generate-local-port-in-nl_connect.patch
- lib-socket-randomize-the-generated-local-port.patch
- lib-nl-preserve-s_local-if-nl_connect-fails.patch
- socket-clear-port-when-unable-to-generate-local-port.patch
- socket-add-fallback-for-nl_connect-by-trying-to-bind.patch
- socket-fix-assertion-in-nl_connect-when-all-ports-ar.patch
* Updated symbol file libnl-3-200.symbols
2013-05-21 - Heiko Stuebner <mmind@debian.org>
libnl3 (3.2.21-1) unstable; urgency=low
* New upstream release (Closes: #707081)
Including CAN support (Closes: #698954)
* Add symbols files (Closes: #654758)
* Provide static libraries (Closes: #693939, #693940)
* Update standards to 3.9.4
* Removed doc package. Libnl3 documentation is released
separately now.
2012-06-30 - Heiko Stuebner <mmind@debian.org>
libnl3 (3.2.7-4) unstable; urgency=low
* Add watch file (Closes: #679473)
* Use dh-autoreconf to update the build system (Closes: 679474)
2012-06-18 - Heiko Stuebner <mmind@debian.org>
libnl3 (3.2.7-3) unstable; urgency=low
* Fix FTBFS due to failing gen-tags.sh (Closes: #674322)
* Convert to Multi-Arch (Closes: #676611)
* Update standards to 3.9.3 - no changes
* Switch to dpkg-source format 3.0 (quilt)
2012-03-05 - Heiko Stuebner <mmind@debian.org>
libnl3 (3.2.7-2) unstable; urgency=low
* Force doxygen dot-threads to 1 to circumvent segfaults on armel
* Add missing build-dependency on ghostscript
2012-02-13 - Heiko Stuebner <mmind@debian.org>
libnl3 (3.2.7-1) unstable; urgency=low
* New upstream release
* Build-depend on source-highlight (Closes: #657254)
2011-12-19 - Heiko Stuebner <mmind@debian.org>
libnl3 (3.2.3-2) unstable; urgency=low
* Upload to unstable
* Split split udeb to be in line with regular packages
* Move libnl and libnl-genl to /lib for iw and wpa_supplicant.

See Also

Package Description
libnl-route-3-dev_3.2.21-1ubuntu4.1_i386.deb development library and headers for libnl-route-3
libnm-glib-dev_0.9.8.8-0ubuntu7.3_i386.deb network management framework (GLib interface)
libnm-glib-vpn-dev_0.9.8.8-0ubuntu7.3_i386.deb network management framework (GLib interface)
libnm-glib-vpn1_0.9.8.8-0ubuntu7.3_i386.deb network management framework (GLib VPN shared library)
libnm-glib4_0.9.8.8-0ubuntu7.3_i386.deb network management framework (GLib shared library)
libnm-gtk-common_0.9.8.8-0ubuntu4.5_all.deb network management framework (common files for wifi and mobile)
libnm-gtk-dev_0.9.8.8-0ubuntu4.5_i386.deb network management framework (dialogs development libraries)
libnm-gtk0_0.9.8.8-0ubuntu4.5_i386.deb network management framework (GNOME dialogs for wifi and mobile)
libnm-util-dev_0.9.8.8-0ubuntu7.3_i386.deb network management framework (development files)
libnm-util2_0.9.8.8-0ubuntu7.3_i386.deb network management framework (shared library)
libnspr4-dev_4.13.1-0ubuntu0.14.04.1_i386.deb Development files for the NetScape Portable Runtime library
libnspr4_4.13.1-0ubuntu0.14.04.1_i386.deb NetScape Portable Runtime Library
libnss-ldap_264-2.2ubuntu4.14.04.2_i386.deb NSS module for using LDAP as a naming service
libnss-sss_1.11.8-0ubuntu0.7_i386.deb Nss library for the System Security Services Daemon
libnss3-1d_3.28.4-0ubuntu0.14.04.3_i386.deb Network Security Service libraries - transitional package
Advertisement
Advertisement