libmono-corlib2.0-cil_3.2.8+dfsg-4ubuntu1.1_all.deb


Advertisement

Description

libmono-corlib2.0-cil - Mono core library (for CLI 2.0)

Property Value
Distribution Ubuntu 14.04 LTS (Trusty Tahr)
Repository Ubuntu Updates Main i386
Package filename libmono-corlib2.0-cil_3.2.8+dfsg-4ubuntu1.1_all.deb
Package name libmono-corlib2.0-cil
Package version 3.2.8+dfsg
Package release 4ubuntu1.1
Package architecture all
Package type deb
Category libs
Homepage http://www.mono-project.com/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 712.07 KB
Installed size 2.59 MB
Mono is a platform for running and developing applications based on the
ECMA/ISO Standards. Mono is an open source effort led by Xamarin.
Mono provides a complete CLR (Common Language Runtime) including compiler and
runtime, which can produce and execute CIL (Common Intermediate Language)
bytecode (aka assemblies), and a class library.
This package contains the Core Library (mscorlib.dll) of Mono for CLI 2.0,
which is the glue between the BCL (Base Class Libraries) and the JIT.
You should install libmono-i18n-west2.0-cil if you are using
ISO 8859-15 (Latin 9) or other common Western European code pages.
US-ASCII, ISO 8859-1 (Latin 1) and UTF-8 users don't need any extra I18N
packages.

Alternatives

Package Version Architecture Repository
libmono-corlib2.0-cil_3.2.8+dfsg-4ubuntu1.1_all.deb 3.2.8+dfsg all Ubuntu Updates Main
libmono-corlib2.0-cil_3.2.8+dfsg-4ubuntu1_all.deb 3.2.8+dfsg all Ubuntu Main
libmono-corlib2.0-cil_3.2.8+dfsg-4ubuntu1_all.deb 3.2.8+dfsg all Ubuntu Main
libmono-corlib2.0-cil - - -

Requires

Name Value
mono-runtime << 3.2.9
mono-runtime >= 3.2.8

Conflicts

Name Value
mono-classlib-2.0 << 1.1.13.6
mono-classlib-2.0-dbg << 1.1.13.6

Replaces

Name Value
mono-classlib-2.0 << 1.1.13.6
mono-classlib-2.0-dbg << 1.1.13.6

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libmono-corlib2.0-cil_3.2.8+dfsg-4ubuntu1.1_all.deb
Source Package mono

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmono-corlib2.0-cil deb package:
    # sudo apt-get install libmono-corlib2.0-cil

Files

Path
/usr/lib/mono/2.0/mscorlib.dll
/usr/share/doc/libmono-corlib2.0-cil/changelog.Debian.gz
/usr/share/doc/libmono-corlib2.0-cil/copyright

Changelog

2015-03-20 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
mono (3.2.8+dfsg-4ubuntu1.1) trusty-security; urgency=medium
* SECURITY UPDATE: TLS impersonation attack
- debian/patches/CVE-2015-2318.patch: add handshake state validation to
mcs/class/Mono.Security/Mono.Security.Protocol.Tls/ClientRecordProtocol.cs,
mcs/class/Mono.Security/Mono.Security.Protocol.Tls/Context.cs,
mcs/class/Mono.Security/Mono.Security.Protocol.Tls/RecordProtocol.cs,
mcs/class/Mono.Security/Mono.Security.Protocol.Tls/ServerRecordProtocol.cs.
- CVE-2015-2318
* SECURITY UPDATE: FREAK attack vulnerability
- debian/patches/CVE-2015-2319.patch: remove EXPORT ciphers from
mcs/class/Mono.Security/Mono.Security.Protocol.Tls/CipherSuiteFactory.cs,
mcs/class/Mono.Security/Mono.Security.Protocol.Tls/ClientRecordProtocol.cs,
mcs/class/Mono.Security/Mono.Security.Protocol.Tls/SslCipherSuite.cs,
mcs/class/Mono.Security/Mono.Security.Protocol.Tls/SslServerStream.cs,
mcs/class/Mono.Security/Mono.Security.Protocol.Tls/TlsCipherSuite.cs.
- CVE-2015-2319
* SECURITY UPDATE: SSLv2 support
- debian/patches/CVE-2015-2320.patch: remove client-side SSLv2 fallback in
mcs/class/Mono.Security/Mono.Security.Protocol.Tls/RecordProtocol.cs.
- CVE-2015-2320
* debian/source/options: Don't use single-debian-patch for Ubuntu.
2014-02-28 - Jo Shields <directhex@apebox.org>
mono (3.2.8+dfsg-4ubuntu1) trusty; urgency=low
* Include mystery patchset from Matthias Klose <doko@ubuntu.com> which
adds support for little-endian PPC64.
2014-02-27 - Jo Shields <directhex@apebox.org>
mono (3.2.8+dfsg-4) experimental; urgency=low
* [3930eef] Add missing libmono-winforms2.0-cil dependency to 
libmono-cil-dev.
2014-02-26 - Jo Shields <directhex@apebox.org>
mono (3.2.8+dfsg-3) experimental; urgency=low
* [6a91386] -z and -n do the same thing, right? Fixes autopkgtest for real.
2014-02-25 - Jo Shields <directhex@apebox.org>
mono (3.2.8+dfsg-2) experimental; urgency=low
* [2192ca9] Only trigger mono-gac postinst on upgrades. This should fix 
an edge case when GAC-installing libraries which rely on 
machine.config's key remapping at the same time as mono-gac 
first-install, such as F#. Thanks to Christopher James Halse Rogers.
2014-02-20 - Jo Shields <directhex@apebox.org>
mono (3.2.8+dfsg-1) experimental; urgency=low
* The "Debian 9.0 Zurg" release
* [9972bf8] Imported Upstream version 3.2.8+dfsg
* [c9f9468] README is gone, ship README.md instead since it might be useful
* [029af3f] Refresh symbols files for libmono*
* [e2acadb] Don't use killall to kill stray Mono processes, it doesn't work 
as desired. (Closes: #738277)
* [0b1a48e] Delete some corner-case build rules for working around arch 
issues
* [26e5fbc] Bump System.Reactive to 2.2
* [660166e] Fix up XBuild paths
* [ea9afdc] Add new Facades to mono-devel
* [8305898] Add new XBuild 12.0 files to mono-xbuild package
* [4575803] Add new Mono.XBuild.Tasks library
* [66a2288] Refreshed clilibs versioning and renamed packages as required 
by ABI changes
2014-01-17 - Mirco Bauer <meebey@debian.org>
mono (3.2.3+dfsg-7) experimental; urgency=medium
[ Mirco Bauer ]
* [fd41e43] Added a hard timeout of 1 hour per test pass to prevent blocking
buildds forever
* [68cd63d] Hard kill stray mono processes after each test pass to make the
life of buildd admins nicer
* [2b00059] Added psmisc to build-deps for the killall command
[ Christopher James Halse Rogers ]
* [c6ee8c7] Make the install-framework commmand idempotent

See Also

Package Description
libmono-corlib4.0-cil_3.2.8+dfsg-4ubuntu1.1_all.deb Mono core library (for CLI 4.0)
libmono-corlib4.5-cil_3.2.8+dfsg-4ubuntu1.1_all.deb Mono core library (for CLI 4.5)
libmono-cscompmgd8.0-cil_3.2.8+dfsg-4ubuntu1.1_all.deb Mono cscompmgd library (for CLI 2.0)
libmono-csharp4.0c-cil_3.2.8+dfsg-4ubuntu1.1_all.deb Mono.CSharp library (for CLI 4.0)
libmono-custommarshalers4.0-cil_3.2.8+dfsg-4ubuntu1.1_all.deb Mono CustomMarshalers library (for CLI 4.0)
libmono-data-tds2.0-cil_3.2.8+dfsg-4ubuntu1.1_all.deb Mono Data Library (for CLI 2.0)
libmono-data-tds4.0-cil_3.2.8+dfsg-4ubuntu1.1_all.deb Mono Data Library (for CLI 4.0)
libmono-db2-1.0-cil_3.2.8+dfsg-4ubuntu1.1_all.deb Mono DB2 library
libmono-debugger-soft2.0a-cil_3.2.8+dfsg-4ubuntu1.1_all.deb Mono Soft Debugger library (for CLI 2.0)
libmono-debugger-soft4.0a-cil_3.2.8+dfsg-4ubuntu1.1_all.deb Mono Soft Debugger library (for CLI 4.0)
libmono-entityframework-sqlserver6.0-cil_3.2.8+dfsg-4ubuntu1.1_all.deb EntityFramework.SqlServer library (for CLI 4.0)
libmono-entityframework6.0-cil_3.2.8+dfsg-4ubuntu1.1_all.deb EntityFramework library (for CLI 4.0)
libmono-http4.0-cil_3.2.8+dfsg-4ubuntu1.1_all.deb Mono.Http library (for CLI 4.0)
libmono-i18n-cjk4.0-cil_3.2.8+dfsg-4ubuntu1.1_all.deb Mono I18N.CJK library (for CLI 4.0)
libmono-i18n-mideast4.0-cil_3.2.8+dfsg-4ubuntu1.1_all.deb Mono I18N.MidEast library (for CLI 4.0)
Advertisement
Advertisement