libgd3_2.1.0-3ubuntu0.11_i386.deb


Advertisement

Description

libgd3 - GD Graphics Library

Property Value
Distribution Ubuntu 14.04 LTS (Trusty Tahr)
Repository Ubuntu Updates Main i386
Package filename libgd3_2.1.0-3ubuntu0.11_i386.deb
Package name libgd3
Package version 2.1.0
Package release 3ubuntu0.11
Package architecture i386
Package type deb
Category libs
Homepage http://www.libgd.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 116.22 KB
Installed size 464.00 KB
GD is a graphics library. It allows your code to quickly draw images
complete with lines, arcs, text, multiple colours, cut and paste from
other images, flood fills, and write out the result as a PNG file.
This is particularly useful in World Wide Web applications, where PNG is
one of the formats accepted for inline images by most browsers.
This is the runtime package of the library.

Alternatives

Package Version Architecture Repository
libgd3_2.1.0-3ubuntu0.11_amd64.deb 2.1.0 amd64 Ubuntu Updates Main
libgd3_2.1.0-3_i386.deb 2.1.0 i386 Ubuntu Main
libgd3_2.1.0-3_amd64.deb 2.1.0 amd64 Ubuntu Main
libgd3 - - -

Requires

Name Value
libc6 >= 2.11
libfontconfig1 >= 2.9.0
libfreetype6 >= 2.2.1
libjpeg8 >= 8c
libpng12-0 >= 1.2.13-4
libtiff5 >= 4.0.3
libvpx1 >= 1.0.0
libxpm4 -
multiarch-support -
zlib1g >= 1:1.1.4

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libgd3_2.1.0-3ubuntu0.11_i386.deb
Source Package libgd2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgd3 deb package:
    # sudo apt-get install libgd3

Files

Path
/usr/lib/i386-linux-gnu/libgd.so.3
/usr/lib/i386-linux-gnu/libgd.so.3.0.0
/usr/share/doc/libgd3/changelog.Debian.gz
/usr/share/doc/libgd3/copyright
/usr/share/lintian/overrides/libgd3

Changelog

2019-02-27 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
libgd2 (2.1.0-3ubuntu0.11) trusty-security; urgency=medium
* SECURITY UPDATE: buffer overflow in gdImageColorMatch
- debian/patches/CVE-2019-6977.patch: use gdMaxColors in
src/gd_color_match.c.
- CVE-2019-6977
* SECURITY UPDATE: double-free in gdImage*Ptr() functions
- debian/patches/CVE-2019-6978.patch: properly handle failure in
src/gd_gif_out.c, src/gd_jpeg.c, src/gd_wbmp.c, add test to
tests/jpeg/CMakeLists.txt, tests/jpeg/jpeg_ptr_double_free.c.
- CVE-2019-6978
2018-08-23 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
libgd2 (2.1.0-3ubuntu0.10) trusty-security; urgency=medium
* SECURITY UPDATE: Double free
- debian/patches/CVE-2018-1000222.patch: fix in
src/gd_bmp.c.
- CVE-2018-1000222
* SECURITY UPDATE: Infinite loop
- debian/patches/CVE-2018-5711.patch: fix in
src/gd_gif_in.c.
- CVE-2018-5711
2017-09-04 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
libgd2 (2.1.0-3ubuntu0.8) trusty-security; urgency=medium
* SECURITY UPDATE: Double-free memory
- debian/patches/CVE-2017-6362.patch: introduces a static
helper to check failure or success in src/gd_png.c also
adds tests in tests/png/CMakeLists.txt, tests/Makemodule.am,
tests/png/bug00381_1.c, tests/png/bug00381_2.c.
- CVE-2017-6362
2017-08-10 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
libgd2 (2.1.0-3ubuntu0.7) trusty-security; urgency=medium
* SECURITY UPDATE: memory read vulnerability in GIF
- debian/patches/CVE-2017-7890.patch: zeroing buffers to avoid
information leak and adding test in src/gd_gif_in.c,
tests/gif/CMakeLists.txt, tests/MakeModule.am,
tests/gif/uninitialized_memory_read.c,
tests/gif/unitialized_memory_read.gif.
- CVE-2017-7890
2017-02-28 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
libgd2 (2.1.0-3ubuntu0.6) trusty-security; urgency=medium
* SECURITY UPDATE: potential unsigned underflow
- debian/patches/CVE-2016-10166.patch: refactor loop in
src/gd_interpolation.c.
- CVE-2016-10166
* SECURITY UPDATE: DoS vulnerability in gdImageCreateFromGd2Ctx()
- debian/patches/CVE-2016-10167.patch: properly fail in src/gd_gd2.c.
- CVE-2016-10167
* SECURITY UPDATE: signed integer overflow in gd_io.c
- debian/patches/CVE-2016-10168.patch: check counts in src/gd_gd2.c.
- CVE-2016-10168
* SECURITY UPDATE: OOB reads of the TGA decompression buffer
- debian/patches/CVE-2016-6906-pre1.patch: fix coverty warning in
src/gd_tga.c.
- debian/patches/CVE-2016-6906-pre2.patch: fix TGA RLE decoding in
src/gd_tga.c.
- debian/patches/CVE-2016-6906-1.patch: check for overflow in
src/gd_tga.c.
- debian/patches/CVE-2016-6906-2.patch: add another overflow check in
src/gd_tga.c.
- CVE-2016-6906
* SECURITY UPDATE: double-free in gdImageWebPtr()
- debian/patches/CVE-2016-6912.patch: add helper function to indicate
failure in src/gd_webp.c.
- CVE-2016-6912
* SECURITY UPDATE: DoS via oversized image
- debian/patches/CVE-2016-9317.patch: check for oversized images in
src/gd.c.
- CVE-2016-9317
* SECURITY UPDATE: DoS via stack consumption
- debian/patches/CVE-2016-9933.patch: check for invalid colors in
src/gd.c.
- CVE-2016-9933

See Also

Package Description
libgdk-pixbuf2.0-0_2.30.7-0ubuntu1.8_i386.deb GDK Pixbuf library
libgdk-pixbuf2.0-common_2.30.7-0ubuntu1.8_all.deb GDK Pixbuf library - data files
libgdk-pixbuf2.0-dev_2.30.7-0ubuntu1.8_i386.deb GDK Pixbuf library (development files)
libgdk-pixbuf2.0-doc_2.30.7-0ubuntu1.8_all.deb GDK Pixbuf library (documentation)
libgdraw4_20120731.b-5ubuntu0.1_i386.deb font editor - runtime graphics and widget library
libgettextpo-dev_0.18.3.1-1ubuntu3.1_i386.deb GNU Internationalization library development files
libgettextpo0_0.18.3.1-1ubuntu3.1_i386.deb GNU Internationalization library
libgexiv2-2_0.10.0-1ubuntu2_i386.deb GObject-based wrapper around the Exiv2 library
libgexiv2-dev_0.10.0-1ubuntu2_i386.deb GObject-based wrapper around the Exiv2 library - development files
libgfortran-4.8-dev_4.8.4-2ubuntu1~14.04.4_i386.deb Runtime library for GNU Fortran applications (development files)
libgfortran3_4.8.4-2ubuntu1~14.04.4_i386.deb Runtime library for GNU Fortran applications
libgimp2.0-dev_2.8.10-0ubuntu1.2_i386.deb Headers and other files for compiling plugins for GIMP
libgimp2.0-doc_2.8.10-0ubuntu1.2_all.deb Developers' Documentation for the GIMP library
libgimp2.0_2.8.10-0ubuntu1.2_i386.deb Libraries for the GNU Image Manipulation Program
libgirepository-1.0-1_1.40.0-1ubuntu0.2_i386.deb Library for handling GObject introspection data (runtime library)
Advertisement
Advertisement