emacs24-nox_24.3+1-2ubuntu1.1_i386.deb


Advertisement

Description

emacs24-nox - GNU Emacs editor (without X support)

Property Value
Distribution Ubuntu 14.04 LTS (Trusty Tahr)
Repository Ubuntu Updates Main i386
Package filename emacs24-nox_24.3+1-2ubuntu1.1_i386.deb
Package name emacs24-nox
Package version 24.3+1
Package release 2ubuntu1.1
Package architecture i386
Package type deb
Category editors
Homepage http://www.gnu.org/software/emacs/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 2.39 MB
Installed size 9.86 MB
GNU Emacs is the extensible self-documenting text editor.
This package contains a version of Emacs compiled without support for X.

Alternatives

Package Version Architecture Repository
emacs24-nox_24.3+1-2ubuntu1.1_amd64.deb 24.3+1 amd64 Ubuntu Updates Main
emacs24-nox_24.3+1-2ubuntu1_amd64.deb 24.3+1 amd64 Ubuntu Main
emacs24-nox_24.3+1-2ubuntu1_i386.deb 24.3+1 i386 Ubuntu Main
emacs24-nox - - -

Requires

Name Value
emacs24-bin-common = 24.3+1-2ubuntu1.1
libasound2 >= 1.0.16
libc6 >= 2.15
libdbus-1-3 >= 1.5.12
libgnutls26 >= 2.12.17-0
libgpm2 >= 1.20.4
libselinux1 >= 1.32
libtinfo5 -
libxml2 >= 2.7.4

Provides

Name Value
editor -
emacs24 -
emacsen -
info-browser -
mail-reader -
news-reader -

Conflicts

Name Value
emacs24 -
emacs24-lucid -

Replaces

Name Value
emacs24 -
emacs24-lucid -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package emacs24-nox_24.3+1-2ubuntu1.1_i386.deb
Source Package emacs24

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install emacs24-nox deb package:
    # sudo apt-get install emacs24-nox

Files

Path
/usr/bin/emacs24
/usr/bin/emacs24-nox
/usr/share/doc/emacs24-nox/README.Debian
/usr/share/doc/emacs24-nox/changelog.Debian.gz
/usr/share/doc/emacs24-nox/copyright
/usr/share/emacs/24.3/etc/DOC-24.3.1
/usr/share/lintian/overrides/emacs24-nox
/usr/share/man/man1/emacs24-nox.1.gz
/usr/share/man/man1/emacs24.1.gz
/usr/share/menu/emacs24-nox

Changelog

2017-09-19 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
emacs24 (24.3+1-2ubuntu1.1) trusty-security; urgency=medium
* SECURITY UPDATE: arbitrary code execution
- debian/patches/CVE-2017-14482.patch: Remove unsafe enriched
mode translations in lisp/gnus/mm-view.el,
lisp/textmodes/enriched.el.
- CVE-2017-14482
2014-03-07 - Barry Warsaw <barry@ubuntu.com>
emacs24 (24.3+1-2ubuntu1) trusty; urgency=medium
* Merge from Debian, with remaining changes:
- debian/patches/0009-upstream-bug-14829.patch: Patch from upstream
issue tracker to fix window splitting when split-window-keep-point
is nil.
- debian/patches/0008-No-redisplay-when-reading-dbus-events.patch:
Cherry pick from upstream bzr a fix for a redisplay bug while
reading dbus events.
- debian/rules: Make sure the emacs24-el directory exists.
- emacsVER-lp725988.patch: Set the X EMACS_CLASS to "Emacs24" to please
bamf and gnome-shell.
- debian/emacsVER.desktop: Also set StartupWMClass for bamf and
gnome-shell.
- debian/control.in: Have emacs24-common Depends on
emacs24-common-non-dfsg, now that it is out of multiverse.
Update debian/copyright to match. 
- debian/control.in: Use libtiff5-dev in place of libtiff4-dev.
2013-09-26 - Rob Browning <rlb@defaultvalue.org>
emacs24 (24.3+1-2) unstable; urgency=low
* Set CFLAGS, CPPFLAGS, and LDFLAGS solely via configure in debian/rules.
Don't override the CFLAGS, CPPFLAGS, and LDFLAGS values chosen by the
upstream configure script; instead, make any adjustments at configure
time.  Our quashing of "-Wl,-znocombreloc" during the make invocation
was causing i386 builds of emacs24-lucid to fail under X.
Thanks to Ɓukasz Pankowski <lukpank@o2.pl> for the report, and Samuel
Bronson <naesten@gmail.com> for the patch. (Closes: 684788)
* debian/rules: clean src/stamp-h.in.
Thanks to Samuel Bronson <naesten@gmail.com> for the patch.
* Explicitly create $(pkgdir_el) in debian/rules (fix FTBS).
Thanks to Lucas Nussbaum <lucas@lucas-nussbaum.net> for the report,
Matt Kraai <kraai@ftbfs.org> for the patch, and Dmitrijs Ledkovs
<xnox@debian.org> for the 24.3+1-1.1 NMU. (Closes: 707488)
* Specify --without-gsettings for emacsFLAVOR-nox and emacsFLAVOR-lucid.
Thanks to Yuri D'Elia <wavexx@thregr.org> for the report.
(Closes: 687299, 687303)
* Fix hang at startup on kFreeBSD.
Add debian/patches/0008-Emacs-should-no-longer-hang-at-startup-on-kFreeBSD.patch
and debian/patches/0009-Emacs-should-no-longer-hang-at-startup-on-kFreeBSD.patch
to incorporate the two relevant upstream patches.
Thanks to Christoph Egger <christoph@debian.org> for the report.
(Closes: 712974)
2013-07-26 - Barry Warsaw <barry@ubuntu.com>
emacs24 (24.3+1-1ubuntu3) saucy; urgency=low
* debian/patches/0009-upstream-bug-14829.patch: Patch from upstream
issue tracker to fix window splitting when split-window-keep-point
is nil.
2013-06-14 - Barry Warsaw <barry@ubuntu.com>
emacs24 (24.3+1-1ubuntu2) saucy; urgency=low
* debian/patches/0008-No-redisplay-when-reading-dbus-events.patch:
Cherry pick from upstream bzr a fix for a redisplay bug while
reading dbus events.
* debian/rules: Make sure the emacs24-el directory exists.
2013-06-03 - Dmitrijs Ledkovs <dmitrij.ledkov@ubuntu.com>
emacs24 (24.3+1-1ubuntu1) saucy; urgency=low
* Merge from Debian, remaining changes:
- emacsVER-lp725988.patch: Set the X EMACS_CLASS to "Emacs24" to please
bamf and gnome-shell.
- debian/emacsVER.desktop: Also set StartupWMClass for bamf and
gnome-shell.
- Have emacs24-common Depends on emacs24-common-non-dfsg, now that it
is out of multiverse.  Update debian/copyright to match.
- debian/control.in: Use libtiff5-dev in place of libtiff4-dev.

See Also

Package Description
emacs24_24.3+1-2ubuntu1.1_i386.deb GNU Emacs editor (with GTK+ user interface)
empathy-common_3.8.6-0ubuntu9.2_all.deb GNOME multi-protocol chat and call client (common files)
empathy_3.8.6-0ubuntu9.2_i386.deb GNOME multi-protocol chat and call client
eog-dev_3.10.2-0ubuntu5.2_all.deb Development files for the Eye of GNOME
eog_3.10.2-0ubuntu5.2_i386.deb Eye of GNOME graphics viewer program
erlang-asn1_16.b.3-dfsg-1ubuntu2.2_i386.deb Erlang/OTP modules for ASN.1 support
erlang-base_16.b.3-dfsg-1ubuntu2.2_i386.deb Erlang/OTP virtual machine and base applications
erlang-corba_16.b.3-dfsg-1ubuntu2.2_i386.deb Erlang/OTP applications for CORBA support
erlang-crypto_16.b.3-dfsg-1ubuntu2.2_i386.deb Erlang/OTP cryptographic modules
erlang-dev_16.b.3-dfsg-1ubuntu2.2_i386.deb Erlang/OTP development libraries and headers
erlang-diameter_16.b.3-dfsg-1ubuntu2.2_i386.deb Erlang/OTP implementation of RFC 6733 protocol
erlang-doc_16.b.3-dfsg-1ubuntu2.2_all.deb Erlang/OTP HTML/PDF documentation
erlang-edoc_16.b.3-dfsg-1ubuntu2.2_i386.deb Erlang/OTP module for generating documentation
erlang-eldap_16.b.3-dfsg-1ubuntu2.2_i386.deb Erlang/OTP LDAP library
erlang-erl-docgen_16.b.3-dfsg-1ubuntu2.2_i386.deb Erlang/OTP documentation stylesheets
Advertisement
Advertisement