ppp_2.4.5-5.1ubuntu2.2_amd64.deb


Advertisement

Description

ppp - Point-to-Point Protocol (PPP) - daemon

Property Value
Distribution Ubuntu 14.04 LTS (Trusty Tahr)
Repository Ubuntu Updates Main amd64
Package name ppp
Package version 2.4.5
Package release 5.1ubuntu2.2
Package architecture amd64
Package type deb
Installed size 928 B
Download size 303.85 KB
Official Mirror archive.ubuntu.com
The Point-to-Point Protocol provides a standard way to transmit
datagrams over a serial link, as well as a standard way for the machines
at either end of the link to negotiate various optional characteristics
of the link.
This package is most commonly used to manage a modem for dial-up or
certain kinds of broadband connections.

Alternatives

Package Version Architecture Repository
ppp_2.4.5-5.1ubuntu2.2_i386.deb 2.4.5 i386 Ubuntu Updates Main
ppp_2.4.5-5.1ubuntu2_i386.deb 2.4.5 i386 Ubuntu Main
ppp_2.4.5-5.1ubuntu2_amd64.deb 2.4.5 amd64 Ubuntu Main
ppp - - -

Requires

Name Value
libc6 >= 2.15
libpam-modules -
libpam-runtime -
libpam0g >= 0.99.7.1
libpcap0.8 >= 0.9.8
libssl1.0.0 >= 1.0.0
procps -

Download

Type URL
Binary Package ppp_2.4.5-5.1ubuntu2.2_amd64.deb
Source Package ppp

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ppp deb package:
    # sudo apt-get install ppp

Files

Path
/etc/bash_completion.d/pon
/etc/chatscripts/gprs
/etc/chatscripts/pap
/etc/init.d/pppd-dns
/etc/logrotate.d/ppp
/etc/pam.d/ppp
/etc/ppp/ip-down
/etc/ppp/ip-up
/etc/ppp/ipv6-down
/etc/ppp/ipv6-up
/etc/ppp/options
/etc/ppp/pppoe_on_boot
/etc/ppp/ip-down.d/0000usepeerdns
/etc/ppp/ip-up.d/0000usepeerdns
/usr/bin/plog
/usr/bin/poff
/usr/bin/pon
/usr/lib/pppd/2.4.5/minconn.so
/usr/lib/pppd/2.4.5/openl2tp.so
/usr/lib/pppd/2.4.5/passprompt.so
/usr/lib/pppd/2.4.5/passwordfd.so
/usr/lib/pppd/2.4.5/pppoatm.so
/usr/lib/pppd/2.4.5/pppol2tp.so
/usr/lib/pppd/2.4.5/radattr.so
/usr/lib/pppd/2.4.5/radius.so
/usr/lib/pppd/2.4.5/radrealms.so
/usr/lib/pppd/2.4.5/rp-pppoe.so
/usr/lib/pppd/2.4.5/winbind.so
/usr/sbin/chat
/usr/sbin/pppd
/usr/sbin/pppdump
/usr/sbin/pppoe-discovery
/usr/sbin/pppstats
/usr/share/doc/ppp/FAQ.gz
/usr/share/doc/ppp/PLUGINS.gz
/usr/share/doc/ppp/README.Debian.gz
/usr/share/doc/ppp/README.MPPE
/usr/share/doc/ppp/README.MSCHAP80.gz
/usr/share/doc/ppp/README.MSCHAP81
/usr/share/doc/ppp/README.STATIC-IP
/usr/share/doc/ppp/README.cbcp
/usr/share/doc/ppp/README.gz
/usr/share/doc/ppp/README.pppoe
/usr/share/doc/ppp/README.pppol2tp
/usr/share/doc/ppp/README.pwfd
/usr/share/doc/ppp/README.win9x
/usr/share/doc/ppp/SETUP.gz
/usr/share/doc/ppp/changelog.Debian.gz
/usr/share/doc/ppp/copyright
/usr/share/doc/ppp/defaultroute
/usr/share/doc/ppp/examples/filters
/usr/share/doc/ppp/examples/interfaces
/usr/share/doc/ppp/examples/options.ttyXX
/usr/share/doc/ppp/examples/peers-gprs
/usr/share/doc/ppp/examples/peers-pppoa
/usr/share/doc/ppp/examples/peers-pppoe
/usr/share/doc/ppp/examples/per-linkname
/usr/share/doc/ppp/examples/popp
/usr/share/doc/ppp/examples/userscripts-down
/usr/share/doc/ppp/examples/userscripts-up
/usr/share/doc/ppp/examples/scripts/README.gz
/usr/share/doc/ppp/examples/scripts/autopppd.gz
/usr/share/doc/ppp/examples/scripts/callback
/usr/share/doc/ppp/examples/scripts/chat-callback
/usr/share/doc/ppp/examples/scripts/ip-down.local.add
/usr/share/doc/ppp/examples/scripts/ip-up.local.add
/usr/share/doc/ppp/examples/scripts/ipv6-down.sample
/usr/share/doc/ppp/examples/scripts/ipv6-up.sample
/usr/share/doc/ppp/examples/scripts/options-rsh-loc
/usr/share/doc/ppp/examples/scripts/options-rsh-rem
/usr/share/doc/ppp/examples/scripts/options-ssh-loc
/usr/share/doc/ppp/examples/scripts/options-ssh-rem
/usr/share/doc/ppp/examples/scripts/plog
/usr/share/doc/ppp/examples/scripts/poff
/usr/share/doc/ppp/examples/scripts/pon
/usr/share/doc/ppp/examples/scripts/pon.1
/usr/share/doc/ppp/examples/scripts/ppp-off
/usr/share/doc/ppp/examples/scripts/ppp-on
/usr/share/doc/ppp/examples/scripts/ppp-on-dialer
/usr/share/doc/ppp/examples/scripts/ppp-on-rsh
/usr/share/doc/ppp/examples/scripts/ppp-on-ssh
/usr/share/doc/ppp/examples/scripts/redialer
/usr/share/doc/ppp/examples/scripts/secure-card
/usr/share/doc/ppp/examples/scripts/chatchat/README.gz
/usr/share/doc/ppp/examples/scripts/chatchat/chatchat.c.gz
/usr/share/man/man1/plog.1.gz
/usr/share/man/man1/poff.1.gz
/usr/share/man/man1/pon.1.gz
/usr/share/man/man8/chat.8.gz
/usr/share/man/man8/pppd-radattr.8.gz
/usr/share/man/man8/pppd-radius.8.gz
/usr/share/man/man8/pppd.8.gz
/usr/share/man/man8/pppdump.8.gz
/usr/share/man/man8/pppoe-discovery.8.gz
/usr/share/man/man8/pppstats.8.gz
/usr/share/ppp/chap-secrets
/usr/share/ppp/pap-secrets
/usr/share/ppp/provider.chatscript
/usr/share/ppp/provider.peer

Changelog

2015-04-21 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
ppp (2.4.5-5.1ubuntu2.2) trusty-security; urgency=medium
* SECURITY UPDATE: denial of service via big process id
- debian/patches/CVE-2015-3310.patch: limit size of process id in
pppd/plugins/radius/util.c.
- CVE-2015-3310
2014-11-25 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
ppp (2.4.5-5.1ubuntu2.1) trusty-security; urgency=medium
* SECURITY UPDATE: possible privilege escalation via option parsing
- debian/patches/CVE-2014-3158.patch: fix integer overflow in
pppd/options.c.
- CVE-2014-3158
2012-12-23 - Pavel Plesov <pavel.plesov@gmail.com>
ppp (2.4.5-5.1ubuntu2) raring-proposed; urgency=low
* add EAPTLS-MPPE 0.994 patch from http://www.nikhef.nl/~janjust/ppp/
(Closes: #602503, LP: #643417) (quilt refreshed)
* debian/control: Build-Depends on libssl-dev 
2012-12-02 - Adam Conrad <adconrad@ubuntu.com>
ppp (2.4.5-5.1ubuntu1) raring; urgency=low
[ Ubuntu Merge-o-Matic ]
* Merge from Debian unstable.  Remaining changes:
- /etc/ppp/options: default is noauth instead of auth.
- extra/pon: Perform ppp_on_boot migration from pppoe package.
- debian/ppp.postinst: init script migration for version before
2.4.5~git20081126t100229-0ubuntu2.
- debian/ppp.pppd-dns: Update LSB header.
- Provide pppoe_on_boot file.
- Move pppd-dns script to S45.
- debian/patches/load_ppp_generic_if_needed: load ppp_generic kernel
module if needed.
- Fix FTBFS with linux 3.5 headers.
2012-04-22 - Robert Millan <rmh@debian.org>
ppp (2.4.5-5.1) unstable; urgency=low
* Non-maintainer upload.
* Set Architecture to linux-any.  (Closes: #648345)
2012-09-25 - Tim Gardner <tim.gardner@canonical.com>
ppp (2.4.5-5ubuntu2) quantal-proposed; urgency=low
* FTBS fix against linux 3.5 headers: Update debian/patches/update_if_pppol2tp
to reflect changes in Linux 3.5 includes.
2011-02-03 - Angel Abad <angelabad@ubuntu.com>
ppp (2.4.5-5ubuntu1) natty; urgency=low
* Merge from debian unstable. (LP: #712419) Remaining changes:
- /etc/ppp/options: default is noauth instead of auth.
- extra/pon: Perform ppp_on_boot migration from pppoe package.
- debian/ppp.postinst: init script migration for version before
2.4.5~git20081126t100229-0ubuntu2.
- debian/ppp.pppd-dns: Update LSB header.
- Provide pppoe_on_boot file.
- Move pppd-dns script to S45.
- debian/patches/load_ppp_generic_if_needed: load ppp_generic kernel
module if needed.
2011-01-19 - Marco d'Itri <md@linux.it>
ppp (2.4.5-5) unstable; urgency=medium
* Updated debconf translation: da. (Closes: #601791)
2010-11-24 - Matthias Klose <doko@ubuntu.com>
ppp (2.4.5-4ubuntu1) natty; urgency=low
* Merge with Debian; remaining changes:
- /etc/ppp/options: default is noauth instead of auth.
- extra/pon: Perform ppp_on_boot migration from pppoe package.
- debian/ppp.postinst: init script migration for version before
2.4.5~git20081126t100229-0ubuntu2.
- debian/ppp.pppd-dns: Update LSB header.
- Provide pppoe_on_boot file.
- Move pppd-dns script to S45.
- debian/patches/load_ppp_generic_if_needed: load ppp_generic kernel
module if needed.
2010-08-09 - Marco d'Itri <md@linux.it>
ppp (2.4.5-4) unstable; urgency=low
* Make sure to actually rebuild pppd for the udeb instead of using the
just-built normal binary. (Closes: #591703)
* Removed support for IPX from the udeb.
* Added patch adaptive_echos: support sending LCP echo requests only if
the link is idle. (Closes: #14331)
* Updated debconf translation: pt_BR. (Closes: #592155)
* Removed the suspend/resume script for the obsolete apmd.

See Also

Package Description
pptpd_1.3.4+27+gddb30f8-1ubuntu1.1_amd64.deb PoPToP Point to Point Tunneling Server
printer-driver-hpcups_3.14.3-0ubuntu3.4_amd64.deb HP Linux Printing and Imaging - CUPS Raster driver (hpcups)
printer-driver-hpijs_3.14.3-0ubuntu3.4_amd64.deb HP Linux Printing and Imaging - printer driver (hpijs)
printer-driver-postscript-hp_3.14.3-0ubuntu3.4_all.deb HP Printers PostScript Descriptions
procmail_3.22-21ubuntu0.2_amd64.deb Versatile e-mail processor
procps_3.3.9-1ubuntu2.3_amd64.deb /proc file system utilities
pulseaudio-esound-compat_4.0-0ubuntu11.1_amd64.deb PulseAudio ESD compatibility layer
pulseaudio-module-bluetooth_4.0-0ubuntu11.1_amd64.deb Bluetooth module for PulseAudio sound server
pulseaudio-module-gconf_4.0-0ubuntu11.1_amd64.deb GConf module for PulseAudio sound server
pulseaudio-module-jack_4.0-0ubuntu11.1_amd64.deb jackd modules for PulseAudio sound server
pulseaudio-module-lirc_4.0-0ubuntu11.1_amd64.deb lirc module for PulseAudio sound server
pulseaudio-module-raop_4.0-0ubuntu11.1_amd64.deb RAOP module for PulseAudio sound server
pulseaudio-module-x11_4.0-0ubuntu11.1_amd64.deb X11 module for PulseAudio sound server
pulseaudio-module-zeroconf_4.0-0ubuntu11.1_amd64.deb Zeroconf module for PulseAudio sound server
pulseaudio-utils_4.0-0ubuntu11.1_amd64.deb Command line tools for the PulseAudio sound server
Advertisement
Advertisement