libgstreamer-plugins-base1.0-0_1.2.4-1~ubuntu2.1_amd64.deb


Advertisement

Description

libgstreamer-plugins-base1.0-0 - GStreamer libraries from the "base" set

Distribution: Ubuntu 14.04 LTS (Trusty Tahr)
Repository: Ubuntu Updates Main amd64
Package name: libgstreamer-plugins-base1.0-0
Package version: 1.2.4
Package release: 1~ubuntu2.1
Package architecture: amd64
Package type: deb
Installed size: 1.57 KB
Download size: 426.10 KB
Official Mirror: archive.ubuntu.com
GStreamer is a streaming media framework, based on graphs of filters which operate on media data. Applications using this library can do anything from real-time sound processing to playing videos, and just about anything else media-related. Its plugin-based architecture means that new data types or processing capabilities can be added simply by installing new plug-ins. This package contains libraries from the "base" set, an essential exemplary set of elements.

    Download

    Source package: gst-plugins-base1.0

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libgstreamer-plugins-base1.0-0 deb package:
      # sudo apt-get install libgstreamer-plugins-base1.0-0

    Changelog

    2017-03-23 - Marc Deslauriers <marc.deslauriers@ubuntu.com> gst-plugins-base1.0 (1.2.4-1~ubuntu2.1) trusty-security; urgency=medium * SECURITY UPDATE: DoS in windows_icon_typefind - debian/patches/CVE-2016-9811.patch: add bounds check in gst/typefind/gsttypefindfunctions.c. - CVE-2016-9811 * SECURITY UPDATE: DoS in gst_riff_create_audio_caps - debian/patches/CVE-2017-5837.patch: check for valid channels/rate in gst-libs/gst/riff/riff-media.c. - CVE-2017-5837 * SECURITY UPDATE: DoS in gst_riff_create_audio_caps - debian/patches/CVE-2017-5839.patch: fix infinite recursion in gst-libs/gst/riff/riff-media.c. - CVE-2017-5839 * SECURITY UPDATE: DoS in html_context_handle_element - debian/patches/CVE-2017-5842.patch: check for non-zero length in gst/subparse/samiparse.c. - CVE-2017-5842 * SECURITY UPDATE: DoS in gst_riff_create_audio_caps - debian/patches/CVE-2017-5844.patch: fix divide by zero in gst-libs/gst/riff/riff-media.c. - CVE-2017-5844

    2015-10-14 - Michael Terry <mterry@ubuntu.com> gst-plugins-base1.0 (1.2.4-1~ubuntu2) trusty; urgency=medium [ Johannes Dewender ] * Cherry pick fix for MusicBrainz Audio CD ID calculation, to avoid an error message when submitting to the MB database (LP: #1489816)

    2014-04-24 - Sebastien Bacher <seb128@debian.org> gst-plugins-base1.0 (1.2.4-1~ubuntu1) trusty; urgency=medium * Upload Debian bugfix update as a trusty SRU (lp: #1312305) [ Sebastian Dröge ] * New upstream bugfix release.

    2014-02-09 - Sebastian Dröge <slomo@debian.org> gst-plugins-base1.0 (1.2.3-1) unstable; urgency=medium * New upstream bugfix release: + debian/libgstreamer-plugins-base.symbols: - Add new symbol. * debian/rules: + Run libtoolize in autoreconf. Drop ltmain-as-needed patch and use dh_autoreconf --as-needed.

    2013-12-27 - Sebastian Dröge <slomo@debian.org> gst-plugins-base1.0 (1.2.2-1) unstable; urgency=medium * New upstream bugfix release: + debian/libgstreamer-plugins-base.symbols: - Add new 1.2.2 API additions.

    2013-11-10 - Sebastian Dröge <slomo@debian.org> gst-plugins-base1.0 (1.2.1-2) unstable; urgency=low * debian/gstreamer-plugins-base-apps.install: + Include new gst-play-1.0 tool. * debian/gstreamer-plugins-base-apps.manpages: + Ship the manpages for gst-discoverer-1.0 and gst-play-1.0.

    2013-11-09 - Sebastian Dröge <slomo@debian.org> gst-plugins-base1.0 (1.2.1-1) unstable; urgency=low [ Fabian Greffrath ] * Fix gst_version variable generation. * Add Vcs-* fields to debian/control{,.in}, update Homepage field. * Turn versioned Conflicts into Breaks, remove trailing comma. [ Sebastian Dröge ] * New upstream bugfix release: + debian/libgstreamer-plugins-base.symbols: - Add new 1.2.1 API additions.

    2013-09-24 - Sebastian Dröge <slomo@debian.org> gst-plugins-base1.0 (1.2.0-1) unstable; urgency=low * New upstream stable release: + debian/rules, debian/build-deps.in: - Build-depend on GStreamer >= 1.2.0.

    2013-09-19 - Sebastian Dröge <slomo@debian.org> gst-plugins-base1.0 (1.1.90-1) experimental; urgency=low * New upstream release candidate: + debian/rules, debian/build-deps.in: - Build-depend on GStreamer >= 1.1.90. + debian/libgstreamer-plugins-base.symbols: - Add new symbols.

    2013-08-30 - Sebastian Dröge <slomo@debian.org> gst-plugins-base1.0 (1.1.4-1) experimental; urgency=low * New upstream development snapshot: + debian/rules, debian/build-deps.in: - Build-depend on GStreamer >= 1.1.4. + debian/libgstreamer-plugins-base.symbols: - Add new symbols.

    Advertisement
    Advertisement