gstreamer1.0-plugins-good_1.2.4-1~ubuntu1.4_amd64.deb


Advertisement

Description

gstreamer1.0-plugins-good - GStreamer plugins from the "good" set

Property Value
Distribution Ubuntu 14.04 LTS (Trusty Tahr)
Repository Ubuntu Updates Main amd64
Package filename gstreamer1.0-plugins-good_1.2.4-1~ubuntu1.4_amd64.deb
Package name gstreamer1.0-plugins-good
Package version 1.2.4
Package release 1~ubuntu1.4
Package architecture amd64
Package type deb
Category libs
Homepage http://gstreamer.freedesktop.org/modules/gst-plugins-good.html
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 1.23 MB
Installed size 4.80 MB
GStreamer is a streaming media framework, based on graphs of filters
which operate on media data.  Applications using this library can do
anything from real-time sound processing to playing videos, and just
about anything else media-related.  Its plugin-based architecture means
that new data types or processing capabilities can be added simply by
installing new plug-ins.
This package contains the GStreamer plugins from the "good" set, a set
of good-quality plug-ins under the LGPL license.

Alternatives

Package Version Architecture Repository
gstreamer1.0-plugins-good_1.2.4-1~ubuntu1.4_i386.deb 1.2.4 i386 Ubuntu Updates Main
gstreamer1.0-plugins-good_1.2.3-1ubuntu2_i386.deb 1.2.3 i386 Ubuntu Main
gstreamer1.0-plugins-good_1.2.3-1ubuntu2_amd64.deb 1.2.3 amd64 Ubuntu Main
gstreamer1.0-plugins-good - - -

Requires

Name Value
gstreamer1.0-plugins-base -
libaa1 >= 1.4p5
libavc1394-0 >= 0.5.3
libbz2-1.0 -
libc6 >= 2.17
libcaca0 >= 0.99.beta17-1
libcairo-gobject2 >= 1.10.0
libcairo2 >= 1.10.0
libdv4 -
libflac8 >= 1.3.0
libgcc1 >= 1:4.1.1
libgdk-pixbuf2.0-0 >= 2.22.0
libglib2.0-0 >= 2.37.3
libgstreamer-plugins-base1.0-0 >= 1.2.1
libgstreamer-plugins-good1.0-0 = 1.2.4-1~ubuntu1.4
libgstreamer1.0-0 >= 1.2.0
libiec61883-0 >= 1.2.0
libjack-0.116 -
libjack-jackd2-0 >= 1.9.5~dfsg-14
libjpeg8 >= 8c
liborc-0.4-0 >= 1:0.4.18
libpng12-0 >= 1.2.13-4
libraw1394-11 -
libshout3 -
libsoup2.4-1 >= 2.38
libspeex1 >= 1.2~beta3-1
libstdc++6 >= 4.1.1
libtag1c2a >= 1.5
libv4l-0 >= 0.5.0
libvpx1 >= 1.3.0
libwavpack1 >= 4.40.0
libx11-6 -
libxdamage1 >= 1:1.1
libxext6 -
libxfixes3 -
libxv1 -
zlib1g >= 1:1.1.4

Provides

Name Value
gstreamer1.0-audiosink -
gstreamer1.0-audiosource -
gstreamer1.0-videosink -
gstreamer1.0-videosource -
gstreamer1.0-visualization -

Replaces

Name Value
gstreamer1.0-plugins-bad << 1.1.2

Download

Type URL
Mirror archive.ubuntu.com
Binary Package gstreamer1.0-plugins-good_1.2.4-1~ubuntu1.4_amd64.deb
Source Package gst-plugins-good1.0

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gstreamer1.0-plugins-good deb package:
    # sudo apt-get install gstreamer1.0-plugins-good

Files

Path
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgst1394.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstaasink.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstalaw.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstalpha.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstalphacolor.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstapetag.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstaudiofx.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstaudioparsers.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstauparse.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstautodetect.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstavi.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstcacasink.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstcairo.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstcamerabin2.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstcutter.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstdebug.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstdeinterlace.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstdtmf.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstdv.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgsteffectv.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstequalizer.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstflac.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstflv.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstflxdec.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstgdkpixbuf.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstgoom.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstgoom2k1.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgsticydemux.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstid3demux.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstimagefreeze.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstinterleave.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstisomp4.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstjack.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstjpeg.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstjpegformat.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstlevel.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstmatroska.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstmonoscope.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstmulaw.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstmultifile.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstmultipart.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstnavigationtest.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstoss4audio.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstossaudio.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstpng.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstreplaygain.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstrtp.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstrtpmanager.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstrtsp.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstshapewipe.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstshout2.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstsmpte.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstsouphttpsrc.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstspectrum.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstspeex.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgsttaglib.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstudp.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstvideo4linux2.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstvideobox.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstvideocrop.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstvideofilter.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstvideomixer.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstvpx.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstwavenc.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstwavpack.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstwavparse.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstximagesrc.so
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgsty4menc.so
/usr/share/doc/gstreamer1.0-plugins-good/AUTHORS
/usr/share/doc/gstreamer1.0-plugins-good/NEWS.gz
/usr/share/doc/gstreamer1.0-plugins-good/README.Debian
/usr/share/doc/gstreamer1.0-plugins-good/README.gz
/usr/share/doc/gstreamer1.0-plugins-good/changelog.Debian.gz
/usr/share/doc/gstreamer1.0-plugins-good/copyright
/usr/share/gstreamer-1.0/presets/GstIirEqualizer10Bands.prs
/usr/share/gstreamer-1.0/presets/GstIirEqualizer3Bands.prs
/usr/share/gstreamer-1.0/presets/GstVP8Enc.prs

Changelog

2017-03-23 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
gst-plugins-good1.0 (1.2.4-1~ubuntu1.4) trusty-security; urgency=medium
* SECURITY UPDATE: DoS in gst_aac_parse_sink_setcaps
- debian/patches/CVE-2016-10198.patch: make sure there's enough data in
gst/audioparsers/gstaacparse.c.
- CVE-2016-10198
* SECURITY UPDATE: DoS in qtdemux_tag_add_str_full
- debian/patches/CVE-2016-10199.patch: fix out of bounds read in
gst/isomp4/qtdemux.c.
- CVE-2016-10199
* SECURITY UPDATE: DoS in qtdemux_parse_samples
- debian/patches/CVE-2017-5840.patch: properly increment stts index in
gst/isomp4/qtdemux.c.
- CVE-2017-5840
2016-11-25 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
gst-plugins-good1.0 (1.2.4-1~ubuntu1.3) trusty-security; urgency=medium
* SECURITY UPDATE: incomplete fix for flx decoder
- debian/patches/flxdec-bounds3.patch: don't unref() parent in the
chain function in gst/flx/gstflxdec.c.
- debian/patches/flxdec-bounds4.patch: rewrite logic based on
GstByteReader/Writer in gst/flx/flx_fmt.h, gst/flx/gstflxdec.c,
gst/flx/gstflxdec.h.
- No CVE number
2016-11-22 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
gst-plugins-good1.0 (1.2.4-1~ubuntu1.1) trusty-security; urgency=medium
* SECURITY UPDATE: code execution via out-of-bounds write in flx decoder
- debian/patches/flxdec-bounds1.patch: add bounds checking to
gst/flx/gstflxdec.c.
- debian/patches/flxdec-bounds2.patch: fix compiler warnings in
gst/flx/gstflxdec.c.
- No CVE number
2014-04-25 - Iain Lane <iain.lane@canonical.com>
gst-plugins-good1.0 (1.2.4-1~ubuntu1) trusty; urgency=medium
* SRU Utopic merge to trusty to get bugfix release 1.2.4 (LP: #1312305)
+ qtdemux: reverse playback and video stream switching failure
+ souphttpsrc: racy " server does not support seeking " error
+ crash when reading the device name property of pulsesink
+ rtspsrc: Fix deadlock when task creation is no successful
+ rtpsession: Crash when RTCP FIR received with unknown SSRC
+ v4l2src: Fix using v4l2src with Hauppauge HDPVR video capture device
+ rtpjpegpay: payload size not correctly calculated
+ [regression]eos event could not be send out from gstrtpjitterbuffer.
+ rtph264depay: marks all output buffers as delta units when outputting avc format
+ aacparse : Missing resilience when no audio frame is found
+ check: souphttpsrc: unknown type name ‘SoupStatus’
2014-04-25 - Iain Lane <iain.lane@canonical.com>
gst-plugins-good1.0 (1.2.4-1ubuntu1) trusty; urgency=low
* Merge from Debian unstable.  Remaining changes:
+ Import plugins from -bad that are needed for main applications.
- jpegformat
- camerabin2 (+ basecamerabinsrc + photography)
+ Break and Replace -bad versions which contained these plugins. 
+ Add a library package containing the shared library and a -dev package for
compiling against it. Add Breaks and Replaces against the plugins packages
which formerly contained files shipped here.
2014-04-19 - Sebastian Dröge <slomo@debian.org>
gst-plugins-good1.0 (1.2.4-1) unstable; urgency=medium
* New upstream bugfix release:
+ debian/rules:
- Build-depend on gstreamer >= 1.2.4.
2014-03-14 - Dimitri John Ledkov <xnox@ubuntu.com>
gst-plugins-good1.0 (1.2.3-1ubuntu2) trusty; urgency=medium
* Cherry-pick patch from upstream to fix gtk-docs FTBFS. (LP: #1289818)
2014-02-12 - Iain Lane <iain.lane@canonical.com>
gst-plugins-good1.0 (1.2.3-1ubuntu1) trusty; urgency=low
* Merge from Debian unstable.  Remaining changes:
+ Import plugins from -bad that are needed for main applications.
- jpegformat
- camerabin2 (+ basecamerabinsrc + photography)
+ Break and Replace -bad versions which contained these plugins. 
+ Add a library package containing the shared library and a -dev package for
compiling against it. Add Breaks and Replaces against the plugins packages
which formerly contained files shipped here.

See Also

Package Description
gstreamer1.0-pulseaudio_1.2.4-1~ubuntu1.4_amd64.deb GStreamer plugin for PulseAudio
gstreamer1.0-tools_1.2.4-0ubuntu1.1_amd64.deb Tools for use with GStreamer
gstreamer1.0-x_1.2.4-1~ubuntu2.1_amd64.deb GStreamer plugins for X11 and Pango
gtk-3-examples_3.10.8-0ubuntu1.6_amd64.deb example files for GTK+ 3
gtk2.0-examples_2.24.23-0ubuntu1.4_amd64.deb example files for GTK+ 2.0
gvfs-backends_1.20.3-0ubuntu1.2_amd64.deb userspace virtual filesystem - backends
gvfs-bin_1.20.3-0ubuntu1.2_amd64.deb userspace virtual filesystem - binaries
gvfs-common_1.20.3-0ubuntu1.2_all.deb userspace virtual filesystem - common data files
gvfs-daemons_1.20.3-0ubuntu1.2_amd64.deb userspace virtual filesystem - servers
gvfs-fuse_1.20.3-0ubuntu1.2_amd64.deb userspace virtual filesystem - fuse server
gvfs-libs_1.20.3-0ubuntu1.2_amd64.deb userspace virtual filesystem - private libraries
gvfs_1.20.3-0ubuntu1.2_amd64.deb userspace virtual filesystem - GIO module
haproxy_1.4.24-2ubuntu0.4_amd64.deb fast and reliable load balancing reverse proxy
hardening-includes_2.5ubuntu2.1_all.deb Makefile for enabling compiler flags for security hardening
hardening-wrapper_2.5ubuntu2.1_amd64.deb Compiler wrapper to enable security hardening flags
Advertisement
Advertisement