opam_1.1.1-1_i386.deb


Advertisement

Description

opam - package manager for OCaml

Property Value
Distribution Ubuntu 14.04 LTS (Trusty Tahr)
Repository Ubuntu Universe i386
Package filename opam_1.1.1-1_i386.deb
Package name opam
Package version 1.1.1
Package release 1
Package architecture i386
Package type deb
Category universe/ocaml
Homepage http://opam.ocamlpro.com
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 1006.20 KB
Installed size 5.28 MB
OPAM stands for OCaml PAckage Manager. It aims to suit to a vast number
of users and use cases, and has unique features:
* Powerful handling of dependencies: versions constraints, optional
dependencies, conflicts, etc.
* Multiple repositories backends: HTTP, rsync, git
* Ease to create packages and repositories
* Ability to switch between different compiler versions
Typically, OPAM will probably make your life easier if you recognize
yourself in at least one of these profiles:
* You use multiple versions of the OCaml compiler, or you hack the compiler
yourself and needs to frequently switch between compiler versions.
* You use or develop software that needs a specific and/or modified version
of the OCaml compiler to be installed.
* You use or develop software that depends on a specific version of an OCaml
library, or you just want to install a specific version of a package, not
just the latest one.
* You want to create your own packages yourself, put them on your own
repository, with minimal effort.

Alternatives

Package Version Architecture Repository
opam_1.1.1-1_amd64.deb 1.1.1 amd64 Ubuntu Universe
opam - - -

Requires

Name Value
build-essential -
curl -
libbz2-1.0 -
libc6 >= 2.15
libpcre3 -
opam-docs = 1.1.1-1
wget -
zlib1g >= 1:1.1.4

Download

Type URL
Mirror archive.ubuntu.com
Binary Package opam_1.1.1-1_i386.deb
Source Package opam

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install opam deb package:
    # sudo apt-get install opam

Files

Path
/usr/bin/opam
/usr/bin/opam-admin
/usr/share/doc/opam/changelog.Debian.gz
/usr/share/doc/opam/copyright

See Also

Package Description
opari2_1.0.7+dfsg-2_i386.deb OpenMP Pragma And Region Instrumentor - translation tool
opari_1.1+dfsg-3_i386.deb OpenMP Pragma And Region Instrumentor - translation tool
open-axiom-databases_1.4.1+svn~2626-2ubuntu2_all.deb open scientific computation platform: generated text databases
open-axiom-graphics-data_1.4.1+svn~2626-2ubuntu2_all.deb open scientific computation platform: graphics subsystem data
open-axiom-graphics_1.4.1+svn~2626-2ubuntu2_i386.deb open scientific computation platform: graphics subsystem
open-axiom-hypertex-data_1.4.1+svn~2626-2ubuntu2_all.deb open scientific computation platform: hypertex subsystem data
open-axiom-hypertex_1.4.1+svn~2626-2ubuntu2_i386.deb open scientific computation platform: hypertex subsystem
open-axiom-source_1.4.1+svn~2626-2ubuntu2_all.deb open scientific computation platform: source files
open-axiom-test_1.4.1+svn~2626-2ubuntu2_all.deb open scientific computation platform: regression test inputs
open-axiom-tex_1.4.1+svn~2626-2ubuntu2_all.deb open scientific computation platform: style file for TeX
open-axiom_1.4.1+svn~2626-2ubuntu2_i386.deb open scientific computation platform
open-cobol_1.1-1build1_i386.deb COBOL compiler
open-font-design-toolkit_1.5_all.deb metapackage for open font design
open-invaders-data_0.3-4_all.deb Space Invaders clone (data package)
open-invaders_0.3-4_i386.deb Space Invaders clone
Advertisement
Advertisement