libxklavier16_5.4-0ubuntu1_i386.deb


Advertisement

Description

libxklavier16 - X Keyboard Extension high-level API

Property Value
Distribution Ubuntu 14.04 LTS (Trusty Tahr)
Repository Ubuntu Main i386
Package filename libxklavier16_5.4-0ubuntu1_i386.deb
Package name libxklavier16
Package version 5.4
Package release 0ubuntu1
Package architecture i386
Package type deb
Category libs
Homepage http://www.freedesktop.org/wiki/Software/LibXklavier
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 40.87 KB
Installed size 144.00 KB
Libxklavier provides programmers an API for high(er) level access to the
X Keyboard Extension, to ease creating XKB related applications.

Alternatives

Package Version Architecture Repository
libxklavier16_5.4-0ubuntu1_amd64.deb 5.4 amd64 Ubuntu Main
libxklavier16 - - -

Requires

Name Value
libc6 >= 2.4
libglib2.0-0 >= 2.37.3
libx11-6 -
libxi6 >= 2:1.1.2
libxkbfile1 -
libxml2 >= 2.7.4
x11-xkb-utils -
xkb-data >= 0.8

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libxklavier16_5.4-0ubuntu1_i386.deb
Source Package libxklavier

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libxklavier16 deb package:
    # sudo apt-get install libxklavier16

Files

Path
/usr/lib/libxklavier.so.16
/usr/lib/libxklavier.so.16.4.0
/usr/share/doc/libxklavier16/AUTHORS
/usr/share/doc/libxklavier16/NEWS.gz
/usr/share/doc/libxklavier16/README
/usr/share/doc/libxklavier16/changelog.Debian.gz
/usr/share/doc/libxklavier16/copyright

Changelog

2014-02-21 - Dimitri John Ledkov <xnox@ubuntu.com>
libxklavier (5.4-0ubuntu1) trusty; urgency=medium
* New upstream release
2014-02-17 - Jackson Doak <noskcaj@ubuntu.com>
libxklavier (5.3-0ubuntu1) trusty; urgency=medium
* New upstream release.
* Drop 0001-Explicitly-exporting-only-the-symbols-that-are-reall.patch,
fixed upstream
* Update symbols
2012-10-05 - Colin Watson <cjwatson@ubuntu.com>
libxklavier (5.2.1-1ubuntu2) quantal; urgency=low
* Rebuild for new armel compiler default of ARMv5t.
2012-03-21 - Michael Terry <mterry@ubuntu.com>
libxklavier (5.2.1-1ubuntu1) precise; urgency=low
* debian/patches/revert-default-group-change.patch:
- Revert change in group handling that can cause the wrong layout to
be enabled by default when autologging in.  LP: #960096
2012-02-22 - Michael Biebl <biebl@debian.org>
libxklavier (5.2.1-1) unstable; urgency=low
* New upstream release.
* Remove debian/patches/00git_gir_build_include.patch, merged upstream.
* debian/control.in: Remove alternative dependency on xkb-data-legacy.
* Add symbols file for libxklavier16.
* Only export those symbols which are supposed to be public. Patch
cherry-picked from upstream Git.
* debian/rules: Rebuild gtk-doc API documentation.
2012-02-15 - Martin Pitt <mpitt@debian.org>
libxklavier (5.2-1) unstable; urgency=low
* debian/watch: Watch for xz tarballs.
* New upstream release.
* Drop 00git_introspection.patch, upstream now.
* Add 00git_gir_build_include.patch: Fix building of GIR. Taken from
upstream git head.
* Drop use-pkgconfig-properly.patch, upstream now.
2012-01-16 - Martin Pitt <mpitt@debian.org>
libxklavier (5.1-3) unstable; urgency=low
[ Josselin Mouette ]
* Update repository URL.
[ Martin Pitt ]
* Add gobject-introspection support: (LP: #800561)
- Add 00git_introspection.patch: Already accepted upstream, backported
to 5.1.
- debian/control.in: Add gir1.2-xkl-1.0 binary package and GI build
dependencies. Also add dh-autoreconf build dependency.
- debian/rules: Use dh-autoreconf cdbs module.
- debian/rules: Bump shlibs to this version, as the patch adds a few new
methods and the library bumped minor version.
- Add debian/gir1.2-xkl-1.0.install: Install typelib.
- debian/libxklavier-dev.install: Install .gir.
2011-07-20 - Michael Biebl <biebl@debian.org>
libxklavier (5.1-2) unstable; urgency=low
* debian/watch: Swich to .bz2 tarballs.
* Switch to source format 3.0 (quilt)
- Add debian/source/format
- Remove simple-patchsys.mk from debian/rules.
* Bump debhelper compatibility level to 8.
- Update Build-Depends on debhelper.
- Strip debian/tmp/ from .install files.
* debian/control.in:
- Bump Standards-Version to 3.9.2. No further changes.
- Add Vcs-* fields.
- Remove old Conflicts and Replaces which are no longer necessary.
* debian/patches/use-pkgconfig-properly.patch:
- Use Requires.private in libxklavier.pc to specify the dependencies
instead of substituting CFLAGS/LIBS for other libraries as this will
break with multiarch. Patch courtesy of Steve Langasek. Closes: #620110
2011-02-25 - Frederic Peters <fpeters@debian.org>
libxklavier (5.1-1) experimental; urgency=low
* New upstream release.
+ debian/rules: updated shlibs
2010-04-08 - Josselin Mouette <joss@debian.org>
libxklavier (5.0-2) unstable; urgency=low
* Upload to unstable.

See Also

Package Description
libxml++2.6-2_2.36.0-2ubuntu1_i386.deb C++ interface to the GNOME XML library (libxml2)
libxml++2.6-dev_2.36.0-2ubuntu1_i386.deb C++ interface to the GNOME XML library (libxml2)
libxml++2.6-doc_2.36.0-2ubuntu1_all.deb HTML interface documentation and examples for libxml++
libxml-commons-external-java-doc_1.4.01-2build1_all.deb Documentation of XML Commons external API
libxml-commons-external-java_1.4.01-2build1_all.deb XML Commons external code - DOM, SAX, and JAXP, etc
libxml-commons-resolver1.1-java-doc_1.2-7build1_all.deb XML entity and URI resolver library -- documentation
libxml-commons-resolver1.1-java-gcj_1.2-7build1_i386.deb XML entity and URI resolver library -- native library
libxml-commons-resolver1.1-java_1.2-7build1_all.deb XML entity and URI resolver library
libxml-dom-perl_1.44-1_all.deb Perl module for building DOM Level 1 compliant doc structures
libxml-filter-buffertext-perl_1.01-5_all.deb Perl module for putting all characters into a single event
libxml-libxml-perl_2.0108+dfsg-1_i386.deb Perl interface to the libxml2 library
libxml-libxslt-perl_1.84-1_i386.deb Perl interface to the GNOME libxslt library
libxml-namespacesupport-perl_1.11-1_all.deb Perl module for supporting simple generic namespaces
libxml-parser-perl_2.41-1build3_i386.deb Perl module for parsing XML files
libxml-perl_0.08-2_all.deb Perl modules for working with XML
Advertisement
Advertisement