liblockfile1_1.09-6ubuntu1_i386.deb


Advertisement

Description

liblockfile1 - NFS-safe locking library

Property Value
Distribution Ubuntu 14.04 LTS (Trusty Tahr)
Repository Ubuntu Main i386
Package name liblockfile1
Package version 1.09
Package release 6ubuntu1
Package architecture i386
Package type deb
Installed size 56 B
Download size 7.74 KB
Official Mirror archive.ubuntu.com
Liblockfile is a shared library with NFS-safe locking functions.

Alternatives

Package Version Architecture Repository
liblockfile1_1.09-6ubuntu1_amd64.deb 1.09 amd64 Ubuntu Main
liblockfile1 - - -

Requires

Name Value
libc6 >= 2.4
liblockfile-bin >= 1.09-6ubuntu1
multiarch-support -

Download

Type URL
Binary Package liblockfile1_1.09-6ubuntu1_i386.deb
Source Package liblockfile

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install liblockfile1 deb package:
    # sudo apt-get install liblockfile1

Files

Path
/usr/lib/i386-linux-gnu/liblockfile.so.1
/usr/lib/i386-linux-gnu/liblockfile.so.1.0
/usr/share/doc/liblockfile1/changelog.Debian.gz
/usr/share/doc/liblockfile1/copyright

Changelog

2013-12-06 - Adam Conrad <adconrad@ubuntu.com>
liblockfile (1.09-6ubuntu1) trusty; urgency=low
* Explicitly set CC with DEB_HOST_GNU_TYPE if we're cross-compiling.
2013-06-02 - Anibal Monsalve Salazar <anibal@debian.org>
liblockfile (1.09-6) unstable; urgency=low
* Merge 1.09-5ubuntu1
fix-buffer-overflows.patch: Fix buffer overflows when building strings
- Protect against overflows caused by long hostnames (LP: #941968)
- Protect against overflows caused by large PID numbers (LP: #1011477)
Closes: #677225
* In Makefile.in it compiles nfslock.so.$(NVER) but installs nfslock.so.$(VER) 
Add 688074-Makefile.in-NVER.patch
Patch by Yao Zhao
Closes: #688074
* Standards Version is 3.9.4
2013-01-09 - Tyler Hicks <tyhicks@canonical.com>
liblockfile (1.09-5ubuntu1) raring; urgency=low
* debian/patches/fix-buffer-overflows.patch: Fix buffer overflows when
building strings
- Protect against overflows caused by long hostnames (LP: #941968)
- Protect against overflows caused by large PID numbers (LP: #1011477)
2012-12-11 - Anibal Monsalve Salazar <anibal@debian.org>
liblockfile (1.09-5) unstable; urgency=low
[ Rob Browning ]
* Don't remove /usr/share/doc/liblockfile1 from the postrm anymore.
Doing so breaks multarch, and it appears that the code was originally
inserted to fix an upgrade problem (#339498) from 2005.
(closes: #695268)
2012-06-13 - Anibal Monsalve Salazar <anibal@debian.org>
liblockfile (1.09-4) unstable; urgency=low
* Multiarch issues
- Move liblockfile.a to /usr/lib/$(DEB_HOST_MULTIARCH)
- Compress files with "gzip -n"
Patch by Sven Joachim
Closes: #637569
* Enable hardened build flags
Add Makefile.in.patch
* Standards version is 3.9.3
2011-08-13 - Miquel van Smoorenburg <miquels@cistron.nl>
liblockfile (1.09-3) unstable; urgency=high
* add Replaces/Breaks liblockfile1 for liblockfile-bin (closes: #637555)
* make liblockfile-bin Multiarch: foreign (closes: #637568)
2011-08-12 - Miquel van Smoorenburg <miquels@cistron.nl>
liblockfile (1.09-2) unstable; urgency=high
* fix debian/files botchup (fixes: #637465)
* fix more lintian warnings and errors
2011-08-10 - Miquel van Smoorenburg <miquels@cistron.nl>
liblockfile (1.09-1) unstable; urgency=low
* New upstream version (fixes: #406471, #547721, #273112)
* Make package multi-arch compliant
* Add lintian override for setgid mail helper
* Delete whitespace adjusting macro stuff from dotlockfile.1
* Remove shlib depends from dotlockfile control file entry
2010-02-14 - Anibal Monsalve Salazar <anibal@debian.org>
liblockfile (1.08-4) unstable; urgency=low
* Merge 1.08-3ubuntu1
Compute md5sums during build
Closes: 563544, 564797
* Debian source format is 3.0 (quilt)
Add 04-505851-remove-debug-code.patch
* Add important information to dotlockfile.1
Add 06-493462-dotlockfile.1.patch
Update usage message
Add 07-493462-dotlockfile.c.patch
Patches by Roland Eggner
Closes: 493462
* Make ar overwritable (for cross-builds)
Add 09-562937-make-ar-overwrittable.patch
Patch by Marc Kleine-Budde and Wolfram Sang
Closes: 562937
* Fix out-of-date-standards-version
Add 02-COPYRIGHT.patch
* Fix copyright-refers-to-symlink-license
* Fix maintainer-script-without-set-e
2010-01-12 - Loïc Minier <loic.minier@ubuntu.com>
liblockfile (1.08-3ubuntu1) lucid; urgency=low
* Compute md5sums during build.

See Also

Package Description
liblog-log4perl-perl_1.41-1.1ubuntu1_all.deb Perl port of the widely popular log4j logging package
liblog-message-simple-perl_0.10-1_all.deb simplified interface to Log::Message
liblog4j1.2-java-doc_1.2.17-4ubuntu3_all.deb Documentation for liblog4j1.2-java
liblog4j1.2-java_1.2.17-4ubuntu3_all.deb Logging library for java
liblog4net-cil-dev_1.2.10+dfsg-6_all.deb highly configurable logging API for the CLI
liblog4net1.2-cil_1.2.10+dfsg-6_all.deb highly configurable logging API for the CLI
liblouis-data_2.5.3-2ubuntu1_all.deb Braille translation library - data
liblouis-dev_2.5.3-2ubuntu1_i386.deb Braille translation library - static libs and headers
liblouis2_2.5.3-2ubuntu1_i386.deb Braille translation library - shared libs
liblpsolve55-dev_5.5.0.13-7build1_i386.deb Solve (mixed integer) linear programming problems - library
liblqr-1-0-dev_0.4.1-2ubuntu1_i386.deb converts plain array images into multi-size representation (developments files)
liblqr-1-0_0.4.1-2ubuntu1_i386.deb converts plain array images into multi-size representation
liblrm2-dev_1.0.11+hg2754-1.1build1_i386.deb Reusable cluster development files -- liblrm
liblrm2_1.0.11+hg2754-1.1build1_i386.deb Reusable cluster libraries -- liblrm2
liblrmd1-dev_1.1.10+git20130802-1ubuntu2_i386.deb Development file for pacemaker's lrmd library
Advertisement
Advertisement