libbtf1.2.0_4.2.1-3ubuntu1_i386.deb


Advertisement

Description

libbtf1.2.0 - permutation to block triangular form library for sparse matrices

Property Value
Distribution Ubuntu 14.04 LTS (Trusty Tahr)
Repository Ubuntu Main i386
Package filename libbtf1.2.0_4.2.1-3ubuntu1_i386.deb
Package name libbtf1.2.0
Package version 4.2.1
Package release 3ubuntu1
Package architecture i386
Package type deb
Category libs
Homepage http://www.cise.ufl.edu/research/sparse/SuiteSparse/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 8.55 KB
Installed size 50.00 KB
Suitesparse is a collection of libraries for computations involving
sparse matrices.  This package includes the following dynamic library:
BTF         permutation to block triangular form (beta)

Alternatives

Package Version Architecture Repository
libbtf1.2.0_4.2.1-3ubuntu1_amd64.deb 4.2.1 amd64 Ubuntu Main
libbtf1.2.0 - - -

Requires

Name Value
libc6 >= 2.1.3
multiarch-support -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libbtf1.2.0_4.2.1-3ubuntu1_i386.deb
Source Package suitesparse

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libbtf1.2.0 deb package:
    # sudo apt-get install libbtf1.2.0

Files

Path
/usr/lib/i386-linux-gnu/libbtf.so.1.2.0
/usr/share/doc/libbtf1.2.0/NEWS.Debian.gz
/usr/share/doc/libbtf1.2.0/changelog.Debian.gz
/usr/share/doc/libbtf1.2.0/copyright

Changelog

2013-12-07 - Logan Rosen <logan@ubuntu.com>
suitesparse (1:4.2.1-3ubuntu1) trusty; urgency=low
* Merge from Debian unstable. Remaining changes:
- debian/control: Demote libatlas-doc from Recommends to Suggests, as it
is not in main.
2013-12-01 - Sébastien Villemot <sebastien@debian.org>
suitesparse (1:4.2.1-3) unstable; urgency=low
* Upload to unstable.
* Register user guides for KLU, CAMD, SPQR and LDL in doc-base.
2013-11-13 - Sébastien Villemot <sebastien@debian.org>
suitesparse (1:4.2.1-2) experimental; urgency=low
* Really fix BLAS/LAPACK dependencies of libsuitesparse-dev
- remove obsolete ATLAS specialized libraries (Closes: #645846)
- add virtual package libblas.so as a BLAS alternative (Closes: #645844)
* Remove Daniel Rus Morales from Uploaders, with his consent. Thanks
Daniel for your work!
* d/rules: do not regenerate d/control automatically, this is
forbidden
* d/rules: fix get-orig-source rule
* d/control: use canonical URLs for Vcs-* fields
* Mark debug package as Multi-Arch: same
* Ship libsuitesparseconfig.a in the -dev package.
* Bump Standards-Version to 3.9.5, no changes needed.
2013-05-03 - Sébastien Villemot <sebastien@debian.org>
suitesparse (1:4.2.1-1) experimental; urgency=low
* New upstream release (Closes: #706709)
- debian/library-soname.pl: update soversion numbers
* debian/rules: recreate d/control when d/library-sonames.pl is
modified
2013-04-29 - Sébastien Villemot <sebastien@debian.org>
suitesparse (1:4.2.0-1) experimental; urgency=low
[ Christophe Trophime ]
* New upstream release (Closes: #653660, #687282)
- Renamed UFconfig to SuiteSparse_config
- Update patches to new release
- debian/library-soname.pl: update soversion numbers
[ Sébastien Villemot ]
* debian/control.in:
- fix Maintainer field (Closes: #674266, #674268, #674270, #674271, #674272,
#674273, #674274, #674275, #674276, #674277, #674278, #674279, #674280,
#674281)
- add myself to Uploaders
- remove obsolete DM-Upload-Allowed flag
* Remove obsolete README.source
* debian/rules: clean *.oo files
* Bump to debhelper compat level 9
* Update debian/copyright
* Remove symbols files: they are useless since we bump the soversion
at every new upstream release
* Clean up build flags
- make sure to inject flags from dpkg-buildflags
- buildflags.diff: new patch to remove spurious flags in upstream build
system
- remove -m64 flag on amd64 CPUs (Closes: #701654)
* Fix version in NEWS.Debian, to make lintian happy
* parallel-build.diff: new patch, fixes parallel build
* Multiarchify the package
* Fix BLAS/LAPACK dependencies of libsuitesparse-dev:
- remove obsolete ATLAS specialized libraries (Closes: #645846)
- add libopenblas-dev as a BLAS alternative (Closes: #645844)
* Bump to Standards-Version 3.9.4, no changes needed
* Suitesparse_config_Makefile.diff: new patch, creates a PIC version
of the (small) config code, for embedding in other shared libs
* KLU_Demo_Makefile.diff: new patch, needed for creating the right
dependencies between shared libraries
* Create a new shared library package for SPQR (Closes: #589296)
* Update README.Debian
2012-11-06 - Sebastien Bacher <seb128@ubuntu.com>
suitesparse (1:3.4.0-3ubuntu1) raring; urgency=low
* Resynchronize on Debian, remaining change
* Demote libatlas-doc from Recommends to Suggests, as it is not in main.
2012-08-04 - Evgeni Golov <evgeni@debian.org>
suitesparse (1:3.4.0-3) unstable; urgency=low
* Team upload.
[ Sylvestre Ledru ]
* Standard-Version updated to 3.9.3 (no changes requiered)
[ Evgeni Golov ]
* [f782819] Add -g to CFLAGS. (Closes: #682177)
* [d43b31b] Honour CFLAGS in debian/patches/09-CSparse_Lib_Makefile.diff
[ Anton Gladky ]
* [3a0e1c1] Move repository into debian-science.

See Also

Package Description
libburn-dev_1.3.4-0ubuntu1_i386.deb development package for libburn4
libburn-doc_1.3.4-0ubuntu1_all.deb API documentation for libburn library
libburn4_1.3.4-0ubuntu1_i386.deb library to provide CD/DVD writing functions
libbusiness-isbn-data-perl_20120719.001-1_all.deb data pack for Business::ISBN
libbusiness-isbn-perl_2.07-1_all.deb Perl library to work with International Standard Book Numbers
libbz2-1.0_1.0.6-5_i386.deb high-quality block-sorting file compressor library - runtime
libbz2-dev_1.0.6-5_i386.deb high-quality block-sorting file compressor library - development
libc-ares-dev_1.10.0-2_i386.deb asynchronous name resolver - development files
libc-ares2_1.10.0-2_i386.deb asynchronous name resolver
libc-bin_2.19-0ubuntu6_i386.deb Embedded GNU C Library: Binaries
libc-dev-bin_2.19-0ubuntu6_i386.deb Embedded GNU C Library: Development binaries
libc6-amd64_2.19-0ubuntu6_i386.deb Embedded GNU C Library: 64bit Shared libraries for AMD64
libc6-arm64-cross_2.19-0ubuntu2cross0.10_all.deb Embedded GNU C Library: Shared libraries (for cross-compiling)
libc6-armel-armhf-cross_2.19-0ubuntu2cross1.104_all.deb Dummy package to get libc6:armel installed
libc6-armel-cross_2.19-0ubuntu2cross1.104_all.deb Embedded GNU C Library: Shared libraries (for cross-compiling)
Advertisement
Advertisement