crossbuild-essential-powerpc_11.6ubuntu6_all.deb


Advertisement

Description

crossbuild-essential-powerpc - Informational list of cross-build-essential packages

Property Value
Distribution Ubuntu 14.04 LTS (Trusty Tahr)
Repository Ubuntu Main i386
Package filename crossbuild-essential-powerpc_11.6ubuntu6_all.deb
Package name crossbuild-essential-powerpc
Package version 11.6ubuntu6
Package release -
Package architecture all
Package type deb
Category devel
Homepage -
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 4.33 KB
Installed size 37.00 KB
If you do not plan to cross build Debian packages, you don't need
this package.  Starting with sbuild (>= 0.63.0) this package is
required for cross building Debian packages in a chroot.
This package contains an informational list of packages which are
considered essential for cross building Debian packages.  This
package also depends on the packages on that list, to make it easy to
have the cross-build-essential packages installed.
If you have this package installed, you only need to install whatever
a package specifies as its build-time dependencies to cross build the
package.  Conversely, if you are determining what your package needs
to build-depend on, you can always leave out the packages this
package depends on.

Alternatives

Package Version Architecture Repository
crossbuild-essential-powerpc_11.6ubuntu6_all.deb 11.6ubuntu6 all Ubuntu Main
crossbuild-essential-powerpc - - -

Requires

Name Value
dpkg-cross -
g++-powerpc-linux-gnu >= 4.7.2-3
gcc-powerpc-linux-gnu >= 4.7.2-3
libc6-dev:powerpc -
pkg-config-powerpc-linux-gnu -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package crossbuild-essential-powerpc_11.6ubuntu6_all.deb
Source Package build-essential

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install crossbuild-essential-powerpc deb package:
    # sudo apt-get install crossbuild-essential-powerpc

Files

Path
/usr/share/crossbuild-essential-powerpc/list
/usr/share/doc/crossbuild-essential-powerpc/changelog.gz
/usr/share/doc/crossbuild-essential-powerpc/copyright
/usr/share/doc/crossbuild-essential-powerpc/list

Changelog

2013-11-26 - Matthias Klose <doko@ubuntu.com>
build-essential (11.6ubuntu6) trusty; urgency=low
* Update package lists.
2013-08-06 - Matthias Klose <doko@ubuntu.com>
build-essential (11.6ubuntu5) saucy; urgency=low
* Add package list for AArch64.
2013-01-12 - Adam Conrad <adconrad@ubuntu.com>
build-essential (11.6ubuntu4) raring; urgency=low
* Remove pkgbinarymangler from list.cross, it's not build-essential
for native builds, so it's not build-essential for cross either.
2013-01-08 - Matthias Klose <doko@ubuntu.com>
build-essential (11.6ubuntu3) raring; urgency=low
* Build-depend on python3:any instead of python3.
2013-01-08 - Matthias Klose <doko@ubuntu.com>
build-essential (11.6ubuntu2) raring; urgency=low
* Regenerate the control file.
2013-01-08 - Matthias Klose <doko@ubuntu.com>
build-essential (11.6ubuntu1) raring; urgency=low
* Merge with Debian; remaining changes:
- Build cross packages for arm64, armhf and powerpc.
- Add pkgbinarymangler to the list of essential cross packages.
* Update essential packages lists (Ubuntu archs only).
2013-01-08 - Matthias Klose <doko@debian.org>
build-essential (11.6) unstable; urgency=low
* Update Standards-Version to 3.9.4.
* Build-depend on python3 instead of python.
* Update make-esslist.sh to consider ports archives and distros.
Closes: #603386.
* Update essential packages lists.
* Build crossbuild-essential-<arch> packages for architectures
provided in debian/cross-targets (currently all commented out).
Closes: #693220.
2012-12-05 - Colin Watson <cjwatson@ubuntu.com>
build-essential (11.5ubuntu4) raring; urgency=low
* make-esslist.sh: Manually add armhf, since it isn't in
/usr/share/dpkg/archtable.
* Run make-esslist.sh, adding libc-bin and removing python-minimal.
2012-07-08 - Adam Conrad <adconrad@ubuntu.com>
build-essential (11.5ubuntu3) quantal; urgency=low
* Revert the previous change, build-essential shouldn't be foreign.
2011-11-05 - Steve Langasek <steve.langasek@ubuntu.com>
build-essential (11.5ubuntu2) precise; urgency=low
* Mark build-essential Multi-Arch: foreign.

See Also

Package Description
crossbuild-essential-ppc64el_11.6ubuntu6_all.deb Informational list of cross-build-essential packages
cryptsetup-bin_1.6.1-1ubuntu1_i386.deb disk encryption support - command line tools
cryptsetup_1.6.1-1ubuntu1_i386.deb disk encryption support - startup scripts
cu_1.07-20.1_i386.deb call up another system
culmus_0.130-1_all.deb TrueType and Type1 Hebrew Fonts for X11
cup_0.11a+20060608-3build1_all.deb LALR parser generator for Java(tm)
cups-browsed_1.0.52-0ubuntu1_i386.deb OpenPrinting CUPS Filters - cups-browsed
cups-bsd_1.7.2-0ubuntu1_i386.deb Common UNIX Printing System(tm) - BSD commands
cups-client_1.7.2-0ubuntu1_i386.deb Common UNIX Printing System(tm) - client programs (SysV)
cups-common_1.7.2-0ubuntu1_all.deb Common UNIX Printing System(tm) - common files
cups-core-drivers_1.7.2-0ubuntu1_i386.deb Common UNIX Printing System(tm) - PPD-less printing
cups-daemon_1.7.2-0ubuntu1_i386.deb Common UNIX Printing System(tm) - daemon
cups-driver-gutenprint_5.2.10~pre2-0ubuntu2_all.deb transitional dummy package for gutenprint printer driver
cups-filters-core-drivers_1.0.52-0ubuntu1_i386.deb OpenPrinting CUPS Filters - PPD-less printing
cups-filters_1.0.52-0ubuntu1_i386.deb OpenPrinting CUPS Filters - Main Package
Advertisement
Advertisement