auth-client-config_0.9ubuntu1_all.deb


Advertisement

Description

auth-client-config - pam and NSS profile switcher

Property Value
Distribution Ubuntu 14.04 LTS (Trusty Tahr)
Repository Ubuntu Main i386
Package filename auth-client-config_0.9ubuntu1_all.deb
Package name auth-client-config
Package version 0.9ubuntu1
Package release -
Package architecture all
Package type deb
Category admin
Homepage -
License -
Maintainer Jamie Strandboge <jamie@ubuntu.com>
Download size 15.04 KB
Installed size 99.00 KB
Script for modifying nsswitch.conf and pam configuration using a database of
predefined configurations. Its intended use is to enable easier configuration
of network authentication and authorization (such as LDAP and Kerberos).

Alternatives

Package Version Architecture Repository
auth-client-config_0.9ubuntu1_all.deb 0.9ubuntu1 all Ubuntu Main
auth-client-config - - -

Requires

Name Value
python -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package auth-client-config_0.9ubuntu1_all.deb
Source Package auth-client-config

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install auth-client-config deb package:
    # sudo apt-get install auth-client-config

Files

Path
/etc/auth-client-config/profile.d/acc-cracklib
/etc/auth-client-config/profile.d/acc-default
/usr/sbin/auth-client-config
/usr/share/doc/auth-client-config/README
/usr/share/doc/auth-client-config/changelog.gz
/usr/share/doc/auth-client-config/copyright
/usr/share/man/man8/auth-client-config.8.gz

Changelog

2011-12-17 - Matthias Klose <doko@ubuntu.com>
auth-client-config (0.9ubuntu1) precise; urgency=low
* Build using dh_python2. LP: #904248.
2008-07-11 - Jamie Strandboge <jamie@ubuntu.com>
auth-client-config (0.9) intrepid; urgency=low
* update acc-default kerberos_example so it works better with kerberos
principals that have a local account with the same name. Thanks to
Adam Sommer and Steve Langasek.
* update ldap_example profile comments to mention that libpam-cracklib is
required
* update auth-client config to comment out sentinels required by Debian
and Ubuntu's pam-auth-update (LP: #270328)
* add tests for pam-auth-update specific tests
2008-06-13 - Jamie Strandboge <jamie@ubuntu.com>
auth-client-config (0.8) intrepid; urgency=low
* allow for comma separated lists of types with '-t'
* bump version
2008-03-11 - Jamie Strandboge <jamie@ubuntu.com>
auth-client-config (0.7) intrepid; urgency=low
* update cracklib profile to use pam_smbpass.so (LP: #208419)
* remove debconf dependency and usage (will add it back when needed)
* added NSS netgroup support (LP: #179919)
* bump version
2008-02-21 - Jamie Strandboge <jamie@ubuntu.com>
auth-client-config (0.6) hardy; urgency=low
* use use RawConfigParser instead of SafeConfigParser (LP: #191990)
* update acc-default comments (LP: #191990)
* make more PEP-8 compliant (whitespace)
* debian/rules: update version with changelog version
* debian/control: use Vcs-Bzr url
* lintian fixes
2008-01-17 - Jamie Strandboge <jamie@ubuntu.com>
auth-client-config (0.5) hardy; urgency=low
* new upstream release
- adds cracklib profile
- don't error out if other PAM entries don't exist, but this one does
* debian/control: Suggests libpam-cracklib
2007-08-13 - James D Strandboge <jamie@anemonecomputing.com>
auth-client-config (0.4-0ubuntu1) gutsy; urgency=low
* new upstream release 
* move sed to Build-Depends-Indep
* backported fix for building as root user from 0.4.1
2007-08-05 - James D Strandboge <jamie@anemonecomputing.com>
auth-client-config (0.3-0ubuntu1) gutsy; urgency=low
* new upstream release 
* debian/rules: use run_tests.sh
* debian/control: adjust XS-Python-Version to be >= 2.3
* debian/control: Build-Depends on sed
2007-08-01 - Jamie Strandboge <jamie@strandboge.com>
auth-client-config (0.2-0ubuntu1) gutsy; urgency=low
* initial release

See Also

Package Description
authbind_2.1.1_i386.deb Allows non-root programs to bind() to low ports
autoconf-doc_2.69-6_all.deb automatic configure script builder documentation
autoconf2.13_2.13-62_all.deb automatic configure script builder (obsolete version)
autoconf2.64_2.64-3_all.deb automatic configure script builder (obsolete version)
autoconf_2.69-6_all.deb automatic configure script builder
autofs5_5.0.7-3ubuntu3_all.deb transitional dummy package for 'autofs'
autofs_5.0.7-3ubuntu3_i386.deb kernel-based automounter for Linux
autogen_5.18-2ubuntu2_i386.deb automated text file generator
automake1.10_1.10.3-3.1ubuntu1_all.deb Tool for generating GNU Standards-compliant Makefiles
automake1.11_1.11.6-2_all.deb Tool for generating GNU Standards-compliant Makefiles
automake1.4_1.4-p6-13.1_all.deb A tool for generating GNU Standards-compliant Makefiles
automake1.9_1.9.6+nogfdl-4ubuntu1_all.deb A tool for generating GNU Standards-compliant Makefiles
automake_1.14.1-2ubuntu1_all.deb Tool for generating GNU Standards-compliant Makefiles
automoc_1.0~version-0.9.88-5build1_i386.deb automatic moc for Qt 4 packages
autopkgtest_2.14.1_all.deb automatic as-installed testing for Debian packages
Advertisement
Advertisement