libqtwebkit4_2.3.2-0ubuntu7_amd64.deb


Advertisement

Description

libqtwebkit4 - Web content engine library for Qt

Property Value
Distribution Ubuntu 14.04 LTS (Trusty Tahr)
Repository Ubuntu Main amd64
Package filename libqtwebkit4_2.3.2-0ubuntu7_amd64.deb
Package name libqtwebkit4
Package version 2.3.2
Package release 0ubuntu7
Package architecture amd64
Package type deb
Category libs
Homepage http://trac.webkit.org/wiki/QtWebKit
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 8.16 MB
Installed size 33.92 MB
QtWebKit provides a Web browser engine that makes it easy to embed content
from the World Wide Web into your Qt application.

Alternatives

Package Version Architecture Repository
libqtwebkit4_2.3.2-0ubuntu7_i386.deb 2.3.2 i386 Ubuntu Main
libqtwebkit4 - - -

Requires

Name Value
libc6 >= 2.14
libfontconfig1 >= 2.9.0
libgcc1 >= 1:4.1.1
libgl1 -
libgl1-mesa-glx -
libglib2.0-0 >= 2.37.3
libgstreamer-plugins-base1.0-0 >= 1.0.0
libgstreamer1.0-0 >= 1.0.0
libjpeg8 >= 8c
libpng12-0 >= 1.2.13-4
libqt4-network >= 4:4.7.0~beta1
libqt4-opengl >= 4:4.5.3
libqtcore4 >= 4:4.8.4
libqtgui4 >= 4:4.8.0
libsqlite3-0 >= 3.5.9
libstdc++6 >= 4.2.1
libx11-6 -
libxml2 >= 2.7.4
libxrender1 -
libxslt1.1 >= 1.1.25
multiarch-support -
zlib1g >= 1:1.2.0

Replaces

Name Value
libqt4-webkit <= 4:4.7.0~beta1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libqtwebkit4_2.3.2-0ubuntu7_amd64.deb
Source Package qtwebkit-source

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libqtwebkit4 deb package:
    # sudo apt-get install libqtwebkit4

Files

Path
/usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
/usr/lib/x86_64-linux-gnu/libQtWebKit.so.4.10
/usr/lib/x86_64-linux-gnu/libQtWebKit.so.4.10.2
/usr/share/doc/libqtwebkit4/changelog.Debian.gz
/usr/share/doc/libqtwebkit4/copyright

Changelog

2014-04-09 - Jonathan Riddell <jriddell@ubuntu.com>
qtwebkit-source (2.3.2-0ubuntu7) trusty; urgency=medium
* Add gstreamer 1.0 patches borrowed from SUSE with thanks:
- kubuntu_MediaPlayerPrivateGStreamer-should-take-ownership-of-the-playbin.patch
- kubuntu_buffer-ranges.patch
2014-03-27 - Jonathan Riddell <jriddell@ubuntu.com>
qtwebkit-source (2.3.2-0ubuntu6) trusty; urgency=medium
* Update kubuntu_gstreamer-1.0.diff to fix build failure on i386
2014-03-24 - Jonathan Riddell <jriddell@ubuntu.com>
qtwebkit-source (2.3.2-0ubuntu5) trusty; urgency=medium
* Add kubuntu_gstreamer-1.0.diff borrowed from SuSE to use GStreamer 1.0
2013-12-24 - Dimitri John Ledkov <xnox@ubuntu.com>
qtwebkit-source (2.3.2-0ubuntu4) trusty; urgency=medium
* Apply (adapted) patch from upstream qt/webkit/ANGLE to fix ANGLE FTBFS
with bison 3.0.
2013-10-13 - Colin Watson <cjwatson@ubuntu.com>
qtwebkit-source (2.3.2-0ubuntu3) saucy; urgency=low
* Add basic AArch64 support, based on
https://bugs.webkit.org/show_bug.cgi?id=116030 by Andreas Schwab.
2013-10-10 - Jonathan Riddell <jriddell@ubuntu.com>
qtwebkit-source (2.3.2-0ubuntu2) saucy; urgency=low
* Set WTF_USE_3D_GRAPHICS=0 on ARM, fix compile
2013-07-31 - Jonathan Riddell <jriddell@ubuntu.com>
qtwebkit-source (2.3.2-0ubuntu1) saucy; urgency=low
* New upstream release LP: #1202425
2013-06-25 - Jonathan Riddell <jriddell@ubuntu.com>
qtwebkit-source (2.3.1-0ubuntu4) saucy; urgency=low
* Use g++ 4.7 on ARM
2013-06-15 - Dmitry Shachnev <mitya57@ubuntu.com>
qtwebkit-source (2.3.1-0ubuntu3) saucy; urgency=low
* Do not hardcode wrong .so version name when creating a symlink,
instead use a symlink provided by upstream build (LP: #1191286).
2013-06-15 - Philip Muškovac <yofel@kubuntu.org>
qtwebkit-source (2.3.1-0ubuntu2) saucy; urgency=low
* Fix libQtWebkit.so symlink to point to the correct lib version

See Also

Package Description
libqtxml4-perl_4.13.0-0ubuntu1_amd64.deb perl bindings for the Qt Xml library
libqtxmlpatterns4-perl_4.13.0-0ubuntu1_amd64.deb perl bindings for the Qt XMLPatterns library
libquadmath0_4.8.2-19ubuntu1_amd64.deb GCC Quad-Precision Math Library
libquorum-dev_2.3.3-1ubuntu1_amd64.deb Standards-based cluster framework, Quorum devel files
libquorum5_2.3.3-1ubuntu1_amd64.deb Standards-based cluster framework, Quorum library
librabbitmq-dev_0.4.1-1_amd64.deb AMQP client library written in C - Dev Files
librabbitmq1_0.4.1-1_amd64.deb AMQP client library written in C
librados-dev_0.79-0ubuntu1_amd64.deb RADOS distributed object store client library (development files)
librados2_0.79-0ubuntu1_amd64.deb RADOS distributed object store client library
libraptor1-dev_1.4.21-10_amd64.deb Raptor RDF parser and serializer development libraries and headers
libraptor1-doc_1.4.21-10_all.deb Documentation for the Raptor RDF parser and serializer library
libraptor1_1.4.21-10_amd64.deb Raptor RDF parser and serializer library
libraptor2-0_2.0.13-1_amd64.deb Raptor 2 RDF syntax library
libraptor2-dev_2.0.13-1_amd64.deb Raptor 2 RDF syntax library development libraries and headers
libraptor2-doc_2.0.13-1_all.deb Documentation for the Raptor 2 RDF syntax library
Advertisement
Advertisement