libboost-thread-dev_1.54.0.1ubuntu1_amd64.deb


Advertisement

Description

libboost-thread-dev - portable C++ multi-threading (default version)

Property Value
Distribution Ubuntu 14.04 LTS (Trusty Tahr)
Repository Ubuntu Main amd64
Package filename libboost-thread-dev_1.54.0.1ubuntu1_amd64.deb
Package name libboost-thread-dev
Package version 1.54.0.1ubuntu1
Package release -
Package architecture amd64
Package type deb
Category libdevel
Homepage http://www.boost.org/libs/thread/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 2.78 KB
Installed size 26.00 KB
This package forms part of the Boost C++ Libraries collection.
Toolkit for writing C++ programs that execute as multiple,
asynchronous, independent, threads-of-execution. Each thread has its
own machine state including program instruction counter and
registers.
This package is a dependency package, which depends on Debian's default
Boost version (currently 1.54).

Alternatives

Package Version Architecture Repository
libboost-thread-dev_1.54.0.1ubuntu1_i386.deb 1.54.0.1ubuntu1 i386 Ubuntu Main
libboost-thread-dev - - -

Requires

Name Value
libboost-thread1.54-dev -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libboost-thread-dev_1.54.0.1ubuntu1_amd64.deb
Source Package boost-defaults

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libboost-thread-dev deb package:
    # sudo apt-get install libboost-thread-dev

Files

Path
/usr/share/doc/libboost-thread-dev/changelog.gz
/usr/share/doc/libboost-thread-dev/copyright

See Also

Package Description
libboost-thread1.54-dev_1.54.0-4ubuntu3_amd64.deb portable C++ multi-threading
libboost-thread1.54.0_1.54.0-4ubuntu3_amd64.deb portable C++ multi-threading
libboost1.54-dev_1.54.0-4ubuntu3_amd64.deb Boost C++ Libraries development files
libboost1.54-doc_1.54.0-4ubuntu3_all.deb Boost.org libraries documentation
libboost1.54-tools-dev_1.54.0-4ubuntu3_amd64.deb Boost C++ Libraries development tools
libbrasero-media3-1_3.10.0-0ubuntu1_amd64.deb CD/DVD burning library for GNOME - runtime
libbrasero-media3-dev_3.10.0-0ubuntu1_amd64.deb CD/DVD burning library for GNOME - development
libbrlapi-dev_5.0-2ubuntu2_amd64.deb Library for communication with BRLTTY - static libs and headers
libbrlapi0.6_5.0-2ubuntu2_amd64.deb braille display access via BRLTTY - shared library
libbsd-dev_0.6.0-2ubuntu1_amd64.deb utility functions from BSD systems - development files
libbsd-resource-perl_1.2907-1build1_amd64.deb BSD process resource limit and priority functions
libbsd0_0.6.0-2ubuntu1_amd64.deb utility functions from BSD systems - shared library
libbsf-java-doc_2.4.0-5build1_all.deb Bean Scripting Framework to support scripting - documentation
libbsf-java_2.4.0-5build1_all.deb Bean Scripting Framework to support scripting languages in Java
libbsh-java_2.0b4-15_all.deb Java scripting environment (BeanShell) Version 2 (library)
Advertisement
Advertisement