gir1.2-gusb-1.0_0.1.6-5_amd64.deb


Advertisement

Description

gir1.2-gusb-1.0 - GObject introspection data for libgusb

Property Value
Distribution Ubuntu 14.04 LTS (Trusty Tahr)
Repository Ubuntu Main amd64
Package filename gir1.2-gusb-1.0_0.1.6-5_amd64.deb
Package name gir1.2-gusb-1.0
Package version 0.1.6
Package release 5
Package architecture amd64
Package type deb
Category introspection
Homepage http://www.hughski.com/downloads.html
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 4.29 KB
Installed size 46.00 KB
This package contains the introspection data for GUsb.
It can be used by packages using the GIRepository format to generate
dynamic bindings.

Alternatives

Package Version Architecture Repository
gir1.2-gusb-1.0_0.1.6-5_i386.deb 0.1.6 i386 Ubuntu Main
gir1.2-gusb-1.0 - - -

Requires

Name Value
gir1.2-glib-2.0 -
libgusb2 >= 0.1.5

Download

Type URL
Mirror archive.ubuntu.com
Binary Package gir1.2-gusb-1.0_0.1.6-5_amd64.deb
Source Package libgusb

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gir1.2-gusb-1.0 deb package:
    # sudo apt-get install gir1.2-gusb-1.0

Files

Path
/usr/lib/girepository-1.0/GUsb-1.0.typelib
/usr/share/doc/gir1.2-gusb-1.0/changelog.Debian.gz
/usr/share/doc/gir1.2-gusb-1.0/copyright

Changelog

2014-01-27 - Michal Čihař <nijel@debian.org>
libgusb (0.1.6-5) unstable; urgency=medium
* Miscellaneous fixes from Ubuntu (Closes: #736827):
* Build-depend on valac (>= 0.20), not valac-0.20.
* Install typelib to /usr/lib as expected, not to the multiarch dir.
* Keep libgusb2.symbols at version 0.1.5 for compatibility with
existing Ubuntu builds.
* Call dh --with gir.
2014-01-20 - Michal Čihař <nijel@debian.org>
libgusb (0.1.6-4) unstable; urgency=medium
* Use dh-autoreconf for newer libtool.
2014-01-20 - Michal Čihař <nijel@debian.org>
libgusb (0.1.6-3) unstable; urgency=medium
* Bump standards to 3.9.5.
* Use debhelper 9.
* Use canonical VCS URLs in debian/control.
* Enable multiarch support.
2013-05-17 - Michal Čihař <nijel@debian.org>
libgusb (0.1.6-2) unstable; urgency=low
* Build with valac-0.20 (Closes: #707465).
2013-05-07 - Michal Čihař <nijel@debian.org>
libgusb (0.1.6-1) unstable; urgency=low
* Update to unstable.
2013-03-08 - Andreas Henriksson <andreas@fatal.se>
libgusb (0.1.6-0.1) experimental; urgency=low
* Non maintainer upload with maintainer approval
* Imported Upstream version 0.1.6 (Closes: #699941)
* Update build-dependencies according to configure.ac
- added libglib2.0-dev, gobject-introspection and valac
* Add GObject introspection package gir1.2-gusb-1.0
* Install Vala API (vapi) in libgusb-dev package
* libgusb2.symbols: update for added symbols
2012-06-25 - Michal Čihař <nijel@debian.org>
libgusb (0.1.3-5) unstable; urgency=low
* Fix upstream homepage link.
2012-05-14 - Michal Čihař <nijel@debian.org>
libgusb (0.1.3-4) unstable; urgency=low
* Improve package description (Closes: #668043).
* Adjust debian/copyright to final version of DEP-5.
* Bump standards to 3.9.3.
2012-01-04 - Michal Čihař <nijel@debian.org>
libgusb (0.1.3-3) unstable; urgency=low
* Add missing dependencies to devel package.
2012-01-04 - Michal Čihař <nijel@debian.org>
libgusb (0.1.3-2) unstable; urgency=low
* Disable tests completely, they need USB access and it fails on most
buildds.

See Also

Package Description
gir1.2-gweather-3.0_3.10.2-0ubuntu1_amd64.deb GObject introspection data for the GWeather library
gir1.2-gxps-0.1_0.2.2-2ubuntu2_amd64.deb GObject introspection data for the gxps library
gir1.2-harfbuzz-0.0_0.9.27-1_amd64.deb OpenType text shaping engine (GObject introspection data)
gir1.2-hud-2_13.10.1+14.04.20140402-0ubuntu1_amd64.deb typelib file for libhud2
gir1.2-hud-client-2_13.10.1+14.04.20140402-0ubuntu1_amd64.deb typelib file for libhud-client-2
gir1.2-ibus-1.0_1.5.5-1ubuntu3_amd64.deb Intelligent Input Bus - introspection data
gir1.2-ido3-0.1_13.10.0+14.04.20140407-0ubuntu1_amd64.deb Typelib file for libido3-0.1
gir1.2-javascriptcoregtk-1.0_2.4.0-1ubuntu2_amd64.deb JavaScript engine library from WebKitGTK+ - GObject introspection data
gir1.2-javascriptcoregtk-3.0_2.4.0-1ubuntu2_amd64.deb JavaScript engine library from WebKitGTK+ - GObject introspection data
gir1.2-json-1.0_0.16.2-1ubuntu1_amd64.deb GLib JSON manipulation library (introspection data)
gir1.2-langtag-0.5_0.5.1-2_amd64.deb library to access tags for identifying languages - introspection
gir1.2-lightdm-1_1.10.0-0ubuntu3_amd64.deb Typelib file for liblightdm-1
gir1.2-messagingmenu-1.0_13.10.1+14.04.20140410-0ubuntu1_amd64.deb Messaging Menu - gir bindings
gir1.2-mx-1.0_1.4.7-0ubuntu3_amd64.deb GObject introspection data for the libmx library
gir1.2-nautilus-3.0_3.10.1-0ubuntu8_amd64.deb libraries for nautilus components - gir bindings
Advertisement
Advertisement