rpm_4.9.1.1-1ubuntu0.3_amd64.deb


Advertisement

Description

rpm - package manager for RPM

Property Value
Distribution Ubuntu 12.04 LTS (Precise Pangolin)
Repository Ubuntu Updates Main amd64
Package name rpm
Package version 4.9.1.1
Package release 1ubuntu0.3
Package architecture amd64
Package type deb
Installed size 448 B
Download size 153.44 KB
Official Mirror archive.ubuntu.com
The RPM Package Manager (RPM) is a command-line driven package
management system capable of installing, uninstalling, verifying,
querying, and updating computer software packages.
On Debian and derived systems it is recommended to use "alien" to
convert RPM packages into .deb format instead of bypassing the Debian
package management system by installing them directly with rpm.

Alternatives

Package Version Architecture Repository
rpm_4.9.1.1-1ubuntu0.3_i386.deb 4.9.1.1 i386 Ubuntu Updates Main
rpm_4.9.1.1-1build1_i386.deb 4.9.1.1 i386 Ubuntu Main
rpm_4.9.1.1-1build1_amd64.deb 4.9.1.1 amd64 Ubuntu Main
rpm - - -

Requires

Name Value
libc6 >= 2.14
libelf1 >= 0.131
libpopt0 >= 1.14
librpm2 >= 4.9.0
librpmbuild2 >= 4.9.0
librpmio2 >= 4.9.0
librpmsign0 >= 4.9.0
perl -
rpm-common = 4.9.1.1-1ubuntu0.3
rpm2cpio -

Replaces

Name Value
manpages-pl << 20051017-1

Download

Type URL
Binary Package rpm_4.9.1.1-1ubuntu0.3_amd64.deb
Source Package rpm

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install rpm deb package:
    # sudo apt-get install rpm

Files

Path
/usr/bin/gendiff
/usr/bin/rpm
/usr/bin/rpmbuild
/usr/bin/rpmdb
/usr/bin/rpmgraph
/usr/bin/rpmkeys
/usr/bin/rpmquery
/usr/bin/rpmsign
/usr/bin/rpmspec
/usr/bin/rpmverify
/usr/lib/rpm/brp-compress
/usr/lib/rpm/brp-java-gcjcompile
/usr/lib/rpm/brp-python-bytecompile
/usr/lib/rpm/brp-python-hardlink
/usr/lib/rpm/brp-strip
/usr/lib/rpm/brp-strip-comment-note
/usr/lib/rpm/brp-strip-shared
/usr/lib/rpm/brp-strip-static-archive
/usr/lib/rpm/check-buildroot
/usr/lib/rpm/check-files
/usr/lib/rpm/check-prereqs
/usr/lib/rpm/check-rpaths
/usr/lib/rpm/check-rpaths-worker
/usr/lib/rpm/debugedit
/usr/lib/rpm/desktop-file.prov
/usr/lib/rpm/elfdeps
/usr/lib/rpm/find-debuginfo.sh
/usr/lib/rpm/find-lang.sh
/usr/lib/rpm/find-provides
/usr/lib/rpm/find-requires
/usr/lib/rpm/fontconfig.prov
/usr/lib/rpm/javadeps
/usr/lib/rpm/libtooldeps.sh
/usr/lib/rpm/mkinstalldirs
/usr/lib/rpm/mono-find-provides
/usr/lib/rpm/mono-find-requires
/usr/lib/rpm/ocaml-find-provides.sh
/usr/lib/rpm/ocaml-find-requires.sh
/usr/lib/rpm/osgideps.pl
/usr/lib/rpm/perl.prov
/usr/lib/rpm/perl.req
/usr/lib/rpm/perldeps.pl
/usr/lib/rpm/pkgconfigdeps.sh
/usr/lib/rpm/pythondeps.sh
/usr/lib/rpm/rpm.daily
/usr/lib/rpm/rpm2cpio.sh
/usr/lib/rpm/rpmdb_loadcvt
/usr/lib/rpm/rpmdeps
/usr/lib/rpm/rpmpopt-4.9.1.1
/usr/lib/rpm/script.req
/usr/lib/rpm/tcl.req
/usr/lib/rpm/tgpg
/usr/lib/rpm/fileattrs/desktop.attr
/usr/lib/rpm/fileattrs/elf.attr
/usr/lib/rpm/fileattrs/font.attr
/usr/lib/rpm/fileattrs/libtool.attr
/usr/lib/rpm/fileattrs/mono.attr
/usr/lib/rpm/fileattrs/ocaml.attr
/usr/lib/rpm/fileattrs/perl.attr
/usr/lib/rpm/fileattrs/perllib.attr
/usr/lib/rpm/fileattrs/pkgconfig.attr
/usr/lib/rpm/fileattrs/python.attr
/usr/lib/rpm/fileattrs/script.attr
/usr/share/doc/rpm/CREDITS
/usr/share/doc/rpm/GROUPS
/usr/share/doc/rpm/NEWS.Debian.gz
/usr/share/doc/rpm/README
/usr/share/doc/rpm/README.Debian
/usr/share/doc/rpm/builddependencies.gz
/usr/share/doc/rpm/buildroot
/usr/share/doc/rpm/changelog.Debian.gz
/usr/share/doc/rpm/conditionalbuilds
/usr/share/doc/rpm/copyright
/usr/share/doc/rpm/dependencies.gz
/usr/share/doc/rpm/format.gz
/usr/share/doc/rpm/hregions
/usr/share/doc/rpm/macros.gz
/usr/share/doc/rpm/multiplebuilds
/usr/share/doc/rpm/queryformat.gz
/usr/share/doc/rpm/relocatable
/usr/share/doc/rpm/signatures
/usr/share/doc/rpm/spec.gz
/usr/share/doc/rpm/triggers.gz
/usr/share/doc/rpm/tsort.gz
/usr/share/man/man1/gendiff.1.gz
/usr/share/man/man8/rpm.8.gz
/usr/share/man/man8/rpmbuild.8.gz
/usr/share/man/man8/rpmdb.8.gz
/usr/share/man/man8/rpmdeps.8.gz
/usr/share/man/man8/rpme.8.gz
/usr/share/man/man8/rpmgraph.8.gz
/usr/share/man/man8/rpmi.8.gz
/usr/share/man/man8/rpmkeys.8.gz
/usr/share/man/man8/rpmquery.8.gz
/usr/share/man/man8/rpmsign.8.gz
/usr/share/man/man8/rpmspec.8.gz
/usr/share/man/man8/rpmu.8.gz
/usr/share/man/man8/rpmverify.8.gz

Changelog

2015-01-16 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
rpm (4.9.1.1-1ubuntu0.3) precise-security; urgency=medium
* SECURITY UPDATE: code execution via insecure temp file use
- debian/patches/CVE-2013-6435.patch: create file with proper
permissions in lib/fsm.c.
- CVE-2013-6435
2013-06-12 - Mark Russell <mark.russell@canonical.com>
rpm (4.9.1.1-1ubuntu0.2) precise; urgency=low
* Mark rpm2cpio Multi-Arch: foreign (LP: #1175687) 
2013-01-17 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
rpm (4.9.1.1-1ubuntu0.1) precise-security; urgency=low
* SECURITY UPDATE: denial of service and possible code execution via
crafted headers
- debian/patches/CVE-2011-3378.patch: properly validate values in
lib/header.c.
- CVE-2011-3378
* SECURITY UPDATE: denial of service and possible code execution via
invalid region tag
- debian/patches/CVE-2012-0060.patch: validate region tags in
lib/header.c, lib/package.c, lib/signature.c.
- CVE-2012-0060
* SECURITY UPDATE: denial of service and possible code execution via
large region size
- debian/patches/CVE-2012-0061.patch: check length in lib/header.c.
- CVE-2012-0061
* SECURITY UPDATE: denial of service and possible code execution via
negative value in region offset
- debian/patches/CVE-2012-0815.patch: properly handle negative values
in lib/header.c, lib/package.c, lib/signature.c.
- CVE-2012-0815
2011-11-02 - Colin Watson <cjwatson@ubuntu.com>
rpm (4.9.1.1-1build1) precise; urgency=low
* Rebuild for liblzma5.
2011-08-05 - Michal Čihař <nijel@debian.org>
rpm (4.9.1.1-1) unstable; urgency=low
* New upstream release.
* Rediff patches to match current code.
* Update symbols file.
* Do not list non linux archs in depends, use linux-any instead 
(Closes: #634373).
* Add s390x to symbols definition (Closes: #636519).
* Use dh-autoreconf instead of manually doing the same.
* Use autotools_dev dh sequence to update config.*.
2011-07-12 - Michal Čihař <nijel@debian.org>
rpm (4.9.0-7) unstable; urgency=low
* Remove useless .la files from python-rpm (Closes: #633267).
* Avoid linking python module with libpython (LP: #789656).
* Remove empty lines from debian/*.symbols, they cause warnings during
build.
2011-06-13 - Michal Čihař <nijel@debian.org>
rpm (4.9.0-6) unstable; urgency=low
* Add --fail-missing to debian/rules to catch non installed files.
* Include attributes definition files in rpm package (Closes: #630163).
* Include pkgconfig script in librpm-dev package.
* Include forgotten dependency generators in rpm package.
* Include rpm plugins in librpm2 package.
2011-05-21 - Michal Čihař <nijel@debian.org>
rpm (4.9.0-5) unstable; urgency=low
* Disable cap on non Linux arches in configure.
2011-05-21 - Michal Čihař <nijel@debian.org>
rpm (4.9.0-4) unstable; urgency=low
* Depend on libcap onl on linux-any.
* Change linux only build deps to linux-any instead of listing others.
2011-05-20 - Michal Čihař <nijel@debian.org>
rpm (4.9.0-3) unstable; urgency=low
* Build with file capability support (Closes: #625766).
* Bump standards to 3.9.2.
* Upload to unstable to bring libdb5.1 support there.

See Also

Package Description
rrdtool-tcl_1.4.7-1ubuntu1_amd64.deb time-series data storage and display system (Tcl interface)
rrdtool_1.4.7-1ubuntu1_amd64.deb time-series data storage and display system (programs)
rsync_3.0.9-1ubuntu1.1_amd64.deb fast, versatile, remote (and local) file-copying tool
rsyslog-doc_5.8.6-1ubuntu8.9_all.deb documentation for rsyslog
rsyslog_5.8.6-1ubuntu8.9_amd64.deb reliable system and kernel logging daemon
rtkit_0.10-2ubuntu0.12.04.1_amd64.deb Realtime Policy and Watchdog Daemon
ruby1.8-dev_1.8.7.352-2ubuntu1.6_amd64.deb Header files for compiling extension modules for the Ruby 1.8
ruby1.8-examples_1.8.7.352-2ubuntu1.6_all.deb Examples for Ruby 1.8
ruby1.8_1.8.7.352-2ubuntu1.6_amd64.deb Interpreter of object-oriented scripting language Ruby 1.8
ruby1.9.1-dev_1.9.3.0-1ubuntu2.10_amd64.deb Header files for compiling extension modules for the Ruby 1.9.1
ruby1.9.1-examples_1.9.3.0-1ubuntu2.10_all.deb Examples for Ruby 1.9
ruby1.9.1_1.9.3.0-1ubuntu2.10_amd64.deb Interpreter of object-oriented scripting language Ruby
rubygems-doc_1.8.15-1ubuntu0.1_all.deb Transitional package for rubygems
rubygems1.8_1.8.15-1ubuntu0.1_all.deb Transitional package for rubygems
rubygems_1.8.15-1ubuntu0.1_all.deb package management framework for Ruby libraries/applications
Advertisement
Advertisement