openbve_1.4.0.9-1_all.deb


Advertisement

Description

openbve - realistic 3D train/railway simulator (main program)

Property Value
Distribution Ubuntu 12.04 LTS (Precise Pangolin)
Repository Ubuntu Universe amd64
Package name openbve
Package version 1.4.0.9
Package release 1
Package architecture all
Package type deb
Installed size 1.17 KB
Download size 334.57 KB
Official Mirror archive.ubuntu.com
OpenBVE is a railway train-driving simulator with an emphasis on
in-cab driving, realistic physics, braking system and train safety
system modelling.
Technically, the simulator handles detailed per-car simulation of the
brake systems, friction, air resistance, toppling and more. In trains
supplied with 3D cabs, the driving experience is augmented with
forces that shake the driver's simulated body upon acceleration and
braking, as well as through curves.
Compared to other rail-based simulators, OpenBVE has its main focus on
realism---not necessarily on user-friendliness. There may be a need
to study operational manuals for the routes and trains chosen, rather
than merely memorising a few keystrokes.
The simulator is designed to be backwards-compatible with existing
'BVE Trainsim' routes and cab interiors, allowing a wide range of
existing scenarios to be loaded by a single-program (BVE1, BVE2,
BVE4 and extended OpenBVE route formats).
OpenBVE uses OpenGL for 3D graphics rendering, OpenAL for positional
surround sound, and is written in the C# language.  Note that binary
train extension plugins are not currently supported on Linux/Unix,
because these would require Win32 emulation.

Alternatives

Package Version Architecture Repository
openbve_1.4.0.9-1_all.deb 1.4.0.9 all Ubuntu Universe
openbve - - -

Requires

Name Value
libmono-corlib4.0-cil >= 2.10.1
libmono-i18n4.0-all -
libmono-system-drawing4.0-cil >= 1.0
libmono-system-windows-forms4.0-cil >= 1.0
libmono-system4.0-cil >= 2.10.7
libtaoframework-openal1.1-cil >= 2.1.svn20090801
libtaoframework-openal1.1-cil << 2.1.svn20090802
libtaoframework-opengl3.0-cil >= 2.1.svn20090801
libtaoframework-opengl3.0-cil << 2.1.svn20090802
libtaoframework-sdl1.2-cil << 2.1.svn20090802
libtaoframework-sdl1.2-cil >= 2.1.svn20090801
mono-runtime >= 2.10.1
openbve-data >= 1.4.0.0

Provides

Name Value
bve-engine -

Download

Type URL
Binary Package openbve_1.4.0.9-1_all.deb
Source Package openbve

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install openbve deb package:
    # sudo apt-get install openbve

Files

Path
/etc/openbve/filesystem.cfg
/usr/games/openbve
/usr/lib/openbve/OpenBve.exe
/usr/lib/openbve/OpenBveApi.dll
/usr/lib/openbve/Plugins/OpenBveAts.dll
/usr/lib/openbve/Plugins/Sound.Flac.dll
/usr/lib/openbve/Plugins/Sound.RiffWave.dll
/usr/lib/openbve/Plugins/Texture.Ace.dll
/usr/lib/openbve/Plugins/Texture.BmpGifJpegPngTiff.dll
/usr/share/applications/openbve.desktop
/usr/share/doc/openbve/NEWS.Debian.gz
/usr/share/doc/openbve/README.Debian.gz
/usr/share/doc/openbve/changelog.Debian.gz
/usr/share/doc/openbve/copyright
/usr/share/doc/openbve/credits.html
/usr/share/doc/openbve/releasenotes.html
/usr/share/doc/openbve/routes-and-trains.txt.gz
/usr/share/lintian/overrides/openbve
/usr/share/man/man6/openbve.6.gz
/usr/share/menu/openbve

Changelog

2012-02-08 - Paul Sladen <debian@paul.sladen.org>
openbve (1.4.0.9-1) unstable; urgency=low
* New upstream stable release (1.4.0.9)
2012-02-04 - Paul Sladen <debian@paul.sladen.org>
openbve (1.4.0.7-2) unstable; urgency=low
* debian/openbve.desktop: Add generic name, and [de] name (Closes: #657599)
* debian/openbve.desktop: Disable StartupNotify=false (Closes: #657599)
(Thanks to Ronny Standtke)
2012-02-04 - Paul Sladen <debian@paul.sladen.org>
openbve (1.4.0.7-1) unstable; urgency=low
* New upstream stable release (1.4.0.7)
* Delete extranous 'licence-background.txt' previously merged into
debian/copyright in commit 9ae7ec26.
* routes-and-trains.txt: refresh/cull list of third-party content websites
2012-01-21 - Paul Sladen <debian@paul.sladen.org>
openbve (1.4.0.5-1) unstable; urgency=low
* Openbve ITP (Closes: #522854)
* New upstream stable release (1.4.0.5)
2012-01-13 - Paul Sladen <debian@paul.sladen.org>
openbve (1.4.0.0-2) UNRELEASED; urgency=low
[Paul Sladen]
* Openbve ITP (Closes: #522854)
* debian/filesystem.cfg: use 'SpecialFolder.LocalApplicationData'
+ emulate behaviour until upstream allows LocalApplicationData
* debian/README.source: document 'mask.bin'
* debian/rules+control: convert to minimal debhelper 7 + bumps build-dep
* debian/rules: use --with=cli
+ restore '--exclude-moduleref=AtsPluginProxy.dll'
(removed >= 1.2.10.0-0ubuntu2) to stop errors
* Provide more context for licensing discussions with upstream
* Drop lynx dependency now that 'dh_installchangelogs' is used
* Merge 'known-issues.txt' into main 'README.Debian'
2012-01-11 - Iain Lane <laney@debian.org>
openbve (1.4.0.0-1) experimental; urgency=low
* Initial Debian upload
* New upstream stable release (1.4.0.0)
+ update upstream URL to 'trainsimframework.org/*'
+ credits file as part of docs too
+ update 'changelog.html' and 'credits.html'
+ install new modular plugins to '/usr/lib/openbve/Plugins'
+ bump openbve-data (>= 1.4.0.0) hard dependency
* debian/changelog: DEP5 and bump copyright to latest upstream wording
* debian/source/format: '3.0 (quilt)'
* debian/source/options: single-debian-patch
2011-10-29 - Alessandro Menti <alessandro.menti@hotmail.it>
openbve (1.2.10.0-0ubuntu3) precise; urgency=low
* debian/control: Add missing dependency (libmono-i18n4.0-all) and remove
dependency on libmono-i18n4.0-cil as the latter is a dependency of the
first. Thanks to Paul Childs for the fix and to Paul Sladen for finding a
dependency simplification. (LP: #877776)
Adding also ${misc:Depends} to the Depends field and bumping the
Standards-Version to 3.9.2 (current version).
* debian/rules: Add build-arch and build-indep recommended targets.
2011-07-02 - Jo Shields <directhex@apebox.org>
openbve (1.2.10.0-0ubuntu2) oneiric; urgency=low
* debian/rules: Skip AtsPluginProxy.dll modulrefs, these are Win32 only.
* openBVE/OpenBveApi/OpenBveApi.csproj,
openBVE/OpenBve/OpenBve.csproj: set TargetFrameworkVersion to v4.0.
* debian/control: Tweak dependencies and build-dependencies for 4.0.
2010-12-28 - Paul Sladen <ubuntu@paul.sladen.org>
openbve (1.2.10.0-0ubuntu1) natty; urgency=low
* New upstream stable version (1.2.10.0)
2010-12-24 - Arvind S Raj <sraj.arvind@gmail.com>
openbve (1.2.7.3-0ubuntu3) natty; urgency=low
* debian/control: Fixed typo in first line of third paragraph of
the package description-missing 's' in 'based' (LP: #628758)

See Also

Package Description
opencascade-draw_6.5.0.dfsg-2build1_amd64.deb OpenCASCADE CAE platform shared library
opencascade-examples_6.5.0.dfsg-2build1_all.deb OpenCASCADE CAE platform library input examples
opencc_0.3.0-1_amd64.deb simplified-traditional chinese conversion tool
openchangeclient_1.0-1_amd64.deb Command-line client for the MAPI (Exchange/Outlook) protocol
openchangeproxy_1.0-1_amd64.deb Experimental MAPI (Exchange/Outlook) proxy
openchangeserver-dev_1.0-1_amd64.deb Experimental MAPI (Exchange/Outlook) server - development files
openchangeserver_1.0-1_amd64.deb Experimental MAPI (Exchange/Outlook) server
opencity-data_0.0.6.4stable-1_all.deb data for opencity, a 3D city simulator game
opencity_0.0.6.4stable-1_amd64.deb 3D city simulator game
opencl-headers_1.1-2010.07.15-2_all.deb OpenCL (Open Computing Language) header files
openclipart-libreoffice_2.0-1ubuntu1_all.deb clip art for OpenOffice.org/LibreOffice gallery
openclipart-openoffice.org_3.3.0-7ubuntu7_all.deb clip art for OpenOffice.org/LibreOffice gallery
openclipart-png_2.0-1ubuntu1_all.deb clip art in PNG format
openclipart-svg_2.0-1ubuntu1_all.deb clip art in SVG format
openclipart_2.0-1ubuntu1_all.deb Open Clip Art Library
Advertisement
Advertisement