nvi - 4.4BSD re-implementation of vi

Distribution: Ubuntu 12.04 LTS (Precise Pangolin)
Repository: Ubuntu Universe amd64
Package name: nvi
Package version: 1.81.6
Package release: 8.2
Package architecture: amd64
Package type: deb
Installed size: 680 B
Download size: 270.41 KB
Official Mirror: archive.ubuntu.com
Vi is the original screen based text editor for Unix systems. It is considered the standard text editor, and is available on almost all Unix systems. Nvi is intended as a "bug-for-bug compatible" clone of the original BSD vi editor. As such, it doesn't have a lot of snazzy features as do some of the other vi clones such as elvis and vim. However, if all you want is vi, this is the one to get.



    Binary package: nvi_1.81.6-8.2_amd64.deb
    Source package: nvi

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install nvi deb package:
      # sudo apt-get install nvi


    • /etc/init.d/nviboot
    • /usr/bin/nex
    • /usr/bin/nvi
    • /usr/bin/nview
    • /usr/share/doc/nvi/FAQ.gz
    • /usr/share/doc/nvi/README.1st
    • /usr/share/doc/nvi/README.Debian
    • /usr/share/doc/nvi/README.gz
    • /usr/share/doc/nvi/TODO.gz
    • /usr/share/doc/nvi/changelog.Debian.gz
    • /usr/share/doc/nvi/changelog_stable.gz
    • /usr/share/doc/nvi/copyright
    • /usr/share/lintian/overrides/nvi
    • /usr/share/man/man1/nex.1.gz
    • /usr/share/man/man1/nvi.1.gz
    • /usr/share/man/man1/nview.1.gz
    • /usr/share/vi/recover
    • /usr/share/vi/catalog/dutch
    • /usr/share/vi/catalog/english
    • /usr/share/vi/catalog/french
    • /usr/share/vi/catalog/german
    • /usr/share/vi/catalog/ru_SU.KOI8-R
    • /usr/share/vi/catalog/spanish
    • /usr/share/vi/catalog/swedish


    2011-05-14 - Axel Beckert <abe@debian.org> nvi (1.81.6-8.2) unstable; urgency=low * Non-maintainer upload. * Build-depend on libdb-dev (Closes: #621381) * Bumped Standards-Version to 3.9.2 - Included full license texts in debian/copyright instead of refering to /usr/share/common-licenses/BSD (which is due to be removed from common-licenses) * Added a dependency on ${misc:Depends} to each binary to fix the lintian warning debhelper-but-no-misc-depends. * Added a README.source (based on dpatch's standard README.source) to fix the lintian warning patch-system-but-no-source-readme.

    2010-01-28 - Moritz Muehlenhoff <jmm@debian.org> nvi (1.81.6-8.1) unstable; urgency=medium * Non-maintainer upload. * Build-depend on libdb4.7-dev (Closes: #555933)

    2009-07-24 - Jan Christoph Nordholz <hesso@pool.math.tu-berlin.de> nvi (1.81.6-8) unstable; urgency=low * Fix generation of backup file names. Closes: #534732. * Bump Standards version to 3.8.2 (no changes). * Minor adjustments to make lintian's pedantic mode happier: * Remove redundant lines from d/control. * Add some patch descriptions. * Adjust packaging copyright year list.

    2009-06-05 - Jan Christoph Nordholz <hesso@pool.math.tu-berlin.de> nvi (1.81.6-7) unstable; urgency=low * Replace README.debian (which was until now duplicating copyright information) with a note regarding nvi's UTF support. Closes: #386590. * Fix regular expressions to be 8-bit clean again. Closes: #523934. * Bump standards version to 3.8.1 (no changes).

    2009-03-08 - Jan Christoph Nordholz <hesso@pool.math.tu-berlin.de> nvi (1.81.6-6) unstable; urgency=low * Fix {^A}. Thanks to Al Viro for his thorough analysis and immediate patch suggestion. Closes: #518397. * Fix pagesize argument passed to db__set_pagesize(). * Allow editing of 8-bit files even if LC_CTYPE is set to C. Closes: #496305. * Uncomment stable branch in watch file because DEHS will just report the version taken from the first line.

    2009-03-01 - Jan Christoph Nordholz <hesso@pool.math.tu-berlin.de> nvi (1.81.6-5) unstable; urgency=low * nvi no longer requires a specific libdb4 revision. To this end revive 03db4.dpatch and make a few adjustments. Closes: #490361. Stay at low urgency despite RC - I want proper testing for this widechar mess. * Start new patch 13widechar_horrors.dpatch and begin to fix all the places the widechar support hasn't reached yet or which have simply been overlooked. * Fix number increment/decrement bug (that's one of those). Closes: #497349. * Lintian cleanups: * Switch to dh_prep. * Have package scripts call 'set -e'. * Add new lintian override regarding the (unused) dist/ltconfig.

    2008-08-25 - Jan Christoph Nordholz <hesso@pool.math.tu-berlin.de> nvi (1.81.6-4) unstable; urgency=high * Safeguard the creation of /var/tmp/vi.recover in the postinst against symlink attacks. Thanks Raphael Geissert for spotting this. RC security bug, urgency bumped. Closes: #496462.

    2008-07-09 - Jan Christoph Nordholz <hesso@pool.math.tu-berlin.de> nvi (1.81.6-3) unstable; urgency=low * Convert debian/copyright to proposed format and supplement it.

    2008-06-22 - Jan Christoph Nordholz <hesso@pool.math.tu-berlin.de> nvi (1.81.6-2) unstable; urgency=low * The '-F' option is no longer supported - adapt the manpage accordingly. Closes: #381995. * Finally fix the trailing tab+'set number' -> SEGV issue. Closes: #330782.