mpi-default-dev - Standard MPI development files (metapackage)

Distribution: Ubuntu 12.04 LTS (Precise Pangolin)
Repository: Ubuntu Universe amd64
Package name: mpi-default-dev
Package version: 1.0.1
Package release:
Package architecture: amd64
Package type: deb
Installed size: 31 B
Download size: 3.56 KB
Official Mirror:
This metapackage depends on the development files of the recommended MPI implementation for each platform, currently Open MPI on all of the platforms where it exists, and MPICH2 on the others. The package which this depends on has alternatives links for the shared libraries libmpi and libmpi++, and for compilers mpicc, mpic++/mpicxx/mpiCC, mpif77 and mpi90 and their manpages.




    Source package: mpi-defaults

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install mpi-default-dev deb package:
      # sudo apt-get install mpi-default-dev


    • /usr/share/doc/mpi-default-dev/README.Debian
    • /usr/share/doc/mpi-default-dev/changelog.gz
    • /usr/share/doc/mpi-default-dev/copyright
    • /usr/share/mpi-default-dev/debian_defaults


    2011-12-04 - Sylvestre Ledru <> mpi-defaults (1.0.1) unstable; urgency=low * Team upload * Upload in unstable * Switch to dpkg-source 3.0 (quilt) format * Update of the description (clearly state that it is a metapackage) * Update of the target in debian/rules to match the policy * Fix the lintian warning debian-rules-missing-recommended-target

    2011-05-19 - Manuel Prinz <> mpi-defaults (1.0) experimental; urgency=low * Use MPICH2 instead of LAM on architectures not supported by Open MPI. Closes: #555653. * Updated list of architectures where Open MPI is supported. Closes: #553701, #627239. * Dropped MPICH from the list of known MPI implementations. * Updated Standards-Version to 3.9.2. No changes needed. * Added ${misc:Depends} to Depends fields to fix lintian warning. * Removed versioned Build-Dependency of debhelper.

    2009-07-01 - Manuel Prinz <> mpi-defaults (0.6) unstable; urgency=low * Set Standards-Version to 3.8.2. No changes needed. * Added lpia to list of supported architectures, defaulting to Open MPI. Thanks to Steven Susbauer! (Closes: #532643)

    2009-07-01 - Manuel Prinz <> mpi-defaults (0.5) unstable; urgency=low * Fix folding in Build-Depends, backslashes are no longer allowed by dpkg-dev (>= 1.15.3), fixing FTBFS with newer versions. Thanks to Cyril Brulebois for the patch! (Closes: #535230)

    2009-03-23 - Manuel Prinz <> mpi-defaults (0.4) unstable; urgency=low * debian/control: Fixed broken dependency line. (Closes: #520141) * Made LAM default on Sparc.

    2009-03-14 - Manuel Prinz <> mpi-defaults (0.3) unstable; urgency=low [ Manuel Prinz ] * Added myself to Uploaders. * Changed section of mpi-default-bin to "net" (Closes: #509782) * Mode LAM default on alpha, since Open MPI still has build issues. * Made Open MPI default on GNU/kFreeBSD. Thanks to Petr Salinger for the patch! (Closes: #513219) * Provide /usr/share/mpi-defaults-dev/debian_defaults with architecture- dependent information about the default MPI implementation, so build scripts can use it. Thanks to Daniel Leidert for the suggestion! (Closes: #518653)

    2008-12-05 - Adam C. Powell, IV <> mpi-defaults (0.2) unstable; urgency=low * Changed debhelper build-dep version to harmonize with compat. * Added binary-indep target (D'oh!).

    2008-11-20 - Adam C. Powell, IV <> mpi-defaults (0.1) unstable; urgency=low * First cut package for setting default MPI dependencies.